Dell Unity: SP-Panik nach mehr als 240 Tagen Verfügbarkeit

摘要: Der Dell Unity XT 480-, 680- oder 880-Storage-Prozessor (SP) kann nach mehr als 240 Tagen in Betrieb sein. (von Dell korrigierbar)

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Bei Dell Unity XT 480, 680 oder 880 SP kann ein Fehler auftreten, nachdem sie 240 Tage lang betriebsbereit waren.  Bei anderen Dell Unity-Systemen kann das Problem nach mehr als 240 Tagen (d. h. nach mehr als 730 Tagen) auftreten.

UDoctor kann eine Warnmeldung für jede Codeversion unter 5.3 erzeugen, bei der der SP seit mehr als 240 Tagen ausgeführt wird, und diese Warnmeldung verweist auf diesen KB-Artikel.  Siehe Wissensdatenbank-Artikel Dell Unity: Kritische Warnmeldung 640003 tritt in OE 5.2.1 oder höher auf, wobei die Fehlerkorrektur für die Verfügbarkeit des Storage-Prozessors (SP) bereits angewendet wurde, um weitere Details zur UDoctor-Warnung zu erhalten.

原因

Ein SP-Fehler kann aufgrund einer Ganzzahlüberlaufberechnung auftreten, die dazu führt, dass ein 64-Bit-Ergebnis in einer 32-Bit-Variablen gespeichert wird. 

Das Problem tritt höchstwahrscheinlich auf einem Unity XT 480-, 680- oder 880-Array mit den Unity OE-Versionen 5.1.0.0.5.394 bis 5.2.0.0.5.173 auf. Dies ist auf Änderungen innerhalb dieses Codes und der in diesen Modellen verwendeten SP-Hardware zurückzuführen und darauf, wie der Code mit dieser Hardware interagiert.

 

HINWEIS: Bei älteren Codes und Unity-Modellen tritt dieses Problem mit geringererWahrscheinlichkeit auf, aber es ist nicht unmöglich, dass das Problem bei älterem Code oder älteren Unity-Modellen auftritt, insbesondere wenn der SP länger als 240 Tage ausgeführt wird (d. h. mehr als 730 Tage).

 

HINWEIS: Die durchschnittliche Anzahl der Tage, bevor ein SP-Neustart durch dieses Problem ausgelöst wird, beträgt 275 bis 300 Tage. Der Neustart des SP kann vor 275 Tagen erfolgen, ist aber weniger wahrscheinlich. Der Storage-Prozessor wird aufgrund dieses Problems erst nach 240 Tagen neu gestartet.

解析度

Lösung:
Die Korrektur ist in Unity OE Version 5.2.1.0.5.013 und höher verfügbar.  Dell rät jedoch davon ab, ein Upgrade auf diese Codeversion durchzuführen.  Dell empfiehlt Kunden dringend, ein Upgrade auf den neuesten verfügbaren Code durchzuführen oder, falls der neueste Code nicht der "Zielcode" ist, zumindest ein Upgrade auf den Zielcode durchzuführen.

Außerdem identifiziert das UDoctor-Dienstprogramm dieses Problem auf Unity OE Version 5.3 und niedriger. Dies liegt daran, dass die Korrektur in Version 5.3 bereitgestellt wurde, aber auf 5.2.1 und höheren Code zurückportiert wurde.  Die UDoctor-Warnmeldung wird auf dem zurückportierten Code ausgelöst.


Problemumgehung:

Starten Sie den SP proaktiv alle 240 Tage neu, um einen SP-Fehler zu vermeiden. Anweisungen zum Neustart eines SP finden Sie in folgendem Artikel: Unity: Anleitung zum Neustart eines Storage-Prozessors (vom Nutzer korrigierbar).

Kunden können eine "uptime" Befehl, indem Sie über SSH eine Verbindung zu einem Array herstellen und das Servicekonto verwenden, um die SP-Laufzeit abzurufen.

Das folgende Beispiel zeigt, dass die Betriebszeit 31 Tage beträgt.

04:30:01 service@xxx spa:~/user# uptime
04:30am  up 31 days  3:41,  2 users,  load average: 29.21, 29.45, 29.51

 


 

Die UDoctor-Warnmeldung wird alle drei Tage aktualisiert, es sei denn, die obige Korrektur oder Problemumgehung wird implementiert.  Dell Technologies empfiehlt Kunden, den Fix oder Workaround zu implementieren (falls sie den Fix nicht implementieren können). Wenn jedoch weder die Korrektur noch der Workaround implementiert werden können, kann die UDoctor-Überprüfung nur für diese Bedingung deaktiviert werden.

Melden Sie sich über SSH beim primären SP an und geben Sie den folgenden Befehl aus:

svc_udoctor --jobs --disable CalculateUptime

Dadurch wird verhindert, dass die Prüfung alle drei Tage ausgeführt wird.

受影響的產品

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
文章屬性
文章編號: 000200921
文章類型: Solution
上次修改時間: 12 12月 2025
版本:  24
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。