Dell Unity:240日以上稼働した後のSPパニック

摘要: Dell Unity XT 480、680、または880ストレージ プロセッサー(SP)が240日を超えて稼働した後にパニックが発生することがあります。(Dell Correctable)

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Dell Unity XT 480、680、880 SPが240日間稼働した後にパニックが発生することがあります。  その他のDell Unityシステムでは、240日以上(つまり730日以上)後に問題が発生する可能性があります。

UDoctorは、SPが240日を超えて実行されている場合、5.3より前のコード バージョンでアラートを生成する可能性があり、そのアラートはこのKB記事を参照します。  KB記事「 Dell Unity: 重要アラート640003 OE 5.2.1以降で発生しており、ストレージ プロセッサー(SP)のアップタイム パニック修正がすでに適用されている場合、UDoctorアラートの詳細を参照してください。

原因

SPパニックは、整数オーバーフロー計算により、64ビットの結果が32ビット変数に格納されることが原因で発生する可能性があります。

この問題は、Unity OEバージョン5.1.0.0.5.394から5.2.0.0.5.173を実行しているUnity XT 480、680、または880アレイで発生する 可能性が最も高い です。これは、そのコードとそれらのモデルで使用されるSPハードウェア内の変更、およびコードがそのハードウェアとどのように相互作用するかが原因です。

 

メモ: 古いコードやUnityモデルではこの問題が発生する可能性は低くなりますが、特にSPが240日以上(つまり730日以上)実行されている場合に、古いコードや古いUnityモデルで問題が発生する可能性は低くありません。

 

メモ: この問題によってSPの再起動がトリガーされるまでの平均日数は275日から300日です。SP の再起動は 275日より前に発生する可能性がありますが、その可能性は低くなります。この問題が原因でストレージ プロセッサーが再起動するのは、240日より前には発生しません。

解析度

修正:
この修正は、Unity OEバージョン5.2.1.0.5.013以降で使用できます。  ただし、このコード バージョンへのアップグレードは推奨されません。  Dellでは、入手可能な最新のコードにアップグレードするか、少なくとも最新のコードが「ターゲット」コードでない場合はターゲット コードにアップグレードすることを強くお勧めします。

また、UDoctorユーティリティーは、Unity OEバージョン5.3以前でこの問題を特定します。これは、修正がバージョン5.3で 提供され ましたが、5.2.1以降のコードに バックポート されたためです。  UDoctorアラートは 、バックポートされた コードでトリガーされます。


対処方法:

SPパニックを回避するために、SPを240日ごとにプロアクティブに再起動します。SPを再起動する手順については、次の記事を参照してください。「Unity:ストレージ プロセッサーを再起動する方法(ユーザー修正可能)

お客様は、 "uptime" コマンドを実行して、SSHを使用してアレイに接続し、サービス アカウントを使用してSPランタイムを取得します。

次の例では、稼働時間が31日であることを示しています。

04:30:01 service@xxx spa:~/user# uptime
04:30am  up 31 days  3:41,  2 users,  load average: 29.21, 29.45, 29.51

 


 

UDoctorアラートは、上記の修正または回避策が実装されていない限り、3日ごとに更新されます。  デル・テクノロジーズでは、お客様が修正または回避策を実装することをお勧めします(修正を実装できない場合)。ただし、修正または回避策を実装できない場合は、 この状態 のみのUDoctorチェックを無効にすることができます。

SSHを使用してプライマリーSPにログインし、次のコマンドを発行します。

svc_udoctor --jobs --disable CalculateUptime

これにより、3日ごとのチェック実行が無効になります。

受影響的產品

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
文章屬性
文章編號: 000200921
文章類型: Solution
上次修改時間: 12 12月 2025
版本:  24
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。