PowerFlex:SDS 裝置在 AWS 或 Azure 雲端環境中重新開機後遺失資料
摘要: SDS 裝置在重新開機後遺失資料。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
在一個 SDS 上硬作業系統重啟後,該主機上的 SDS 裝置不再有資料或簽名。
PowerFlex 系統在雲端環境、AWS 或 Azure 中執行。
症狀
- SDS 節點硬重啟(有意與否)
- 在重新開機時,SDS 裝置仍然存在,但所有裝置在重新加入 PowerFlex 系統時都會移至錯誤狀態。
- SDS 中重新啟動的設備處於錯誤狀態,無法清除。
- 裝置缺少 SDS 裝置簽名(來自 sds trc 紀錄):
2023/02/27 06:42:26.477168 7f669822fdb0:mosAsyncIO_OpenFileEx:00465: Opened file /dev/nvme2n1 (fd 18), maxInflight 8, maxIoSize 1310720, ptr 0x7f66a8003bf0 2023/02/27 06:42:26.477313 7f669822fdb0:phyDevMap_ThreadedReadDevId:00732: ERROR: Read device ID of /dev/nvme2n1 took 10 milli rc=INVALID_DEVICE_HEADER_SIGNATURE
如果 CloudLink 正在執行,裝置會顯示為「未加密」和「data_raw」(從 svmd.log)
{"mpoint":"/dev/nvme0n1","status":"unencrypted","label":"","type":"data_raw","size":1788, "drives" : ["/dev/nvme0n1"]},"9486948577258625":
{"mpoint":"/dev/nvme1n1","status":"unencrypted","label":"","type":"data_raw","size":1788, "drives" : ["/dev/nvme1n1"]},"9486948577268625":
{"mpoint":"/dev/nvme2n1","status":"unencrypted","label":"","type":"data_raw","size":1788, "drives" : ["/dev/nvme2n1"]},"9486948577278625":
{"mpoint":"/dev/nvme3n1","status":"unencrypted","label":"","type":"data_raw","size":1788, "drives" : ["/dev/nvme3n1"]},"9486948577288625":
{"mpoint":"/dev/nvme4n1","status":"unencrypted","label":"","type":"data_raw","size":1788, "drives" : ["/dev/nvme4n1"]},"9486948577298625":
{"mpoint":"/dev/nvme5n1","status":"unencrypted","label":"","type":"data_raw","size":1788, "drives" : ["/dev/nvme5n1"]},"9491767425":
影響
資料降級,且後續僅有一個節點重新開機時將進行重新建置
如果多個節點同時或接近同時重新開機,則可能發生資料遺失。
原因
在 AWS 或 Azure 等雲端環境中執行時,如果為基礎硬體選擇的裝置是 NVME,這些裝置會暫時發生,且資料會在硬重啟或實體關機時消失。從 此處的 AWS 文件:
- NVMe SSD 驅動器是臨時存儲。當實例電源關閉時,將根據 AWS 設計擦除 NVMe 設備。
- NVMe 固態硬碟用於極致性能。在計畫內或無預警關機後,資料不會持續存在。建議使用備份解決方案。
解析度
如文件中所述,此為設計運作方式。確保有備份解決方案。
受影響的版本
PowerFlex 3.6.x,PowerFlex
4.x
受影響的產品
PowerFlex rack, ScaleIO文章屬性
文章編號: 000211253
文章類型: Solution
上次修改時間: 06 1月 2026
版本: 1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。