Windows Server:フォワーダーの設定が不適切なため、Active DirectoryドメインでDNS解決が遅延または失敗する
摘要: Active Directoryドメイン内のDNSサーバーでフォワーダーが正しく構成されていない場合、名前解決が失敗したり、予想以上に時間がかかったりすることがあります。これは通常、外部DNS名の解決にのみ影響します。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
外部DNSの名前解決が完全に失敗するか、予想以上に時間がかかります。内部解決にはフォワーダーが使用されないため、内部の名前解決は問題なく機能する可能性があります。
原因
ドメイン内のDNSサーバーでフォワーダーが正しく構成されていないと、外部DNS解決の遅延や障害が発生する可能性があります。具体的には、 ドメイン内の DNS サーバー (ほとんどの場合、そのドメインのドメイン コントローラー (DC) である) は、相互に転送するように構成しないでください。ドメイン 外の DNSサーバーのみをフォワーダーとして使用する必要があります。
フォワーダーに適した候補は次のとおりです。
- 覚えやすいIPアドレス(
1.1.1.1, 8.8.8.8, 9.9.9.9,その他) - インターネット サービス プロバイダー(ISP)が提供するDNSサーバー
他のパブリックDNSサーバーも同様に適切な応答を提供する場合があります
また、外部の名前解決にフォワーダーの代わりにルートヒントを使用することもできます。この記事は、フォワーダーが使用されている場合にのみ適用されます。
解析度
この問題に対処するには、次の手順を実行します。
- DNSサーバーで、DNSマネージャー コンソールを起動します。
- コンソールの左ペインで、サーバーを右クリックし、 プロパティを選択します。サーバーを右クリックする前に、左クリックする必要がある場合があります。
- フォワーダータブをクリックし、フォワーダーのリストを確認します。
- フォワーダーのリストに内部DNSサーバーが含まれている場合は、[ Edit ]ボタンをクリックして、リストからすべての内部サーバーを削除します。必要な追加のフォワーダーを指定します。
- OKをクリックしてEdit Forwardersウィンドウを閉じ、再度Propertiesウィンドウを閉じます。
- サーバーを右クリックし、[ キャッシュのクリア]を選択します。これは、外部名前解決の応答時間を正確に評価するために必要です。
ドメイン内のすべてのDNSサーバーで、上記の手順を繰り返します。フォワーダーはサーバーごとに構成され、サーバー間でレプリケートされません。
これらの手順を実行した後、 nslookup コマンドを実行して名前解決をテストし、応答時間を確認します。
其他資訊
いくつかの例外を除き、DNS が適切に構成されていれば、ドメイン内のすべての DNS サーバーのゾーン内に同じレコードがあります。これは、ゾーン転送または Active Directory レプリケーションが機能していると仮定して、標準ゾーンと Active Directory 統合ゾーンのどちらを使用するかに関係なく当てはまります。したがって、1 つの DNS サーバーがクエリに応答できない場合、ドメイン内の他の DNS サーバーも応答できません。これらのサーバー間でクエリを転送すると、名前解決プロセスが遅くなるだけです。
受影響的產品
Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022產品
PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450
, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640
...
文章屬性
文章編號: 000212612
文章類型: Solution
上次修改時間: 10 12月 2024
版本: 5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。