Connectrix B-Serien: Når du har oppgradert til Fabric OS 9.1.1c, returnerer innebygde kommandoer med «fosexec»-kommandoen en feil

摘要: Etter at du har oppgradert til Fabric OS (FOS) 9.1.1c, kan du ikke kjøre innebygde kommandoer fra UNIX- eller Linux-serveren til svitsjen med «fosexec»-kommandoene.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Miljø:

Fabric OS 9.1.1c

Problem:

Utdataene viser feil når du kjører en innebygd kommando fra en UNIX- eller Linux-server. Kommandoen slutter å reagere når du undersøker en annen logisk svitsj-FID på samme kabinett. Eksempel:

[hosttest@VM1234 ~]$
[hosttest@VM1234 ~]$ ssh aa.bb.cc.dd fosexec --fid 44 -cmd 'firmwareshow'
hosttest@aa.bb.cc.dd's password:
/bin/stty: 'standard input': Inappropriate ioctl for device
/bin/stty: 'standard input': Inappropriate ioctl for device
/etc/ssh_inline_profile: line 25: FUNCNEST: readonly variable
Appl     Primary/Secondary Versions
------------------------------------------
FOS      v9.1.1c
         v9.1.1c
---------------------------------------------------

"firmwareshow" on FID 44:

[hosttest@VM3198 ~]$

原因

Dette problemet ble oppdaget under intern testing. En endring i feilen ble funnet da oppgraderingen til FOS 9.2.0a ble utført.

Feil:
[hosttest@VM3198 ~]$
[hosttest@VM3198 ~]$ ssh aa.bb.cc.dd fosexec --fid 44 -cmd 'firmwareshow'
hosttest@10.60.23.25's password:
/bin/stty: 'standard input': Inappropriate ioctl for device
/bin/stty: 'standard input': Inappropriate ioctl for device
Appl     Primary/Secondary Versions
------------------------------------------
FOS      v9.2.0a
         v9.2.0a
---------------------------------------------------

"firmwareshow" on FID 44:

[hosttest@VM3198 ~]$

解析度

Løsning:

Oppgrader til Fabric OS 9.2.0b eller nyere.

Omgåelse av problemet:

Kjør kommandoene direkte på svitsjen.

其他資訊

Se Brocade-DEFEKT FOS-850854 og DEFEKT FOS-844429 som drøfter dette problemet.

受影響的產品

Connectrix, Connectrix B-Series

產品

Connectrix B-Series Fabric OS 9.X
文章屬性
文章編號: 000218645
文章類型: Solution
上次修改時間: 29 7月 2025
版本:  4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。