Data Domain: REST API-fel – REST-tjänsten är inaktiverad
摘要: Så här löser du REST-API-fel (Application Programming Interface).
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
Identifierade symptom
Följande symtom har identifierats:
- Fel i Cyber Recovery-gränssnittet
- Felmeddelandet "Fick HTTP-svarskod 400 felaktig begäran vid inloggning till DD med REST API" felmeddelande
- Felmeddelandet "REST-tjänsten är inaktiverad" visas när du försöker ansluta till DD på port 3009 med hjälp av webbläsare eller API-anrop
原因
Grundorsak till problemet
Rotorsaken till problemet är att REST-tjänsten är inaktiverad på Data Domain.
Detta kan bero på att webbtjänsten är inaktiverad, vilket krävs för att REST-tjänsten ska kunna köras.
- REST-tjänsten är inaktiverad
- Webbtjänsten är inaktiverad
Relevanta felmeddelanden
Relevanta felmeddelanden som anger orsaken till problemet är:
- "REST-tjänsten är inaktiverad"
- "Fick HTTP-svarskod 400 felaktig begäran vid inloggning till DD med REST API"
# Relevant command to check the status of the web service $ adminaccess enable web-service
解析度
Aktivera REST-tjänsten på Data Domain
För att lösa REST API-felet måste REST-tjänsten på Data Domain köras. Detta kan uppnås genom att aktivera webbtjänsten.
# Enable web service using the following CLI command adminaccess enable web-service
När webbtjänsten har aktiverats körs REST-tjänsten, vilket gör att REST API-anrop kan slutföras.
Verifiera lösningen
Kontrollera att problemet har lösts genom att försöka ansluta till Data Domain på port 3009 med hjälp av ett webbläsar- eller API-anrop. Om REST-tjänsten körs visas inte felet "REST-tjänsten är inaktiverad".
Viktigt! Om problemet kvarstår kontaktar du Dells support.
受影響的產品
PowerProtect Cyber Recovery, DD OS文章屬性
文章編號: 000353903
文章類型: Solution
上次修改時間: 07 8月 2025
版本: 1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。