Data Domain: Błąd interfejsu API REST — usługa REST jest wyłączona

摘要: Rozwiązywanie problemów z błędami interfejsu programowania aplikacji (API) REST.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Zidentyfikowane objawy

Zidentyfikowano następujące objawy:

  • Błędy interfejsu użytkownika Cyber Recovery
    • Komunikat o błędzie "Got HTTP response code 400 Bad Request while login to DD using REST API"
  • Komunikat o błędzie "Usługa REST jest wyłączona" podczas próby połączenia z DD na porcie 3009 przy użyciu wywołania przeglądarki lub interfejsu API

原因

Główna przyczyna problemu

Główną przyczyną problemu jest wyłączenie usługi REST w Data Domain.

Może to być spowodowane wyłączeniem usługi internetowej, która jest wymagana do uruchomienia usługi REST.

  • Usługa REST jest wyłączona
  • Usługa internetowa jest wyłączona

Odpowiednie komunikaty o błędach

Odpowiednie komunikaty o błędzie, które wskazują przyczynę problemu, obejmują:

  • "Usługa REST jest wyłączona"
  • "Got HTTP response code 400 Bad Request while login to DD using REST API"
# Relevant command to check the status of the web service
$ adminaccess enable web-service

解析度

Włączanie usługi REST w Data Domain

Aby rozwiązać błąd interfejsu API REST, usługa REST w Data Domain musi być uruchomiona. Można to osiągnąć, włączając usługę internetową.

# Enable web service using the following CLI command
adminaccess enable web-service

Po włączeniu usługi internetowej usługa REST jest uruchamiana, umożliwiając pomyślne zakończenie wywołań interfejsu API REST.

Weryfikacja rozwiązania

Aby sprawdzić, czy problem został rozwiązany, spróbuj połączyć się z Data Domain na porcie 3009 przy użyciu wywołania przeglądarki lub interfejsu API. Jeśli usługa REST jest uruchomiona, błąd "Usługa REST jest wyłączona" nie jest wyświetlany.

Przestroga: Jeśli problemy nadal występują, skontaktuj się z działem pomocy technicznej firmy Dell.

受影響的產品

PowerProtect Cyber Recovery, DD OS
文章屬性
文章編號: 000353903
文章類型: Solution
上次修改時間: 07 8月 2025
版本:  1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。