SC:如何準備更新 Dell Compellent Storage Center Operating System

摘要: 本教學課程說明如何準備更新 Dell Compellent 儲存系統或 SCOS。請遵循以下步驟,以確保順利執行更新程序。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

注意:首先,請務必聯絡 Dell Storage 技術支援團隊協助更新。開啟線上要求或致電執行此操作。

本教學課程說明如何準備更新 Dell Compellent Storage Center Operating System (或 S.C.O.S.)。您可以遵循這些步驟,以確保順利執行更新程序。

 

準備 SCOS 更新所需遵循的步驟:

  1. 檢閱儲存裝置的最佳實務
  2. 執行容錯移轉測試
  3. 安裝 Enterprise Manager DSM
  4. 更新防火牆規則
  5. 環境資訊檢查清單
     


步驟 1:檢閱最佳實務文件

重要:您可以在 SC Series 技術白皮書與影片中找到最佳實務文件。建議您檢閱本文和其中的連結,以確保組態為最佳狀態,然後再進行更新。本文包含適用於 SC Series 的所有技術文件,包括 Dell Compellent 儲存裝置。如需作業系統特定資訊,請從下列作業系統中選取:ESXi 6.X、IBM AIX、Linux/UNIX、Windows 

準備時,請注意「在 SAN 上開機」、「Live Volume」和「複製」設定,如上述最佳實務文件所述。
 

但是,要檢查的最重要事項是 (根據作業系統而定): 

VMware - 使用 VMware vSphere 的 Dell Compellent 最佳實務。

Recommended Multipathing: Round Robin
Login Time-Out/Login Retry Count: Set to 5
LUN Queue Depth: 255
Jumbo Frames: 9000 

 
Windows - Windows Server 最佳實務/Microsoft Multipath I/O (MPIO) 最佳實務。
  1. 建議的多路徑:循環制
  2. 請確保下列 Registry Editor 位置的逾時值設定為 60:
    H_Key_Local_Machine\System\CurrentControlSet\Services\Disk
  3. Microsoft MPIO 建議的 Registry Editor 位置中的設定:
    H_Key_Local_Machine/System/CurrentControlSet/Services/mpio/Parameters

                   

Recommended Multipathing: Round Robin
Login Time-Out/Login Retry Count: Set to 5
LUN Queue Depth: 255
Jumbo Frames: 9000 


建議的 iSCSI 啟動器設定 

在此 Registry Editor 位置進行以下設定:
H_Key_Local_Machine\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CEBFC1-08002BE10318}\\Parameters
SCSI 啟動器設定欄位設定:
 
MaxRequestHoldTime 90
LinkDownTime 45
Jumbo Frames: 9000
回到頁首

 


步驟 2:容錯移轉測試


為什麼在 SCOS 更新之前進行容錯移轉測試很重要?

容錯移轉測試會驗證主機的最佳實務組態是否正確,以便主機能夠在更新期間保持連接至其儲存裝置。如果組態不正確,容錯移轉測試的影響會比升級期間的影響短。

如何執行容錯移轉測試?

  1. 如果先前未完成容錯移轉測試,請務必在規劃的維護時段完成此作業。
     
  2. 讓系統進入維護模式 (如此可避免在控制器重新開機時產生不必要的支援事件)。 
    • 在管理介面中,以滑鼠右鍵按一下要進入維護模式的系統。
    • 按一下下列選項編輯設定 > 一般 > 作業模式 > 維護 (下圖 1 (僅限英文版))

      Compellent 維護模式
      圖 1:將「作業模式」變更為「維護模式」。

       
  3. 按順序為控制器執行重新開機 (一個在另一個之後)
    • 在管理介面中,以滑鼠右鍵按一下要執行容錯移轉測試的系統
    • 按一下下列選項動作 > 系統 > 關機/重新開機
    • 在新的功能表視窗中,選擇重新開機,並為「重新開機選項」選擇依順序重新開機。(下圖 2 (僅限英文版))

      Compellent 控制器重新啟動選項
      圖 2:「依順序重新開機」的重新開機選項。

       
  4. 在容錯移轉測試期間監控主機,並確保其能夠存取磁碟區
    1. 連線至主機,並檢查磁碟區是否保持連線,以及資料是否可存取
    2. 在 DSM 中,連線能力狀態應為部分。如果連線能力狀態為中斷,則必須檢閱最佳實務組態。(下圖 3 (僅限英文版))

      Compellent 主機連線能力狀態
      圖 3:主機上的連線能力狀態
       
  5. 測試完成後,請務必使系統回到生產模式
    • 在管理介面中,以滑鼠右鍵按一下要進入生產模式的系統
    • 按一下下列選項編輯設定 > 一般 > 作業模式 > 生產 (上圖 1 (僅限英文版))
  6. 在控制器完成重新開機後重新平衡連接埠
訊息 1/2 - 由於容錯移轉,此 Storage Center 的控制器連接埠目前不平衡

如果在測試期間遇到問題,請記下症狀或錯誤訊息,然後聯絡技術支援。

返回頂端


 


步驟 3:Enterprise Manager/Dell Storage Manager (DSM) 安裝


如果正在使用外部資料庫,建議您在升級 DSM 之前備份 SQL 資料庫或拍攝虛擬機器的快照。如果使用 Data Collector 中的內部資料庫,則不需要備份。
如何備份 SQL 資料庫:

  1. 前往 SQL Server 並開啟 SQL Server Management Studio
  2. 按一下「新查詢」並執行命令
    Backup Database YourDatabaseName TO Disk='D:\yourbackupfilename.bak'

      (下圖 4,僅限英文版)

SQL 備份
圖 4:SQL 資料庫備份命令和結果


如何安裝 DSM:

重要:請勿解除安裝舊版的 Enterprise Manager (安裝 DSM 會升級 Enterprise Manager)

Dell 支援網站驅動程式與下載類別底下,下載最新版本的 Dell Storage Manager (DSM)。
與 DSM 相關的所有文件也可在說明文件章節中找到。

請先啟動 Data Collector 精靈。精靈會安裝 visual C++ 並重新開機。

  • 系統重新開機後,如果 Data Collector 未自動重新啟動,請將其重新啟動
  • 重新開機可能需要最多 10 分鐘的時間
  • 到達登入畫面後,安裝即已完成
  • 關閉 Data Collector

然後安裝 DSM Client。

  • 啟動 DSM CLIENT 設定
  • Visual c++ 也會安裝,並且系統會完成重新開機
  • Visual++ 安裝完成後,它將繼續安裝 DSM
  • 安裝可能會持續 20 分鐘,然後才會到達登入畫面
  • 登入畫面出現後,表示安裝已完成

這些設定會自動注入到新的 DSM 中。

返回頂端


 


步驟 4:防火牆規則更新

如需最新的防火牆需求集,請參閱文章# 000130450 -  Dell Compellent:Storage Center 啟用 Dell SupportAssist Enterprise 和安全主控台的網路需求。



回到頁首


 


步驟 5:環境資訊檢查清單

支援團隊可能會就您的環境提出以下問題:
  • 下列應用程式是否正在使用中?
    • CompCU (例如,用於為 Nagios 監控設定 SNMP 設陷)
    • Bridgehead 備份裝置
    • Replay Manager 或 Application Protection Manager
    • Dell Storage API PowerShell SDK
    • RestAPI
    • SRA (VMware)
    • Dell Storage vSphere Web Client 附掛程式
    • Dell Storage Integration Tools for VMware (DSITV)
    • 授權 FC FLUID Cache (以使用 SSD 作為快取)
  • 是否有連接至 Dell Compellent 的 NAS FluidFS?
  • 您的主機是否符合最低驅動程式和韌體需求?


回到頁首

 

原因

不適用

解析度

不適用

受影響的產品

Entry Level & Midrange, Compellent (SC, SCv & FS Series)
文章屬性
文章編號: 000134713
文章類型: Solution
上次修改時間: 03 9月 2025
版本:  9
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。