AppSync : Échec de la récupération SQL en raison d’un ou plusieurs fichiers ldf (log SQL) manquants.
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
AppSync ne parvient pas à restaurer une base de données SQL sur un hôte de montage.
Les événements Service Plan affichent le message suivant :
Unable to recover database MyDB on the instance MySQL-QA. See the host plug-in log, application event log, and the SQL Server error log for details.
Le journal des événements d’application du système d’exploitation affiche le message suivant :
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnostiquez et corrigez l’erreur du système d’exploitation, puis relancez l’opération.
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnostiquez et corrigez l’erreur du système d’exploitation, puis relancez l’opération.
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnostiquez et corrigez l’erreur du système d’exploitation, puis relancez l’opération.
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnostiquez et corrigez l’erreur du système d’exploitation, puis relancez l’opération.
Le journal du plug-in AppSync sur l’hôte de montage affiche le message suivant :
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
原因
Bug logiciel
解析度
Ce problème est résolu dans AppSync 4.0.
其他資訊
Les notes de mise à jour d’AppSync 4.0 n’indiquent pas que le problème a été corrigé dans la section correspondante, mais il a bien été confirmé que le correctif est disponible dans la version AppSync 4.0
Installez la mise à niveau AppSync 4.0 pour résoudre ce problème.
Installez la mise à niveau AppSync 4.0 pour résoudre ce problème.
受影響的產品
AppSync產品
AppSync文章屬性
文章編號: 000170225
文章類型: Solution
上次修改時間: 18 9月 2026
版本: 8
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。