AppSync:ldf(sql log)ファイルがないためにSQLリカバリーに失敗します。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
AppSyncが、マウント ホスト上のSQLデータベースのリカバリーに失敗します。
サービス プランのイベントは次のように表示されます。
Unable to recover database MyDB on the instance MySQL-QA. See the host plug-in log, application event log, and the SQL Server error log for details.
オペレーティング システムのアプリケーション イベント ログに次のように表示されます。
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnose and correct the operating system error, and retry the operation.
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnose and correct the operating system error, and retry the operation.
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnose and correct the operating system error, and retry the operation.
Error Mountx 17207 MSSQLSERVER FileMgr::StartLogFiles:
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnose and correct the operating system error, and retry the operation.
マウント ホスト上のAppSyncプラグインのログに次のように表示されます。
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.
原因
ソフトウェア バグ
解析度
AppSync 4.0では、この問題は解決されています。
其他資訊
AppSync 4.0リリース ノートでは、「修正済み」のセクションでこの問題は解決済みになっていませんが、この修正はAppSync 4.0で対処済みであることが確認されています。
この問題を解決するには、AppSync 4.0にアップグレードしてください。
この問題を解決するには、AppSync 4.0にアップグレードしてください。
受影響的產品
AppSync產品
AppSync文章屬性
文章編號: 000170225
文章類型: Solution
上次修改時間: 18 9月 2026
版本: 8
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。