Isilon:Gen6:節點無法開機,並出現錯誤訊息「無法執行硬體升級的收據更新」

摘要: Gen6 節點無法在 PSI 組態階段開機,顯示「isi_upgrade_hardware」指令檔正在執行,接著出現錯誤訊息「無法執行硬體升級的收據更新」。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Gen6 節點無法在 PSI 組態階段開機,顯示「isi_upgrade_hardware」指令檔正在執行,接著出現錯誤訊息「無法執行硬體升級的收據更新」。這可能在叢集上最近的硬體升級 (例如 DIMM、NIC 或 SSD 升級) 後發生。開機順序的結尾將類似以下內容 (重要行以粗體標示):

2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]:硬體升級
的更新收據2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]:更新收據 - cmd:/usr/bin/isi_hwtools/isi_json_update/mfg/psi/receipt.json FE 002-iFEIO-10GBE-B-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]:更新收據 - cmd:/usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json MODEL_BOM,運算 001-infinity-compute-low-64GB-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]:更新收據 - cmd:/usr/bin/isi_hwtools/isi_json_update /mfg/psi/receipt.json MODEL_BOM,SSD 001-infinity-SSD-1x400gb-psi
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]:下一步 - 執行isi_upgrade_hardware --node --validate
2021-05-05T11:55:15-07:00 isi_upgrade_hardware[470]:自動更換識別已啟用
2021-05-05T11:56:16-07:00 isi_upgrade_hardware[470]:無法剖析硬體升級 gconfig:(在 hwupgrade.upgrades 中升級):沒有此類檔案或目錄
2021-05-05T11:56:16-07:00 Python:[520] 警告:IPMI 錯誤:rv=0, CC=0xc1。IPMB 位址:0x20 cmd:0xbf,netfn:0x30,cmd 資料:[01]
2021-05-05T11:56:16-07:00 Python:[520] 警告:CC[c1]:命令無效。
2021-05-05T11:56:16-07:00 Python:bootstrap_get_minbay:minbay 1、主要 0、次要 0、等待 0 秒 6458 USEC
無法執行硬體升級
的收據更新 為避免發生 DL 情況,請立即聯絡 Dell EMC 客戶支援:

原因

最近的硬體升級是使用舊版的 isi_hardware_upgrade 腳本運行的,其中包含導致進程清理階段無法成功完成的錯誤。/root/node_hardware_upgrade.json 檔案遺留在節點上。這會導致節點認為它仍在進行硬體升級,並正在嘗試執行流程中的下一步,此步驟會失敗,因為實際上沒有仍在進行中的升級。這將阻止節點完成啟動。

解析度

1.首先,與客戶和任何在場的現場人員確認目前實際上並沒有進行硬體升級。然後,從復原 shell 功能表中,按下 1 以進入復原 shell,然後按下 Enter 以載入預設 shell。

2.檢查節點上是否有下列檔案:/root/node_hardware_upgrade.json

3.如果找到,請重新命名此檔案,然後重新開機節點:

# mv /root/node_hardware_upgrade.json /root/node_hardware_upgrade.json.bak
# reboot


4。如果節點成功開機,建議搶先檢查叢集中的其他節點是否存在此檔案,如果找到此檔案,請將其移除:
# isi_for_array -s 'mv /root/node_hardware_upgrade.json /root/node_hardware_upgrade.json.bak'

受影響的產品

Isilon, Isilon A200
文章屬性
文章編號: 000191007
文章類型: Solution
上次修改時間: 26 8月 2022
版本:  2
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。