AppSync: Terugzetten vanaf AppSync snapshot kan mislukken als gevolg van een time-out

摘要: Terugzetten van AppSync snapshot naar de productiehost is mislukt vanwege een time-out.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Een herstelbewerking van de AppSync GUI loopt uiteindelijk vast en mislukt als gevolg van een time-outfout.

De AppSync gebeurtenissen geven het onderstaande weer:
  
<DATE & TIME>, Restore Copy, fc520a7d-b08d-41ab-9878-70608fdf8ea6, ORCL_000093, <hostyname>, AppSync kan een of alle van de volgende storagebestandssystemen niet herstellen: /my/path/data99,
 
In serverlogboeken wordt de time-out weergegeven:
 
<DATE & TIME> INFO [EJB default - 8] [com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> finished restore/refresh volumes on XIO Array <DATE &TIME> INFO [EJB default - 8] [com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> klaar met het herstellen/vernieuwen van volumes op XIO Array <DATE &TIME> WARN [EJB default - 8] [com.arjuna.ats.arjuna] [AppSync_Server] [] ARJUNA012077: Abort called on already aborted atom action 0:ffffff0a25bf41:-396b7557:61391564:19b548 <DATE &TIME> ERROR [EJB default - 8] [org.jboss.as.ejb3.invocation] [AppSync_Server] [] WFLYEJB0034: EJB-aanroeping mislukt op component RestoreXIOSnapshotCommandBean voor methode openbare booleaanse com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean.restorePhasePIT(com.emc.archway.context.ExecutionContext, java.util.Set, booleaanse): javax.ejb.EJBTransactionRolledbackException: javax.transaction.RollbackException: WFLYEJB0447: Transaction 'Local transaction (delegate=TransactionImple < ac, BasicAction: 0:ffff0a25bf41:-396b7557:61391564:19b548 status: ActionStatus.ABORTED >, owner=Local transaction context for provider JBoss JTA transaction provider)' was al teruggedraaid op org.jboss.as.ejb3@17.0.1.Final/org.jboss.as.ejb3.tx.CMTTxInterceptor.endTransaction(CMTTxInterceptor.java:114)

 

原因

Er zijn een aantal snapshots betrokken bij de herstelbewerking die vertraging/time-out veroorzaakte. Mogelijke oorzaak niet vastgesteld, maar dit kan een prestatie-/traagheidsprobleem zijn op bronnen zoals array en host.

解析度

Door de waarde van de transactie-time-out aan te passen, kan AppSync tijdens de herstelbewerking geen time-out uitvoeren.
  
  1. Ga naar C:\EMC\AppSync\jboss\standalone\configuration\standalone.xml.
  2. Wijzig de waarde van standaardwaarde 300 naar nieuwe waarde 2400 seconden - <coordinator-environment default-timeout=2400
  3. Stop alle services (EMC AppSync Datastore en EMC AppSync Security service)
  4. Start de services (EMC AppSync Datastore Service, EMC AppSync Security Service, EMC AppSync serverservice)

受影響的產品

AppSync
文章屬性
文章編號: 000191827
文章類型: Solution
上次修改時間: 11 5月 2026
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。