PowerMax:VMware SRM 保護群組中出現重複裝置 ID 的 SRDF SRA 組態問題

摘要: 如果兩個不同陣列配對中的兩個陣列裝置具有相同的裝置 ID (例如 0003A),VMware 便無法正確識別一對保護群組。例如,陣列 A 和陣列 B 與陣列 C 成對,也可能與陣列 D 成對。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

此示例取自實驗室:

如果兩個不同陣列對中的兩個陣列設備具有相同的設備 ID,例如 0003A,VMware 無法正確識別一對保護群組。

例如,三個陣列(儘管它們可能有四個)、A、B 和 C。他們在 A 和 C 以及 B 和 C 之間配置了對。碰巧的是,每個對的一組在 A 和 C 上具有相同的設備 ID:

從 A 到 C 的配對: 0003A - 001B8
從 B 到 C 的配對: 0003A - 000F0

這些是獨立的配對,SRDF SRA 識別它們沒有問題,如下所示:
陣列對

為每個對集創建保護組后,流覽每個保護組並查找對。其中一個保護組將無法識別設備對,或者有時顯示錯誤的配對。

保護群組 

原因

問題的原因似乎是 VMware SRM 程式碼。它仰賴裝置 ID,而非使用在每個陣列上唯一的 NAA (或 WWN)。

解析度

目前的因應措施是將 Storage vMotion 將其中一個有問題的配對移至新的配對,然後移除該配對,不再在 VMware 中使用。通過仔細規劃,可以避免重複的ID。

VMware 已確認此問題,修正將於 SRM 8.6 提供。目前的發行日期為 2022 年 6 月,但可能會有變更。他們表示之後可以提供向後連接至 SRM 8.4/8.5。

受影響的產品

Symmetrix, VMAX, PowerMax 2000, PowerMax 2500, PowerMax 8000, PowerMax 8500, VMware
文章屬性
文章編號: 000195144
文章類型: Solution
上次修改時間: 13 3月 2025
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。