IDPA:韌體工作失敗錯誤:等待時發生 9029 逾時
摘要: 本文說明在 ESXi 檢查階段執行 PowerProtect-DP-Rapid-Upgrade-Checker (RUCK) 錯誤時可能出現的問題的解決方案。 此錯誤與節點事件服務或 IRAC 服務模組或 iDRAC 狀態有關。韌體工作失敗,並顯示錯誤:等待內部工作完成時發生 9029 逾時
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
RUCK 工具在firmware_readiness檢查期間失敗,並顯示下列訊息:
Firmware pre-upgrade checks failed. Firmware task failed with error: [9029] timeout while waiting for an internal task to complete. Check Node Event service/IRAC Service Module/IDRAC status and check logs for details.
原因
ESXi 上的 iDRAC Service Module (ISM) 狀態可能會達到下列狀態:
- 非使用中
- 使用中 (未執行中)
- 使用中 (執行中)
前兩種狀態 (非使用中、使用中 (未執行中)) 會使升級無法啟動。
ISM 服務在 iDRAC 中顯示為「未執行」,如下所示:
- 非使用中
- 使用中 (未執行中)
- 使用中 (執行中)
前兩種狀態 (非使用中、使用中 (未執行中)) 會使升級無法啟動。
ISM 服務在 iDRAC 中顯示為「未執行」,如下所示:
解析度
若要將 ISM 服務變更為「執行中」狀態,請遵循以下準則:
1- 以根身分登入報告錯誤的 ESXi。
2- 執行 /etc/init.d/dcism-netmon-watchdog status 若要確認 ESXi 主機上 ISM 服務的狀態:
root@idpahypervisor1:~> /etc/init.d/dcism-netmon-watchdog status
iSM is active (not running)
3- 在 iDRAC 設定/設定標籤中檢查 iDRAC 使用者介面,以確認「未執行」狀態:
如果兩個服務都處於「未執行」狀態,請繼續執行下列行動計畫。不需要任何停機時間:
1.以 root 身分登入 ESXi 伺服器。
2.停止 ESXi 上的 dcism 服務:
/etc/init.d/dcism-netmon-watchdog stop
- 停止 sfcdb-watchdog 服務:
/etc/init.d/sfcbd-watchdog stop
- 重新啟動 iDRAC:
/opt/dell/DellPTAgent/tools/ipmitool_static mc reset cold
- 等待 iDRAC 再次啟動。
- 啟動服務 sfcg-watchdog:
/etc/init.d/sfcbd-watchdog start
- 等待幾分鐘,然後檢查 ESXi 和 iDRAC 上的 ISM 服務狀態。應顯示為「running」:
其他資訊
若要取得 iDRAC IP,可透過以下命令取得:
esxcli hardware ipmi bmc get
若是預設 iDRAC IP,請建立通道:
PowerProtect DP 系列裝置和 IDPA:DP4400 如何從 ESXi 透過 SSH 通道存取 iDRAC UI
或者,使用 ssh 至 iDRAC 並執行命令:
racadm get idrac.servicemodule
下列文章說明相同錯誤的其他案例:
PowerProtect DP 系列和 IDPA:快速升級 ChecKer 公用程式顯示「firmware_readiness」檢查失敗
受影響的產品
PowerProtect Data Protection Appliance文章屬性
文章編號: 000222521
文章類型: Solution
上次修改時間: 17 2月 2025
版本: 2
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。