PowerEdge XE9680L 和 XE9685L:GPU 韌體更新可能會失敗,並重新啟動虛擬電源
摘要: 在 Dell PowerEdge XE9680L 和 XE9685L 系統上更新 GPU 韌體後,需要實體重新啟動電源才能成功完成更新。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
更新 GPU 韌體後,系統需要重新啟動電源才能正確完成韌體更新。
執行實體電源週期可讓您成功更新 GPU 韌體。
但是,若使用 Dell Technologies InfoHub 文章中建議的虛擬重新啟動電源方法,可能會導致下列元件韌體更新失敗 (如圖 [1] 所示):
HGX_FW_NVSwitch_0 HGX_FW_NVSwitch_1 HGX_FW_NVLinkManagementNIC_0

圖 1:虛擬電源重新啟動後,GPU 韌體更新失敗 (仍維持先前版本)。
原因
工程團隊已察覺此問題,並已確認這是由於 iDRAC 的限制所導致。
解析度
為確保遠端韌體更新成功,建議使用替代的 Redfish API 方法,執行虛擬 AC 電源重新啟動。如果韌體更新已失敗,請先重新嘗試更新。成功後,繼續使用替代的 Redfish API 方法,以完成虛擬電源週期。
因應措施:
方法 1:重新啟動 AC 電源
為避免韌體更新相關問題,客戶可在完成更新程序後,執行實體 AC 電源重新啟動。如需詳細說明,請參閱下列文章:PowerEdge:如何重設與排空我的伺服器
電力方法 2:紅魚
第 1 步:若要關閉系統電源,請使用 Redfish API,如下所示:
POST /redfish/v1/Systems/System.Embedded.1/Actions/ComputerSystem.Reset
{
"ResetType":"GracefulShutdown"
}
(Reference Site: Dell Technologies Developer)
步驟 2:使用下方的 Redfish API 執行虛擬電源週期執行:
POST /redfish/v1/Chassis/System.Embedded.1/Actions/Oem/DellOemChassis.ExtendedReset
{
"ResetType":"PowerCycle"
"FinalPowerState": "On"
}
(Reference Site: Dell Technologies Developer)
範例:
使用 Linux CLI
執行 Redfish 命令 使用下列命令從 Linux 命令列執行 Redfish 作業。執行前,請務必將下列變數替換為您的 iDRAC 值:
${username} = iDRAC username
${pwd} = iDRAC password
${IDRAC_IP} = IP address of your system's iDRAC interface 順利關機
$ curl -k -u ${username}:${pwd} \ -X POST https://${IDRAC_IP}/redfish/v1/Systems/System.Embedded.1/Actions/ComputerSystem.Reset \ -H "Content-Type: application/json" \ -d '{"ResetType":"GracefulShutdown"}'開啟電源
$ curl -k -u ${username}:${pwd} \ -X POST https://${IDRAC_IP}/redfish/v1/Chassis/System.Embedded.1/Actions/Oem/DellOemChassis.ExtendedReset \ -H "Content-Type: application/json" \ -d '{"ResetType": "PowerCycle", "FinalPowerState": "On"}'
方法 3:BIOS
- GPU 韌體更新已完成。
- 手動 重新開機 至 F2 功能表。
- 在系統 BIOS> 中設定 FullPowerCycle 其他設定>電源週期要求
- 保存設定,然後 離開 F2 功能表 ,方法是直接重新啟動系統,而不是在顯示視窗中按 一下「是」, 如圖 2 所示。
- 系統電源開啟,並顯示 BIOS POST 畫面。
- 系統因 vAC 而關機。

圖 2:快顯視窗以確認結束。
受影響的產品
PowerEdge XE9680L, PowerEdge XE9685L文章屬性
文章編號: 000355295
文章類型: Solution
上次修改時間: 17 3月 2026
版本: 3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。