OpenManage Enterprise:與自訂角色建立關聯時,目錄使用者的首次登入會失敗
摘要: 與自訂角色關聯時,Dell OpenManage Enterprise (OME) 目錄使用者首次登入會失敗。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
首次登入裝置時,將目錄群組與自訂使用者角色建立關聯後,登入會失敗,並出現未知錯誤。
第一次嘗試以目錄使用者身分登入時,會顯示一般登入失敗:

可使用 tomcat/application.log 顯示下列錯誤:
[ERROR] 2025-06-10 15:06:27.286 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-25] LdapAuthDetails - Throwing
io.vertx.pgclient.PgException: { "message": "null value in column \"base_entity_id\" violates not-null constraint", "severity": "ERROR", "code": "23502", "detail": "Failing row contains (201, null, 24901).", "where": "SQL statement \"
使用正常使用者帳戶成功登入 Web UI 時,會顯示以下錯誤:
An Error occurred while retrieving the user details

原因
使用者-實體合併存儲過程會導致級聯刪除,在首次登錄期間取消使用者許可權的關聯。
解析度
OpenManage Enterprise 4.6.0 版的下一個版本預計會修正儲存程序,預計在 2026 年 1 月推出。此修復可確保在首次登錄期間不會發生級聯使用者實體刪除。在此之前,請使用下列因應措施:
- 從 OpenManage Enterprise 刪除受影響的使用者和群組。
- 刪除受影響的自訂角色。
- 重新建立自訂角色、重新匯入 AD 群組,並與重新建立自訂角色做關聯。
- 使用目錄使用者登入,以確保重新建立的自訂角色正常運作。
受影響的產品
Dell EMC OpenManage Enterprise文章屬性
文章編號: 000382453
文章類型: Solution
上次修改時間: 18 3月 2026
版本: 3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。