Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell PowerEdge FN I/O Module Configuration Guide 9.10(0.0)

PDF

Sample Configurations

The following configurations are examples for enabling IPv6 IS-IS. These examples are not comprehensive directions. They are intended to give you some guidance with typical configurations.

  • NOTE: Only one IS-IS process can run on the router, even if both IPv4 and IPv6 routing is being used.

You can copy and paste from these examples to your CLI. To support your own IP addresses, interfaces, names, and so on, be sure that you make the necessary changes.

  • NOTE: Whenever you make IS-IS configuration changes, clear the IS-IS process (re-started) using the clear isis command. The clear isis command must include the tag for the ISIS process. The following example shows the response from the router:
    Dell#clear isis *
                                              % ISIS not enabled.
                                              Dell#clear isis 9999 *
                                           
You can configure IPv6 IS-IS routes in one of the following three different methods:
  • Congruent Topology — You must configure both IPv4 and IPv6 addresses on the interface. Enable the ip router isis and ipv6 router isis commands on the interface. Enable the wide-metrics parameter in router isis configuration mode.
  • Multi-topology — You must configure the IPv6 address. Configuring the IPv4 address is optional. You must enable the ipv6 router isis command on the interface. If you configure IPv4, also enable the router isis command. In router isis configuration mode, enable multi-topology under address-family ipv6 unicast.
  • Multi-topology Transition — You must configure the IPv6 address. Configuring the IPv4 address is optional. You must enable the ipv6 router isis command on the interface. If you configure IPv4, also enable the ip router isis command. In router isis configuration mode, enable multi-topology transition under address-family ipv6 unicast.
Figure 1. IPv6 IS-IS Sample Topography Illustration of an IPv6 sample topography.

IS-IS Sample Configuration — Router 1

The following is a sample configuration for enabling IPv6 IS-IS.

R1(conf)#interface Loopback 0
                                 R1(conf-if-lo-0)#ip address 192.168.1.1/24
                                 R1(conf-if-lo-0)#ipv6 address 2001:db8:9999:1::/48
                                 
                                 R1(conf-if-lo-0)#ip router isis 9999
                                 R1(conf-if-lo-0)#no shutdown
                                 R1(conf-if-lo-0)#router isis 9999
                                 R1(conf-router_isis)#is-type level-1
                                 R1(conf-router_isis)#net FF.F101.0002.0C00.1111.00
                                 R1(conf-router_isis)#ipv6 route 2001:db8:9999:2::/128 2001:db8:1021:2::
                                 R1(conf)#ipv6 route 2001:db8:9999:3::/128 2001:db8:1022:3::
                                 R1(conf)#ip route 192.168.1.2/32 10.0.12.2
                                 R1(conf)#ip route 192.168.1.3/32 10.0.13.3
                                 
                                 R1(conf)#interface GigabitEthernet 1/21
                                 R1(conf-if-gi-1/21)#ip address 10.0.12.1/24
                                 R1(conf-if-gi-1/21)#ipv6 address 2001:db8:1022:1::/48
                                 R1(conf-if-gi-1/21)#isis circuit-type level-1
                                 R1(conf-if-gi-1/21)#isis network point-to-point
                                 R1(conf-if-gi-1/21)#ip router isis 9999
                                 R1(conf-if-gi-1/21)#no shutdown
                                 
                                 R1(conf-if-gi-1/21)#interface GigabitEthernet 1/34
                                 R1(conf-if-gi-1/34)# ip address 10.0.13.1/24
                                 R1(conf-if-gi-1/34)#ipv6 address 2001:db8:1021:1::/48
                                 R1(conf-if-gi-1/34)#ip router isis 9999
                                 R1(conf-if-gi-1/34)#no shutdown
                                 R1(conf-if-gi-1/34)#end
                                 
                                 R1#show ip route
                                 Codes: C - connected, S - static, R - RIP,
                                 B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
                                 O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
                                 N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
                                 E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
                                 L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
                                 > - non-active route, + - summary route
                                 
                                 Gateway of last resort is not set
                                 Destination    Gateway             Dist/Metric Last Change
                                 -----------      -------             ----------- -----------
                                 C 10.0.12.0/24   Direct, Gi 1/21        0/0   00:00:57
                                 C 192.168.1.0/24 Direct, Lo 0           0/0   00:04:19
                                 S 192.168.1.2/32 via 10.0.12.2, Gi 1/21 1/0   00:00:57
                                 
                                 R1#show isis data
                                 IS-IS Level-1 Link State Database
                                 LSPID LSP Seq Num       LSP Checksum LSP Holdtime ATT/P/OL
                                 R1.00-00  * 0x0000000F 0x3A6C   1176              0/0/0
                                 R1.02-00  * 0x00000002 0x90AC   1076              0/0/0
                                 R1.03-00  * 0x00000002 0x67C3   1176              0/0/0
                                 R2.00-00  0x0000000C   0x5418   1183              0/0/0
                                 R2.00-00  0x00000009   0x1E39   1183              0/0/0
                                 R2.03-00  0x00000002   0x589D   1180              0/0/0
                                 
                                 R1#show isis neigh
                                 System Id Interface State Type Priority Uptime   Circuit Id
                                 R2        Gi 1/21   Up    L1   64       00:02:28 R1.02
                                 R2        Gi 1/34   Up    L1   64       00:00:42 R1.03
                                 R1#
                                 
                              
R2(conf)#interface Loopback 0
                                 R2(conf-if-lo-0)#ip address 192.168.1.1/24
                                 R2(conf-if-lo-0)#ipv6 address 2001:db8:9999:1::/48
                                 R2(conf-if-lo-0)#ip router isis 9999
                                 R2(conf-if-lo-0)#no shutdown
                                 
                                 R2(conf-if-lo-0)#router isis 9999
                                 R2(conf-router_isis)#int gi 2/11
                                 R2(conf-if-gi-2/11)#ip address 10.0.12.2/24
                                 R2(conf-if-gi-2/11)#ipv6 address 2001:db8:9999:2::/48
                                 R2(conf-if-gi-2/11)#ip router isis 9999
                                 R2(conf-if-gi-2/11)#isis network point-to-point
                                 R2(conf-if-gi-2/11)#no shutdown
                                 R2(conf-if-gi-2/11)#int gi 2/31
                                 R2(conf-if-gi-2/31)#ip address 10.0.23.2/24
                                 R2(conf-if-gi-2/31)#ipv6 address 2001:db8:1021:2::/48
                                 R2(conf-if-gi-2/31)#ip router isis 9999
                                 R2(conf-if-gi-2/31)#isis network point-to-point
                                 R2(conf-if-gi-2/31)#no shutdown
                                 R2(conf-if-gi-2/31)#router isis 9999
                                 
                                 R2(conf-router_isis)#ipv6 route 2001:db8:9999:1::/128 2001:db8:1021:1::
                                 R2(conf)#ipv6 route 2001:db8:9999:3::/128 2001:db8:1023:3::
                                 R2(conf)#ip route 192.168.1.1/32 10.0.12.1
                                 R2(conf)#ip route 192.168.1.3/32 10.0.23.3
                                 R2(conf)#ex
                                 
                                 R2#show ip route
                                 Codes: C - connected, S - static, R - RIP,
                                 B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
                                 O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
                                 N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
                                 E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
                                 L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
                                 > - non-active route, + - summary route
                                 
                                 Gateway of last resort is 172.21.212.1 to network 0.0.0.0
                                 
                                 Destination     Gateway              Dist/Metric Last Change
                                 -----------        -------              -----------   -----------
                                 *S 0.0.0.0/0       via 172.21.212.1, Vl 212 1/0    00:59:50
                                 C  10.0.12.0/24    Direct, Gi 2/11          0/0    00:02:25
                                 C  10.0.23.0/24    Direct, Gi 2/31          0/0    00:01:53
                                 C  10.10.92.0/24   Direct, Po 4             0/0    6d9h
                                 C  172.21.212.0/24 Direct, Vl 212           0/0    2d20h
                                 C  192.168.1.0/24  Direct, Lo 0             0/0    01:11:48
                                 S  192.168.1.1/32  via 10.0.12.1, Gi 2/11   1/0    00:00:51
                                 S  192.168.1.3/32  via 10.0.23.3, Gi 2/31   1/0    00:00:39
                                 
                                 R2#show isis data
                                 IS-IS Level-1 Link State Database
                                 LSPID    LSP Seq Num   LSP Checksum LSP Holdtime ATT/P/OL
                                 R2.00-00 * 0x0000000F  0x0174       1088         0/0/0
                                 
                                 R2#show isis neigh
                                 A2#show isis neigh
                                 System Id Interface State Type Priority Uptime    Circuit Id
                                 R1        Gi 2/11 Up      L1   64       00:02:19  A102.02
                                 R3        Gi 2/31 Up      L1   64       00:00:25  A121.03
                                 R2#
                                 
                              
R3(conf)#interface Loopback 0
                                 R3(conf-if-lo-0)#ip address 192.168.1.3/24
                                 R3(conf-if-lo-0)#ipv6 address 2001:db8:9999:3::/48
                                 R3(conf-if-lo-0)#ip router isis 9999
                                 R3(conf-if-lo-0)#no shutdown
                                 R3(conf-if-lo-0)#router isis 9999
                                 R3(conf-router_isis)#net FF.F101.0002.0C00.1133.00
                                 R3(conf-router_isis)#ipv6 route 2001:db8:9999:1::/128 2001:db8:1022:1::
                                 R3(conf)#ipv6 route 2001:db8:9999:2::/128 2001:db8:1023:2::
                                 R3(conf)#ip route 192.168.1.1/32 10.0.13.1
                                 R
                                 3(conf)#interface GigabitEthernet 3/14
                                 R3(conf-if-gi-3/14)#ip address 10.0.13.3/24
                                 R3(conf-if-gi-3/14)#ipv6 address 2001:db8:1022:3::/48
                                 R3(conf-if-gi-3/14)#ip router isis 9999
                                 R3(conf-if-gi-3/14)#isis circuit-type level-1
                                 R3(conf-if-gi-3/14)#isis network point-to-point
                                 R3(conf-if-gi-3/14)#no shutdown
                                 R3(conf-if-gi-3/14)#interface GigabitEthernet 3/21
                                 R3(conf-if-gi-3/21)#ip address 10.0.23.3/24
                                 R3(conf-if-gi-3/21)#ipv6 address 2001:db8:1023:3::/48
                                 R3(conf-if-gi-3/21)#ip router isis 9999
                                 R3(conf-if-gi-3/21)#isis circuit-type level-1
                                 R3(conf-if-gi-3/21)#isis network point-to-point
                                 R3(conf-if-gi-3/21)#no shutdown
                                 R3(conf-if-gi-3/21)#end
                                 
                                 R3#show ip route
                                 Codes: C - connected, S - static, R - RIP,
                                 B - BGP, IN - internal BGP, EX - external BGP,LO - Locally Originated,
                                 O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1,
                                 N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
                                 E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1,
                                 L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default,
                                 > - non-active route, + - summary route
                                 Gateway of last resort is not set
                                 Destination   Gateway          Dist/Metric Last Change
                                 -----------      -------            ----------- -----------
                                 C 10.0.13.0/24   Direct, Gi 3/14         0/0    00:00:10
                                 C 10.0.23.0/24   Direct, Gi 3/21         0/0    00:00:03
                                 C 192.168.1.0/24 Direct, Lo 0            0/0    00:00:32
                                 S 192.168.1.1/32 via 10.0.13.1, Gi 3/14  1/0    00:00:10
                                 S 192.168.1.2/32 via 10.0.23.2, Gi 3/21  1/0    00:00:03
                                 
                                 R2#show isis data
                                 IS-IS Level-1 Link State Database
                                 LSPID      LSP Seq Num   LSP Checksum LSP Holdtime ATT/P/OL
                                 R1.00-00   0x0000000F    0x3A6C      1198        0/0/0
                                 R1.03-00   0x00000001    0x69C2      1193        0/0/0
                                 R2.00-00   * 0x00000007  0x51F6      1198        0/0/0
                                 R2.03-00   * 0x00000001  0x5A9C      1200        0/0/0
                                 
                                 IS-IS Level-2 Link State Database
                                 LSPID    LSP Seq Num    LSP Checksum LSP Holdtime ATT/P/OL
                                 R3.00-00 * 0x00000008   0xC09C       1199         0/0/0
                                 R3#show isis neigh
                                 System Id Interface State Type Priority Uptime  Circuit Id
                                 R1        Gi 3/14   Init  L1   64      00:00:02  R1.03
                                 R2        Gi 3/21   Up    L1   64      00:00:14  A101.03
                                 
                              

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\