Lrave
1 Nickel

MIO Board died

Jump to solution

Hi All,


Is there anything what can be done to get a control over fans in Alienware Aurora if MIO board died? I tried rivatuner and speed fan but both of them seems do not work...

I did clean re installation of Win7 from resource disk and of course my MIO board bricked.... bad luck that I didnt know about issue with MIO board --> re installation of system before...................

FX doesnt work, thermal controller readings are off. I tried already everything what I could find on this forum. MIO board light is on but can not be installed. In hardware manager I got this "unknown device" thing.... I just really gave up trying to fix it..now I just want it to be quite - since I reinstalled system computer is terribly loud....

0 Kudos
16 Replies
Moderator
Moderator

RE: MIO Board died

Jump to solution

You can try with HWinfo to control the fans, however my recommendation will be to get a new MIO board in a third party like eBay or Amazon. 

Alienware-Milena
Dell | Alienware Technical Support Alienware Arena
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
Lrave
1 Nickel

RE: MIO Board died

Jump to solution

I tried Hwinfo and bunch of other software but I can not control fans... As example in HWinfo there should be an icon for fan controlling if my system would support fan control but is not there.....

With SpeedFan when I am changing fan speed value nothing happens....

Actually, there is something what concerns me a lot...why DELL after selling product with broken drivers(resource disk) do nothing to replace this broken by them components? Looking around I realize how common problem it is, when people after reinstalling their systems loosing MIO board just because not correct drivers in resource disk sold by DELL.................

0 Kudos
Cass-Ole
4 Ruthenium

RE: MIO Board died

Jump to solution

Edit: *** I originally took this member's post / issue here to mean Windows 7 was reinstalled, & the mio board might need to be reset afterwards. I typed my response here at the crack of dawn, it wasn't until later I re-read his issue closer & learned the mio board may have bricked by using the recovery/utility disk. Some members here in the past used the term 'Windows recovery disk', meaning the reinstall dvd, which is what I thought happened here. *** Recently a member dug up an old thread, I have pulled out a juicy tid-bit from it:

"We appear to have solved the problems that were related to the MAIN I/O board. I’m posting here in case others find the solution helpful. We ran the FX Tester program

  • C:\Program Files\Alienware\CommandCenter\AlienwareAlienFXTester.exe

It reported that a firmware update had not gone to completion when a previous tech had uninstalled the old Command Center and installed the latest one. After uninstalling and reinstalling the Command Center again my situation appears to be back to normal. The Command Center now communicates with the MAIN I/O board. The fans, lights and venting  work as designed. The Automated Bay Cover Door which runs off the Main I/O board is working properly as well. The AlienwareAlienFXTester.exe program revealed the problem quickly".

The gist of it? CmndCntr was installed, the mio board's firmware didn't stick, his AlienFx spazzed out . didn't work, AlienFx Tester revealed a failed firmware instance, the cure was to reinstall CmndCntr correctly. Dell_ChrisM has been heard to say CmndCntr may need to be reinstalled 'several times' before the firmware sticks ... the member above of course had a working mio board, which acted like it didn't work. This is opposed to a bricked mio, which is what this member's post today is looking more and more like, where an mio board may or will brick if you attempt to install an older firmware version (older CmndCntr version) over a newer version (if you back-flash the mio with old firmware it might brick it, where perhaps the oldest version of all is found on our original recovery/utility cd). The AlienFx tester had information to reveal about a working mio, so try it using the method described above.


- Original Unedited Response -

On some versions of Command Center .netframework 4 must be installed 1st, others need .net 4.5

One version of CmndCntr (2.08.11) at least needs .net 3.5 (& then possibly .net 4 also) 

On your mio you have a lil bitty lime green plastic piece called a jumper. As a last resort, and perhaps for the very 1st time in this forum we might get you to try a 'jumper reset' & see if it brings your mio back from the dead. I'll discuss it last. Right now, let's be optimistic & go w/a theory your mio isnt really dead, but it is playing possum. I hope so. It might be dead, we'll do what we can, if all tests fail, it's probably kapoot.

Is your mio led lit up with computer on? That's a sign of life. This is what I would do 1st, it will involve the power-drain or power dissipation reset. PDR. We'll use it alot 'cause it might work. PDR is like CPR ... 1 2 3 push ... 1 2 3 breathe, do it a lot, see if it helps.

It is possible your unknown device is mio. If you're in device mngr you could 'update driver', be online while you do so just in case. After driver installs, if it will, see what happened. Nothing? Power down.

PDR: unplug machine, press/hold top power on button down for, oh, 30-60 seconds (then let machine rest for 3-5 minutes is another suggestion), plug in, pwr on, see what happens. Lights come on I hope.

Nothing? Pwr down. Do another PDR & remove your case panel; find your mio's usb cable & connector, disconnect it either from the mio itself or trace it to the mthrbrd & disconnect that end of the mio usb cable.

Listen: plug in, pwr up, Windows desktop, now shut down. Unplug machine, PDR. Now. Plug your usb cable back in:

  • we've just tried to do a start-up session without the mio hooked up
  • we want to shut down, & now try a new session with it hooked in

Usb plugged in, plug in machine, power up: did windows detect your mio & can you look carefully to see if it installs drivers, & did your alienFx lights come back on?

If not, device mngr, try again to reinstall drivers if you have an unknown device there, see what happens.

Phase Two: if you have an Aurora R4 (R3), at the bios screen, perform an ePSA pre-boot diagnostics assessment, see if your mio is detected in there or if you have a usb device unrecognized/error. I will be honest, I have an R4, I have run the ePSA, but did so with a working mio. I do not know what ePSA will think about a bunk mio, or report to you.

Utility Partition: if you have an R1 R2 (R3) (R4), & you have your utilty partition, get into it / run it, it should have a Diagnostics option. None of my Aliens have a Utility Partition, I haven't kept up on this.

The DIAG software & test described below might be on your utility partition. 'Enter Diagnostics' etc.

{ edit: in a follow-up Post later below I have photos & a discussion on Diagnostics & ePSA}

Last, if you have created a 32bit Diagnostics CD or on bootable flashdrive, time to run it, or time to create one & run it. Boot into it, look for your mio. If it is shown there on your screen? Test it. If it is absent? It means your MIO is MIA:

  • the sign of a bunk mio is if it is absent from the main screens of a 32bit DIAG test
  • in ePSA perhaps it is a 'usb device error'

You can shut down I suppose, recheck your usb cable, boot back into DIAG, but the mio will communicate over the usb, so, if it is absent from the DIAG test the usb ability is lost, it is dead or it is sick. Try a new usb header, no good?, try your 3rd usb header.

No good? Plan Z. A Jumper Reset.

Perform a PDR 1st. Yes, keep trying that, nothing left to lose.

We will do the jumper reset three times if need be ok?

Place your Green jumper on the pole/pin next to where it sits right now. Power up, shut down. Do a PDR. Take green jumper off, place it to the side, power up, power down. PDR. Place green jumper back on its original poles, power up ... see if it fixed it.

At any point in the scenario of switch poles / remove jumper entirely / replace on original poles, you're looking for signs of life from your mio. Looking to see if Windows installs drivers or your lights come on.

No? Do another Reset series: this time, disconnect your usb cable 1st. Everytime you power down, do a PDR.

Switch pole, pwr up / pwr down. PDR, remove jumper, pwr up / pwr down. PDR. Replace jumper. Pwr up / pwr down. PDR. Reconnect USB, pwr up. Now does it work? Check device mngr, try to install drivers on an unknown USB device if Windows did not.

No good? One last chance I think. Do one more Reset series: switch poles, remove jumper, replace on original poles, PDR inbetween power downs.

If that doesn't do it? Retry your ePSA / 32bit DIAG test. No?

Barring some other malfunction, your mio probably bricked & went bad, time for a replacement.

A replacement will in the least let you know if your mthrbrd is ok & not part of a 'usb malfunction' etc, & if the new one works you'll be back in b'ness.

If nothing helped today, fans are driving you nuts huh. Disconnect the hard drive fan & the pci-e fan from mio. If your radiator fan is loud - full blast, reach at your mthrbrd for the mio's cpu_fan connector, top right, remove it, now see if your system radiator fan will reach, if so, plug it in, let the mthrbrd monitor your cpu-temp & fan speed, keep your side panel off for cooling, wait for your replacement.

The mio connects to the mthrbrd cpu_fan header, so if you are forced to disconnect it to insert your radiator fan, remember later on to reconnect your mio fan connector that is now laying to the side, if you swap your mio out. Gimme a sec to dig up some links, I can check back in about 10 hours from now, be gone all day, ok? Also, wait for other member input in case I left out other tools or trouble-shooting help, before writing your mio off as DOA. Good luck

0 Kudos
Cass-Ole
4 Ruthenium

RE: MIO Board died

Jump to solution

Alienware Desktops MIO (Master Input/Output) Troubleshooting and Policy

http://en.community.dell.com/owners-club/alienware/f/3746/t/19599408

3681.MIOR3R4.JPG

green jumper in the middle

0 Kudos
Cass-Ole
4 Ruthenium

RE: MIO Board died

Jump to solution

Here are links to Diagnostics Tests: A discussion with photos is now in a follow-up post, below

For Aurora R1 R2 (maybe R3, if not see below):

Alienware 32-Bit Diagnostics (GUI for Alienware projects), v.A1382A0/A0494, A1382A0

read the page carefully in order to create your bootable media if you need to run a 32bit DIAG

For Aurora R4 (& possibly R3). Hit F12, enter Diagnostics:

Alienware™ Enhanced Systems Diagnostics (ePSA)

0 Kudos
Cass-Ole
4 Ruthenium

RE: MIO Board died

Jump to solution

If you got lucky & your lights came back on, your fans should have settled down as another sign of life from your mio.

A mio can work independent of CmndCntr, all day long in fact, but if no lights & loud fans, you can try CmndCntr installs/reinstalls/repairs if need be if you're at your wit's end. Who knows if it'll work.

Hopefully what you do today using the methods I described can bring yours back from the dead.

0 Kudos
Lrave
1 Nickel

RE: MIO Board died

Jump to solution

I got netframework 4.5

I also reinstalled Command Center several times, trying old version from resource disk and new one from net.

I followed all suggested steps.

After disconnecting USB cable I got steady yellow light from my alienware button from the front of the case panel. Few times when doing PDR I got yellow light flash for about half of the second and that's all ....

In device manager when I try to reinstall driver windows says that device is already installed . If I uninstall it Windows still can not install it without errors. (Installation failed)

I run PSA+ during initial test I got error message: UUTUSBTM DEVICE INITIALIZATION FAILURE, USER MUST REATTACH UNIT TO ROOT 1, or something similar....

When I run specific tests for all hardware parts within PSA+ I got no error messages.

The red light on MIO Board is still working.

AlienFX tester shows very not helpful message:"It seems there is some problem with the AlienFX board."
Playing with jumper switch didn't bring any effect.

I disconnected MIO Board fan and its a bit better in terms of noise...

0 Kudos
purple397
3 Silver

RE: MIO Board died

Jump to solution

Some other threads have talked about cleaning out, ungunking, and replacing coolant that is used.   How old is your machine?    You still might have to replace the MIO board.   Other folks reported fan problems from an update, and also spoke of updating the BIOS.   I dunno, I do not have an Aurora, just thought I might mention some of the other threads.  

0 Kudos
Cass-Ole
4 Ruthenium

RE: MIO Board died

Jump to solution

There is a new post right above me where a forum member points toward the signs of a faulty cooler; I assume he's noticed your loud fans & pointed out alternative explanations. I realize you used your Resource DVD of course, and it may have everything to do with this. But. It would *** if you had a pre-existing condition, so you reinstalled Windows at an attempt at a fix, now your mio bricked, & we never solve the original issue. Was there one? Why did you feel it was time to reinstall Windows, & did your AlienFx & system basically run ok & work right before you reinstalled it the other day? If so, good.


Below, on my Area-51 I booted into & ran my 32-bit DIAG, burned to a CD:

1781.PTDC0001 - Copy.JPG

Click 'Test System' > next screen > click Custom Test. Why? I'm looking for my MIO

32b 1.JPG

PTDC0005 - Copy.JPG_7142.PTDC0006PTDC0004 - Copy.JPG

Above: a working MIO on DIAG. Below photo: I disconnect the usb cable, to replicate a dead mio?

32b 3.jpg

disappears; there's no usb connection detected between it & my mthrbrd. A bunk mio may look similar

If on your Aurora R1 R2 - R3 maybe - (my R4 can not run this test, it has its own ePSA shown later)you can get to this test by whatever means, or have already performed this test, you're looking for your MIO board to show up, be accounted for on your hardware list.

Tesla often says to test your mio or run DIAG outside of windows, this is the test (or ePSA) he usually means:

  • I disconnected my hard drive 1st, so Windows has nothing to do with this test
  • I have booted into it using my 32-bit DIAG CD but you can also make a bootable flashdrive  

He is also heard to say, if your mio is not on this screen? It might be temporarily bunk or plain bricked. An MIO can not be working if it is MIA from this basic hardware device testing list. If an mio is on the list & 'acting funny' - or my AlienFx / CmndCntr seem odd - yes, I can test it now, but it has to be on the list 1st.

An MIO MIA from this list? Again, all that is left basically to do is make sure the usb cable is solid at both ends, mio led is on, then do your PDR & jumper reset procedures, hoping it will show signs of life &/or pop up on the DIAG list eventually. If it can not find its way on this list you've also lost access to the 3rd type of reset:

  • we're told a 32-bit test performed on an mio can further help 'reset it'
  • if its on the list, does it need a reset? *laughs* if it doesn't help ... it can't hurt
  • if it isn't even there on the list? there is nothing to test & then nothing to reset
  • usb communication is down between it & mthrbrd: temporary? or permanent, yikes

If the mthrbrd can not detect it outside of windows like this, you can never expect it to be functional on your Windows install let alone have nor expect CmndCntr functions to work.

I left you the link to the Dell/Aurora page to download & create 32-bit DIAG & look for your MIO on the list. It has to be there 1st. Let me know if you have done this basic trouble-shooting step:

  • if you have, & if your RESET procedures failed?
  • perhaps try a different usb header, no good?, try the last usb header on your mthrbrd
  • still no good?

Knowing you used your Resource DVD it is highly likely it has in fact bricked your mio. I know of no other way to get it back online, working, but that does not mean someone else has other tools to try. At $30 a pop on eBay, you can make a small investment in a replacement & hopefully be back up running.

********************************

R3 / R4 PSA+ vs ePSA

The 32-bit DIAG software isn't on the R3 download page, I could be wrong but I assume if when you hit F12 at the BIOS logo on R3, if you see PSA+ available, maybe you can try the 32-bit DIAG test burned to CD / flashdrive, perhaps as part of your utility partition if you still have one, I do not have one.

On my R4, I hit F12 & I can enter Diagnostics as part of my ePSA test:

6761.PTDC0005.JPG

I saw no MIO test in there, but, in my build right now I have nothing connected to my #1 USB header. The test knows that too (see above). My mio works however, & until I know more about whether there is a specific mio test in this ePSA, it is possible a bricked or 'dormant' mio may not be detected also as a usb device:

  • my mio is on usb#3
  • if it were bunk, or acting bunk, I suspect my test here would also say: error on USB#3 etc.

- 32-bit DIAG Error on R4 -

I can not use my 32-bit CD on R4; if you get this error on your R3, try an ePSA if you have that & look for a USB device error, similar to my USB#1 error. Hopefully a more experienced member will tell us what to expect in the ePSA testing for with a mio dead or alive.

5756.PTDC0003.JPG

Sir, I wish you the best, sorry if yours crapped out, I did my best here for ya

 

0 Kudos