Last reply by 04-27-2020 Solved
Start a Discussion
2 Bronze
2 Bronze

17 R5, no supported AlienFX devices were detected

WIn 10 64, May update. Alienware 17R5. Bios 1.7, AWCC 5.2.37

Uninstalled, reinstalled. Registry does show that it detects devices, and lights work - I just can't change them


Solutions (4)

Accepted Solutions

Not sure if this is related to my post but installed the update to Alienware Command Center (AWCC) and it broke it again.  I was able to fix it within about 20 minutes, so here's what I did to try to streamline my previous steps which worked pretty well:

First off, right now I'm running Windows 10 Pro build 1903, fully up to date according to Windows Update.

Opened AWCC for the first time in a few weeks to change a light setting and got the update notice, went through with the update, after a reboot it was back to broken like most the year.

1) Rebooted into the built-in Administrator account (you have to enable it in local users and groups as it's disabled by default and has absolute permissions across entire system as opposed to standard administrator accounts)

2) Ran Revo Uninstaller to uninstall AWCC, when prompted to check for leftover files I chose "Advanced".  Selected all files that were showing as under any directory path with Alienware Control Center in it as well as that directory itself. **Make sure you click the delete button toward the bottom left of the scan window before hitting next.**

3) Refreshed application list in Revo and Uninstalled Alienware OC controls and did the same "Advanced" check as above but it said nothing leftover was found.

4) Refreshed again and went to the Windows Apps tab in the top ribbon of Revo. AWCC was listed there as well so ran uninstall and did "Advanced" scan/check as in steps 2&3. Selected anything referencing Alienware Command Center/AWCC for the registry keys as well as all files/directories referencing the same.

5) Moved log files from Installed AWCC and OC Controls (C:\ProgramData\Dell\UpdatePackage\Log) into a new subfolder there I created labeled "Old."

6) Rebooted and logged back in directly to built-in Administrator account.

7) Went to registry and completely disabled UAC (Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System -> set EnableLUA to "0").  Reboot back to built-in Administrator.

8 ) Downloaded latest AWCC and OC Controls installers directly from Dell Support.  Installed AWCC and OC Controls.

9) Rebooted back to built-in Administrator account.

10) Ran AWCC and got error when it opened saying no FX devices found, clicked okay, saw notice at bottom right services were starting up, 10 or so seconds later app was accessible and regained control of FX lighting and Fusion tab.

11) Rebooted and logged in to regular user account.

12) No AWCC application (not surprised), ran installer downloaded in step 8 and selected "Repair" option.

13) No AWCC application listed to run in start menu after completing step 12, but files and folders are in the right place and the Command Center Suite is in Apps and Features.

14) Install AWCC from Microsoft Store. Launch when installed.

15) If it tries installing other components (AW Sound Center, FX Systems, etc) go with it following prompts and verifying identity if necessary (for me facial recognition would say something went wrong, try again, though using PIN instead worked). You may or may not get a prompt that says you already own it. If so, just click the close button on bottom left of prompt and continue.

16) After all in the previous steps finish it will ask to download the content now. Click "Okay." It will run the install of these components in the background over a minute or two and you should see messages pop up to say when each is installed. AWCC app should still be up and running and you should be able to verify full access to FX and Fusion tabs again.

17) Once verified you can access FX and Fusion, reenable UAC by going to the registry (refer to step 7) and setting EnableLUA to "1" and reboot.

18) Logging back in to your regular account, launch AWCC app again and it may pop up the no FX devices found message again, click okay and you should see the message about AWCC services starting at the bottom right. After 10-20 seconds there was a UAC prompt to let AWCC make changes. Click "Yes" and you should be able to access FX and Fusion from your regular account with security in place again. (It may have a pop up for a component install again and go ahead and do it if it does.)

The above I've been able to recreate successfully so I really hope it fixes others' issues. I've rebooted after finishing the steps a number of times and it always pops up with the no FX devices found message but hitting OK on that and letting the service startup for it run (followed by the UAC approval window) has given me full access every time. Closing out the app and running it later doesn't give me any no FX devices errors as well, it just loads straight to the app (the service is already running in the background at that point, so duh).

This is pretty much confirmed to me to be a combined issue of permissions as well as the application calling files from two separate locations that you only are getting by running the installer from Dell Support as well as running the install from the Microsoft Store. With Windows 10, the folders the Microsoft Store utilizes seem to be off limits to anything 3rd party.

View solution in original post


If you have Windows 10 Pro, right click on the Start Menu button at the bottom left of your task bar and select Computer Management.  In the window that opens up navigate to Local Users and Groups-->Users.  In the Users folder there is an account called Administrator that is disabled by default in all versions of Windows.  Double click Administrator, uncheck the box for "Account is disabled," and click OK.  I'd suggest right clicking it after and selecting "Set Password" and setting a secure password because that account has control over everything.

If you don't have Pro or just want the command line version, from your account with admin rights click on the Start Menu and type "cmd" and right click on the Command Prompt app to select Run as Administrator.  Enter the following in the elevated privilege instance you just ran:

net user administrator /active:yes 

Hit enter, then type net user administrator <Password>  (instead of <Password>  put in the actual password you want assigned to the account.

Either way you do it I'd reboot before logging in as the administrator and doing any of the other steps.  Once you've finished (hopefully with success!), I'd also highly recommend disabling the administrator account.  From command line you open the elevated instance as outlined above and instead of typing /active:yes you change to: /active:no

From the first method mentioned you'd go into the properties (double clicking the administrator user in Computer Management) and check the box for "Account is disabled."

Hopefully that helps you and you are able to get it working for you like I was for me!

View solution in original post


Was able to fix this by logging into the Administrator account, unlocked it like McScruffy said, with the command line. 
Then, in Add/remove programs, select Alienware Command Center Suite entry, click Modify and then choose Repair.

After this you can check the command center, AlienFX was working without messages immediately.

Logged back into my own account, started AWCC and AlienFx worked immediately without messages or further action required.

View solution in original post


Excellent instructions, McScruffy!   Only had to go to step 11 for everything to work normally again.  When I got to Step 12 and ran AWCC,  everything was back to normal!

Thanks again for fixing something Dell Support can't seem to accomplish.  Also found Revo Uninstaller quite handy.

View solution in original post

Replies (90)

Hi @gelat


Uninstall and reinstall the AWCC in a proper way following ALL the steps in this article:


Alienware Arena Alienware-Eimy
Dell | Alienware Technical Support
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I no longer work the Forum. If you need extra assistance visit: @AlienwareTech


That advice won't work, and they don't have any other advice. When it doesn't work they'll tell you to reinstall Windows and start from scratch, but that won't work either. They charge you for this feature, but it does not function and it is not supported. Eimy's job is to keep you hunting for an answer that doesn't exist.


Didnt work




Send me a private message with the Service Tag so I can assist you further.


Alienware Arena Alienware-Eimy
Dell | Alienware Technical Support
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I no longer work the Forum. If you need extra assistance visit: @AlienwareTech

2 Bronze
2 Bronze

Same here!  It was working fine yesterday, then all of a sudden my lighting turned to blue and then nothing.  I have followed all directions given from Dell to correct to include uninstalling the AWCC and OC Controls...still nothing.  Then I restored my system prior to 05/24 Windows update and still nothing. 

I have the AWCC installed, but the FX button is dead and the AWCC will not do the components update as it kicks back an error for install. 

What is going on here!?  


I was also told that if the restore point did not work, then I will have to reset my laptop to original factory!??  Seriously?


Was this ever resolved?


Doesn't sound like it. Never was fixed for me. I gave up. Now my audio is wrong too, and I'm positive it's because of the control center.


FACTS. I've done a clean windows wipe,bios update,alienwarefx clean reinstall like 100x. nothing works its just faulty software that eventually gives out on every single alienware laptop that exists at somepoint. Some users just get luckier than others and it lasts a year or two and some people experience issues in a few weeks or months. Fact of the matter is they've done nothing to fix the alienwarefx issues in the last few years and this problem has persisted. I hope they get sued tbh. You don't pay 2grand for a laptop for it to not work.

Latest Solutions
Top Contributor