rogerssa
1 Nickel

Avamar GLR Restore

Trying to restore some email from my Exchange 2010 Avamar GLR backup.

Here is the avexglr_plugin.log info

2016-11-21 09:12:21 avexchglr Info <8334>: VSS: Creating vss version 6.0 or greater object

2016-11-21 09:12:21 avexchglr Info <16479>: VSS: Running on Windows 8 or newer OS, setting correct impersonation level

2016-11-21 09:12:21 avexchglr Info <8871>: Gathering writer metadata...

2016-11-21 09:12:21 avexchglr Info <18208>: Initializing GLR PowerShell interface

2016-11-21 09:12:21 avexchglr Info <13313>: Server name = VESTA

2016-11-21 09:12:38 avexchglr Info <13296>: Creating database [2013_Archive_rdb] on server [VESTA]...

2016-11-21 09:12:38 avexchglr Error <0000>: Error Multiple databases match "2013_Archive_rdb". Specify a unique value.

2016-11-21 09:12:38 avexchglr Error <13268>: Creating database [2013_Archive_rdb] failed!

2016-11-21 09:12:38 avexchglr Error <13355>: Unable to create a database [2013_Archive_rdb]

2016-11-21 09:12:38 avexchglr Error <13346>: Unable to create a restore database

2016-11-21 09:12:38 avexchglr Error <13350>: Exchange GLR mount and restore operations unable to complete.

2016-11-21 09:12:50 avexchglr Error <13522>: Failed to mount database

I've checked C:\Program Files\avs\var\avfscache\ and it is empty.  I don't see any rdb file on the server.

What am I doing wrong?  I've stopped the client and started it back up and still get this errror.

Shane

Tags (3)
0 Kudos
12 Replies
Zhou
2 Iron

Re: Avamar GLR Restore

It looks like creating rdb failed. There might be already a RDB there. Did you select overwrite the RDB while restoring? Please upload the whole log if possible.

-Beta

0 Kudos
rogerssa
1 Nickel

Re: Re: Avamar GLR Restore

I get this error prior to being able to restore.  It comes up when I try to browse the Granular Restore.

Here is the log

<logheader platform="Windows Server 2012 R2 Standard Server Edition (No Service Pack) 64-bit" process_id="avexchglr" version="7.0.101-61" tz="Eastern Standard Time" />

--------------------------------------------------------------------------------------------------------

-----  START avexchglr log 2016-11-28 06:39:29 Eastern Standard Time  [7.0.101-61 Windows Server 2012 R2 Standard Server Edition (No Service Pack) 64-bit-AMD64]

--------------------------------------------------------------------------------------------------------

2016-11-28 06:39:29 avexchglr Info <7075>: argc = 6

2016-11-28 06:39:29 avexchglr Info <7076>: argv[0]=avexchglr

2016-11-28 06:39:29 avexchglr Info <7076>: argv[1]=--sysdir=C:\Program Files\avs\etc

2016-11-28 06:39:29 avexchglr Info <7076>: argv[2]=--bindir=C:\Program Files\avs\bin

2016-11-28 06:39:29 avexchglr Info <7076>: argv[3]=--vardir=C:\Program Files\avs\var

2016-11-28 06:39:29 avexchglr Info <7076>: argv[4]=--ctlcallport=11189

2016-11-28 06:39:29 avexchglr Info <7076>: argv[5]=--ctlinterface=3027-Browse

2016-11-28 06:39:30 avexchglr Info <6673>: CTL listening on port 32710

2016-11-28 06:39:30 avexchglr Info <10684>: Setting ctl message version to 3 (from 1)

2016-11-28 06:39:30 avexchglr Info <16136>: Setting ctl max message size to 268435456

2016-11-28 06:39:30 avexchglr Info <18208>: Initializing GLR PowerShell interface

2016-11-28 06:39:30 avexchglr Info <13313>: Server name = VESTA

2016-11-28 06:39:57 avexchglr Info <15423>: db name = 2013_Archive

2016-11-28 06:39:57 avexchglr Info <15423>: db name = 2013_IT

2016-11-28 06:39:57 avexchglr Info <15423>: db name = 2013_SG0

2016-11-28 06:39:57 avexchglr Info <15423>: db name = 2013_SG1

2016-11-28 06:39:57 avexchglr Info <15423>: db name = Mailbox Database 0330412862

2016-11-28 06:40:40 avexchglr Warning <6788>: Found unknown section 'path-data' in workorder, ignoring

2016-11-28 06:40:40 avexchglr Info <7726>: LISTENING ON PORT 32710

2016-11-28 06:40:40 avexchglr Info <7744>: bindir:

2016-11-28 06:40:40 avexchglr Info <13044>: ctl_spawn successful

2016-11-28 06:40:40 avexchglr Info <7729>: original key [3027-Browse], clone [3027-Browse#1]

2016-11-28 06:40:40 avexchglr Info <6686>: Process 13884 (C:\Program Files\avs\bin\avtar) for workorder Browse#1 started

2016-11-28 06:40:40 avexchglr Info <7732>: Waiting for avtar to finish

2016-11-28 06:40:40 avexchglr Info <10684>: Setting ctl message version to 3 (from 1)

2016-11-28 06:40:40 avexchglr Info <16136>: Setting ctl max message size to 268435456

2016-11-28 06:40:41 avexchglr Info <6688>: Process 13884 (C:\Program Files\avs\bin\avtar) finished (code 0: success)

2016-11-28 06:40:41 avexchglr Warning <15188>: failed to process message type 32 ctl_man_exit

2016-11-28 06:40:41 avexchglr Info <13046>: Manager finished

2016-11-28 06:40:41 avexchglr Error <6677>: Error processing CTL message "<ctl_man_exit key="3027-Browse#1" mid="9936/28252/33" />

"

2016-11-28 06:40:41 avexchglr Info <8334>: VSS: Creating vss version 6.0 or greater object

2016-11-28 06:40:41 avexchglr Info <16479>: VSS: Running on Windows 8 or newer OS, setting correct impersonation level

2016-11-28 06:40:41 avexchglr Info <8871>: Gathering writer metadata...

2016-11-28 06:40:42 avexchglr Info <18208>: Initializing GLR PowerShell interface

2016-11-28 06:40:43 avexchglr Info <13296>: Creating database [2013_Archive_rdb] on server [VESTA]...

2016-11-28 06:40:44 avexchglr Error <0000>: Error Multiple databases match "2013_Archive_rdb". Specify a unique value.

2016-11-28 06:40:44 avexchglr Error <13268>: Creating database [2013_Archive_rdb] failed!

2016-11-28 06:40:44 avexchglr Error <13355>: Unable to create a database [2013_Archive_rdb]

2016-11-28 06:40:44 avexchglr Error <13346>: Unable to create a restore database

2016-11-28 06:40:44 avexchglr Error <13350>: Exchange GLR mount and restore operations unable to complete.

2016-11-28 06:41:07 avexchglr Error <13522>: Failed to mount database

0 Kudos
rogerssa
1 Nickel

Re: Avamar GLR Restore

Anyone able to help?

0 Kudos
Highlighted
Zhou
2 Iron

Re: Avamar GLR Restore

The log shows the RDB - 2013_Archive_rdb - already exists. Please remove it and retry.

--Beta

0 Kudos
rogerssa
1 Nickel

Re: Avamar GLR Restore

Where is it. I can't find it in server anywhere

0 Kudos
Zhou
2 Iron

Re: Avamar GLR Restore

Can you run  Get-MailBoxDatabase on Exchange Powershell to check?

--Beta

0 Kudos
rogerssa
1 Nickel

Re: Avamar GLR Restore

Location says it is here

C:\Program Files\avs\var\avfscache\AVFSMOUNT\exch1\db\rdb_2013_Archive.edb

That directory is empty doesn’t exist at all.

0 Kudos
Zhou
2 Iron

Re: Avamar GLR Restore

Please delete this RDB and retry the GLR.

If it still doesn't work, please contact EMC support.

--Beta

0 Kudos
J_H_
3 Zinc

Re: Avamar GLR Restore

you can only have 1 RDB at a time (Recovery DataBase) on the exchange server.

So if you look on the exchange server and you see the datastores that you back one.

one of them would be an RDB

that has to be removed before you can do another one.

So either you have one that was MADE, or one that got orphaned from a previous restore,

or you are trying to do 2 restores on the same exchange server...

rule of thumb,

Only one exchange restore per exchange server at a time

Always check to see if there is an existing RDB and find out of you can remove it.

0 Kudos