Desktops General - Read Only

Last reply by 03-06-2013 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1304225

Disable Intel Boot Agent Help

Long story short, Dell in home tech came today to fix a video card problem but showed up without the replacement card. He had a new motherboard which was for further troubleshooting if the new video card didn't work.  So he replaced the motherboard and kept the exisitng NVidia card and, of course, it didn't correct the video card issues.
 
So here is my new problem.  Now when the computer boots, I get this Intel Boot Agent that is scanning for DHCP.  Needless to say it's annoying.  I've used the search button and haven't yielded any results.  I've gone through the Bios settings and I made sure that I don't have the "IBA..." selected anywhere.  My first bootable is 1: removable, 2: hard drive, and 3: is cd rom.  I see in my options that the IBA is there but I haven't selected it.
 
How do I disable this Intel Boot Agent that is scanning for a DHCP?
Let me know if more info is needed.  Please dumb it down because I'm not uber computer savy
 
Thanks, Tom.
 
My setup is: 1 Week old Vostro 400
Vista 32bit Premium
BIOS ver. 1.0.10 just DL'd from Dell Previous ver. 1.0.3
Intel Core 2 Duo E6550 2.33Ghz
2gig Ram
Integrated 10/100 NIC just DL'd drivers from Dell
Replies (27)
2 Bronze
2 Bronze
2591

Just a little update...

Flashed the BIOS to 1.0.11 but that blasted Boot Agent is still coming up!

Do you know how to disable the Dell logo so one can see the POST information at startup?  I saw a flash of a screen where it said something was not installed but it was only there for a split second.  If the Dell screen wasn't there I could probably read it better.  Maybe this thing is causing the problem?
7 Gold
2591

Mayhemm,

 

The Intel Boot Agent is tied into the BIOS so there is no setting in Windows to eliminate the problem.  Intel does offer a utility to disable the Boot Agent, but from reading the utility's description it doesn't apply to your system.  With a system like yours, Boot Agent must be configured in the BIOS.  You can click here for the Intel Utility I am referring to.

 

As for the Dell logo splash screen, your model's BIOS doesn't offer any options to disable Fast Boot or Quick Boot so that the BIOS boot up screens will appear.  A few things to try.......   on the older Dell systems, if you pressed the ESC key during boot up it would minimize the Dell logo so that you could see the boot up display.  Give it a try.  Not sure if it will work on the newer models.  Secondly, try tapping the PAUSE key when the screen displays the error message about something not installed.  On a lot of systems the PAUSE key will stop the boot process and allow you to see the boot display screen.  Once paused, just press any key to continue the boot process.  Thirdly, you could also try changing the option for Halt On that should be listed in the Standard CMOS Features sub-menu of the BIOS Setup. There is one setting for halting on all errors that may display the error message.  

 

What PCI cards do you have in the system?  My thought is something maybe causing a boot delay so that the Intel Boot Agent kicks in.  Try booting without any cards installed.

 

You mentioned two SATA hard drives, are these setup as a RAID operation?  Are all the drives shown in the BIOS setup and the SATA HDD Auto-Detection option set to Auto.   If you don't have a floppy drive then make sure the Onboard FDC Controller is disabled.

2 Bronze
2 Bronze
2591

Sorry for the long reply time, but I was out of town on business since Friday. Anyway, I'll get to the point.

I tried your suggestions regarding extending bypassing the Logo screen to no effect. However I was able to use info in the link you provided to extend the Boot Agent screen by using CTRL-S. I think I have identified the thing triggering the Boot Agent.

Before the Boot Agent initializes, the PC displays the following:

"AHCI Option ROM (I don't recall the version)

AHCI BIOS not installed!
"

Then the boot agent starts.

Just to be thorough, I don't have any PCI cards installed. My hard drives are not RAIDed and they are set to Auto Detect in the BIOS.

The question is why the PC is searching for AHCI when it doesn't support it?
7 Gold
2591

Mayhemm,

 

Ah, you maybe on to something.  :smileyhappy: 

 

Go into your BIOS Setup and look in the Integrate Peripheral sub-menu.  There is an option for SATA Mode.  Check to see that this is set for IDE.   

2 Bronze
2 Bronze
2591

The SATA Mode is indeed set to IDE.
7 Gold
2591

Mayhemm,

 

Well I thought we were on to something.  Back to the drawing board.  At the moment the only thing I can think of is try changing the boot order.  Put the hard drive first and the CD drive second.  Maybe with the optical drive listed first, if there is no bootable media in it, it's causing the Intel Boot Agent to kick it.  By listing the hard drive first, the system should boot immediately to it.

Message Edited by Majestic on 02-28-2008 07:39 AM
2 Bronze
2 Bronze
2591

That was one of the first things I tried; to no effect. :smileysad:

Any idea why the BIOS thinks it's AHCI? Or how to reset this if clearing the CMOS and flashing it to a new version doesn't work?
7 Gold
2591

Mayhemm,

 

I've kind of run out of ideas at this point.  Of all the things we have tried thus far, at least one usually corrects the problem.  Since Dell replaced the motherboard, you might want to give them a call on it.  Possibly it's a indication of a problem with the new board.

2 Bronze
2 Bronze
2626

Cool.  Thanks anyway for all the help.  I always seem to get the unusual problems.
7 Gold
2626


@Mayhemm wrote:
Cool.  Thanks anyway for all the help. 

I'm more than glad to have been of assistance.  I only wished we were able to resolve the problem.

 


Mayhemm wrote: 
I always seem to get the unusual problems.

I kind of fall into that category myself.  I call it the family curse.  If there is a bird in the sky I can guarantee he will find my head.  :smileyvery-happy:
Latest Solutions
Top Contributor