Highlighted

UEFI vs. Legacy "modes"? (XPS 8900)

In preparing to work with the exciting new hardware of the XPS 8900, which arrived pre-loaded with Windows 10 and a secondary 2 TB hard drive, on first observation it appeared as though I could not press [F12] to boot the system from a system imaging CD-ROM.  The system acted as if it was ignoring the pressing of [F12] that I had attempted - maybe I was not trying hard enough?

Quickly I learned [F2] would still work for entering the BIOS settings.

I disabled the "Secure Boot" option, enabled the "Legacy" mode and also checked the box to allow Legacy option ROMs to be used.  This allowed me to get much closer to installing Windows 7 Professional, but there were still problems.

The two hard drive system was apparently an issue for the Windows 7 installer, and it reported Windows could not be installed on the Primary partition (the "M.2" solid state drive).

A search of two displayed error codes led me through DISCONNECTING the secondary 2 TB hard drive, which then allowed the Windows install to proceed from the Primary (M.2/ssd) location.  Thanks to multiple Gaming system owners for pointing out this hard drive-hardware conflict on YouTube!

It was also possible to create an image of the Primary hard drive using third-party software in case the client should EVER desire to go back to the pre-loaded factory configuration.

QUESTIONS:

Q #1:  Does working with the computer in Legacy mode actually "take away" anything from the UEFI mode (configuration)?

(Note: The 5 or 6 original partitions occupied by the Windows 10 pre-load were reduced down to 1 partition, and Windows was installed on it.)

Now, in attempting to again image the Windows 7 Professional loaded hard drive, the software is reporting mismatched partition tables ("MBR" and "GPT"), and the software refuses to proceed without corrective measures being taken FIRST.

(Note #2: I attempted to reconnect the second (2 TB) hard drive in order to learn whether the issue was one of 'the system' needing to confirm the physical presence of THAT hard drive, before things could progress further.  Booting the imaging software CD-ROM with or without the second hard drive connected did not make a difference.)

Q #2:  Since Windows 7 is on the solid state drive (256 GB), I would be happy to remove EITHER the MBR or GPT partition table that is "in the way", but I do not know which one of these partitions Windows 7 is actually using? ~ Making the wrong choice would be a significant setback.

It truly is unclear which partition the system was using WITH the solid state drive as my previous efforts were progressing; it seems equally likely all of the Windows 7 installation were going to the MBR and the GPT was being "ignored".

If I am wrong, and the GPT was being updated and modified as Windows 7 and a dozen subsequent model-specific Drivers were being installed, if I delete it then all that work is lost.

Q #3: Now that Windows 7 Professional is installed, booted and confirmed as working, can I turn off the Legacy mode options and allow the system to resume booting via UEFI?

Appreciation:

Many thanks to anyone reading this and willing to share their experience in REMOVING one Operating System, re-partitioning a hard drive, and then installing a second (older) Operating System.  This is quite the task!

The client / employer does have in-house I.T. support staff and they are always very helpful, but everyone is busy, busy and it is plain to see the amount of effort required to even explain what is going on (the progression of events).  Plus, everybody has a different well-of-knowledge to draw upon in addressing such questions; its unlikely anyone else has done this before.

Windows 10 may be the biggest, best and most secure O.S. ever to come out of Microsoft, but the business needs of the client take precedence over whatever the vendor "wants" to ship.  Sorry Dell!  Sorry Microsoft!

(the third-party imaging utility software is a very well-known piece of software; I am happy to mention it in private mention, e-mail or follow-up post if that is permitted.)

6 Replies

RE: UEFI vs. Legacy "modes"? (XPS 8900)

Tomorrow I will switch the system back to UEFI mode and see if it boots Windows 7 as is.

0 Kudos
beamermt79
4 Ruthenium

RE: UEFI vs. Legacy "modes"? (XPS 8900)

Hello!  Here is some responses to your questions.

Q1 - No switching from UEFI to Legacy will not effect Windows 7 as UEFI includes items like secure boot that windows 7 doesn't use.  

Q2 - I believe because you used MBR (legacy mode) for your Windows 7 install, the drive with GPT will have to be reformatted for MBR.  I'm not an expert but it sounds like windows 7 doesn't want to or is unable to deal with different drives with different file systems.  If you installed windows 7 under legacy options you will have formatted and installed windows using MBR.  If you turned on legacy options but installed windows using UEFI it will be GPT.  The only way to know this is if you selected BIOS or Legacy vs UEFI when you put the DVD of windows 7 in and booted it up off the disc.  Example on my computer if legacy options are enabled and I used a DVD to boot off of, the drive will be listed twice with BIOS or UEFI in front of it.  The computer management/disk management section in the control panel should be able to tell you what the partition scheme is on the boot drive (the ssd I am assuming).  

Q3 - I wouldn't turn off legacy mode.  BIOS and UEFI work differently and in my experience and goofing off, if you install your OS via Legacy (BIOS) and then shut it off, the OS will not boot or will not function properly.

Again i'm not an expert so I hope this helps.  

neb.kearn
1 Nickel

RE: UEFI vs. Legacy "modes"? (XPS 8900)

I put UEFI secure boot off and the VGA worked immediately. thnx for the tip

Philip_Yip
6 Indium

RE: UEFI vs. Legacy "modes"? (XPS 8900)

For Windows 7 64 Bit a UEFI Boot is always preferred if available. Also the GPT partition scheme is preferred as it allows more than 4 partitions and has multiple boot records making it more robust. Windows 7 Pro was never updated to have the Security Signature required to pass SecureBoot.

In the UEFI BIOS setup:

  • SecureBoot Disabled
  • Legacy Boot Disabled
  • Legacy ROMs Enabled
  • SATA Operation: AHCI

Not sure about your DVD but its likely out of date by at least 5 years... most Windows 7 installation media is vintage 2011 and lacks support for newer hardware.

You should use a Dell Windows 7 Professional Skylake Reinstallation .iso which has been updated to support NVMe (needed for the M.2 SSDs) and USB 3.1. The Dell Skylake .iso will also activate using OEM System Locked Preinstallation (Offline bIOS Based Product Activation) on your XPS 8900. 

For more details see here:

http://dellwindowsreinstallationguide.com/download-dell-windows-7-64-bit-reinstallation-sp2-oem-iso-... 

Dr Philip Yip
Tech Enthusiast and Author of the Unofficial Dell Windows Reinstallation Guide

Windows FAQs and OEM Downloads


#IDoNotWorkFor Dell

RE: UEFI vs. Legacy "modes"? (XPS 8900)

Thank you Philip for this additional information.  It should be helpful in managing the workload at my place of business in one way or another!

Philip_Yip
6 Indium

RE: UEFI vs. Legacy "modes"? (XPS 8900)

You're welcome. P.S. I updated the script file at the weekend and made some new tutorial video. Updated information and tutorial videos are available here:

http://en.community.dell.com/support-forums/software-os/f/3524/t/19999620 

Dr Philip Yip
Tech Enthusiast and Author of the Unofficial Dell Windows Reinstallation Guide

Windows FAQs and OEM Downloads


#IDoNotWorkFor Dell
0 Kudos