Highlighted
JKO55
Bronze

Dimension 4600 - SATA Primary Drive 0 Not Found

Hey - I have a Dell Dimension 4600 system and it has this message when I boot it up:

SATA Primary Drive 0 not found
SATA secondary drive 0 not found
Strike the F1 key to continue
F2 to run the setup utility

The system has been like this since someone set it up for me. There is nothing wrong with the hard drive - I just think it's set up wrong. So when I hit F1 it boots up just fine. I'd like to fix this problem, why am I getting this error and what do I need to do to fix it? - Thanks, Jim

0 Kudos
23 Replies

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

Hello JKO55, It appears that the drives are not set up correctly in the BIOS.

When the system boots, at the Dell Logo screen, press F2 to enter the BIOS and in the Drives section on the left of the screen, make sure the SATA port0 and port1 and enabled. Also make sure that any ports that do not have any devices connected to them are disabled.

Then go to the Boot sequence section and check that the first boot device is Onboard CD\DVD is the first boot device and the second boot device is the hard drive that the OS is installed on.

Save your settings and reboot the system.

If everything else is as it should be, the system should boot normally.

Hope this helps.

0 Kudos
RoHe
Diamond

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

And if that doesn't do it, replace the battery on the motherboard.

 

Ron

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
JKO55
Bronze

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

Hello, thanks for the help. I tried to do as you suggested but in the setup utility under "drive configuration", it shows SATA priimary drive - Unknown Device. Same thing for the secondary drive. It also says "model unknown". What should I be doing? How do I enable the ports? It's not clear. Thanks again for your help - Jim

0 Kudos
RoHe
Diamond

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

In BIOS setup, make sure SATA PRIMARY DRIVE is set to Auto. If it isn't, change it to Auto, save the change and exit setup.

 

If that doesn't help, power off and unplug PC from the wall.  Press/hold power button on the case for ~15 sec. Open the case and remove the battery from the motherboard. Press/hold the power button again for ~30 sec. Reinstall the battery, right-side up! See if it'll boot now. And if that battery is more than 2-3 yrs old, install a fresh one.

 

Ron

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
nclonie
Copper

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

I have exactly this problem.  I installed an additional 80Gb SATA hard disk on my 5 or 6 year old Dimension 4600 - same as the original drive.  It was seen in Windows from the original drive, no errors reported in Device Manager and I was able to store a file on it, so assumed it was OK.  I took out the old drive so that I cld load Windows XP and other programs on to the new one - planning to copy over data files and then dispense with the original drive, which has been giving blue screens from time to time.  However, after loading the XP installation files, at the point where I have to run Setup, I get the message "SATA drive not found".

What's worse, when I took out the new drive and went back to the old one again, I got the same message!  So I now have two inaccessible drives.  In BIOS both are reported as "Unknown device" even though the first one is the original drive.  The new one is a Seagate Barracuda but according to the Dell website not one of those that apparently do give rise to problems like this.  In the Boot Sequence the hard disk is reported as "Not installed".

Searching the internet has turned up a lot of instances of this problem where people have installed new SATA drives.  I would like to try one suggested solution, which is to load the required driver from a floppy disk at the point in loading XP where you are asked if you want to do so, by pressing F6.  However, I can't work out which driver it is.  I have a Dell resource CD with drivers on it.

Another solution for which many users seem to giving heartfelt thanks is to change SATA to ATA in the BIOS, which apparently allows XP to load correctly - but I think that must only apply to newer computers.  I can't find the option to do that in my BIOS.

If anybody can give me the solution to this I'd be most grateful.  If anyone can tell me which file(s) to load at F6 and where to find them if not on the Dell Resource CD, that would also be very helpful.

Thanks.

0 Kudos
Dale_Lehman
Copper

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

ok i tried everything with the sata primary drive 0 found and so on i replaced the batterie the hard drive was good when i got it it was running and working it had windows 98 on it and i went to put windows xp on it and it came up an error it said it couldnt be completly installed would a recovery disk fix this or am i screwed?

0 Kudos
RoHe
Diamond

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

Hang on a nano-sec...

Did you reformat the drive and attempt a clean install of XP? Or are you trying to do an upgrade of Win98 to XP??

Read this from Microsoft for instructions for either a clean install or upgrade of 98 to XP.

Can you put this hard drive into another PC as a secondary drive to see if it's still readable (keep in mind that it won't boot another PC without proper drivers) ? That way you'll get an idea if this is a hard drive issue or a mobo issue.

Not sure what you mean by a "recovery disk". Dell only provides an XP Reinstallation CD which installs XP, and nothing else, meaning you have to install all the drivers and software after installing XP.  You may also have to install the SATA drivers from a floppy onto the hard drive before you an install XP, but BIOS has to see the drive first.

Ron

 

Ron

Forum Member since 2004
I am not a Dell employee

nclonie
Copper

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

Dale, to follow up my post above about all the nonsense I had trying to install XP on a new, working SATA drive:  I got to the point you describe using a Dell recovery disk of XP Home with SP1.  This disk had been supplied with my Dell Dimension 4600 when I got it.  Eventually I got  the primary drive appearing in the BIOS as "Unknown device" and "HD". During installation the files were read off the Dell XP recovery disk but then the process came to a halt with a similar error message to yours.

To cut a long story short, after much wasted time I got a Windows XP Professional disk from an old laptop belonging to my brother.  Using that CD, glory hallelujah, the SATA drive was detected and XP Professional installed no bother, immediately. I also followed the instructions on installing XP given in the Dell 4600 manual.  I mention this because it includes useful tips such as "When the message `Press any key' appears, DO NOT press a key".........Hmmm.  No comment.

As far as I could make out the files missing from my Dell XP recovery disk are two drivers called 1.  Windows\System 32\drivers\disk.sys and 2. Windows\System 32\drivers\PartMgr.sys.  It might be worth checking the Drivers folder of the XP installation disk you're using to find out if it includes those two files.

So going by my experience I'd say

(1) You seem already to have XP.  Try installing that again but be sure to follow the directions in the Dell 4600 manual, because of the quirky instructions such as the one mentioned above.  And check it includes those driver files just mentioned.

(2) Try a recovery disk if you have one (It could be more up to date than mine). Same advice about checking the driver files.

(3) But if you get any of the rubbish about drive not found, files not installing etc. don't waste any more time on it.  Get a copy of XP Professional and your troubles may well be over.  Feel no compunction about using it.  This problem has been around for years as you have no doubt found out, as I did, when looking for solutions.  The big companies concerned have largely ignored it.  You have XP on disk yourself, which you presumably came by legitimately, and are entitled to get it to work one way or another.

You may even find, as I did, that when XP Professional installs, your XP Home files also install.  Something like this happened on my computer.  On start up I got the choice of running either XP or XP Professional. Where the XP Home files had been meantime I have no idea.  Unfortunately I can't absolutely confirm that that's what happened because I decided to use the Professional version and just deleted the XP files without actually trying to run the application.

Hope some of this turns out to be useful - I'm no expert.  Good luck.

chriska
Bronze

Re: Dimension 4600 - SATA Primary Drive 0 Not Found

Did you ever get the Primary Drive recognized.  I am having the same problem and know my HD is good from testing on another Dell.

 

0 Kudos