Highlighted
trentham
Bronze

Dimension 9150 will not boot from sata drive

Jump to solution

I've been struggling with this machine and searching the internet all day long but can't find a solution.  I'm experienced at all this stuff (but still have plenty to learn!) so I hope I've done all the obvious hings.

This is a friend's machine and I was called to find out why it wouldn't boot.  My 'friend' had done some stuff but I don't know what and he had no idea what he was doing anyway!

The m/c is a 9150 with a single SATA HDD (250GB) XP media centre is what I believe is expected to run

Originally it was coming up with "no boot device found" and checking the BIOS showed that SATA0 was not set as a bootable device so I set it but now when booting is just shows a blank screen with the cursor in the top left.  Going via f12 to try booting the utilities partition gives the same result.

Using an XP Pro SP3 CD and going to the recovery console detected NO windows installations.  Using that same CD and continuing as if to install showed 4 apparent 'disks', all seemingly unformatted.

If I boot into Puppy Linux then I can mount all the partitions and access everything as expected.  Similarly I can boot an XP version using UBCD and that recognises the drive and chkdsk finds nothing wrong.

I've also mounted the drive in another machine and run chkdsk there and found no problems.

It seemed as if the BIOS was not able to recognise the SATA drive.  I got hold of the appropriate Intel Matrix Storage Manager driver and tried going through the XP installation process using F6 to load drivers but this made no difference.

As far as I can see, it is as if  the BIOS can't see the disk properly and neither can XP installation, although everything seems find when booting a different OS from CD.

At some stage in the process I had diagnostic lights 1,2,3 on and 4 off, but that just seem to mean there's a problem and I know that!  When it hangs with a cursor flashing there are no lights on.

I tried installing a different SATA drive and going throgh the XP install process but got exactly th same result.  I've also tried setting the SATA operation to try auto/ATA rather than auto/AHCI but to no advantage.

I'm right out of ideas now!

 

0 Kudos
36 Replies
RoHe
Diamond

Re: Dimension 9150 will not boot from sata drive

Jump to solution

Try clearing BIOS settings.

Power off and unplug

Press/hold power button for ~15 sec

Open the case and remove the motherboard battery

Press/hold power button again for ~30 sec

Reinstall the battery (right-side-up!) and see if it boots now with only mouse, monitor and keyboard attached. BTW: If the battery is more than ~2-3 years old, it might be dying/dead so this would be a good time to replace it. CR2032 lithium ion coin cell.

If you don't have an internal floppy drive in this system, you'll probably get a floppy drive error when you reboot after resetting BIOS. In that case, just run BIOS setup (Press F2 before Windows starts to load) and look for the option to disable the Diskette Drive. Save the change and exit setup.

Ron

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
RoHe
Diamond

Re: Dimension 9150 will not boot from sata drive

Jump to solution

Me again...

One more thing.  XP can't see a SATA hard drive unless BIOS is set to RAID Autodetect/ATA. So you'll have to change to that setting if you intend to reinstall XP. If you load the SATA driver from a floppy disk during the XP installation, you'll have to change the setting back to ACHI again before it'll boot the next time.

You can also load the SATA driver after XP has been installed, in which case you can install it from a file downloaded to the hard drive. But remember to change BIOS to ACHI on next reboot.

Ron

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
trentham
Bronze

Re: Dimension 9150 will not boot from sata drive

Jump to solution

Hi Ron,

 

Thanks for those thoughts.  I'll try giving the BIOS a complete reset, though I'm not hopeful.  The machine is only 18 months old so the battery "should" be OK, but I'll replace it anyway.  I always keep a supply of CR2032's (and others) on hand for older machines.  The stuff about floppies I'd already detected (is that the way the system shipped because when I came to it it complained that it couldn't find an internal floppy... surely it would have been set to disabled?  Anyway, it is now!)

Your comment about needing auto/ATA for XP install to work was something I didn't know so I'll have an explore down that line and see what that reveals.

 

p.s. if it helps, I really am experienced so if it helps to reduce your typing, feel free to say things like, "reset the bios by taking the battery out", etc.  I know from my clients that there are those I can talk technical to and those I have to say, "go to the start button and click on it.....".  If I don't understand something, then I'll ask.

 

0 Kudos
RoHe
Diamond

Re: Dimension 9150 will not boot from sata drive

Jump to solution

Sorry, wasn't trying to minimize your experience working with PCs. I try to be complete so the next person with similar problems who stumbles across the thread can find all the info they need to fix it too.

If the system doesn't have an internal floppy drive, the system should have been shipped with the floppy controller disabled in BIOS. The default BIOS setting is to have the floppy drive controller enabled in BIOS. When BIOS gets reset, intentionally or otherwise, the floppy controller is enabled and you get a floppy drive error message when booting.

If this system was complaining about the floppy drive and BIOS hadn't been reset by the user, that suggests either the settings got scrambled or the battery died and everything was reset to the factory defaults.

Because XP doesn't have built-in SATA drivers, it won't see a SATA drive when BIOS is set to RAID or AHCI. And once the SATA drivers are installed into XP, it won't see the hard drive if BIOS is set to RAID Autodetect/ATA. Later versions of Windows have SATA drivers so they don't have this problem.

 Ron

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
trentham
Bronze

Re: Dimension 9150 will not boot from sata drive

Jump to solution

Hi Ron,

I took no offence and was just letting you know you don't need to detail everything, though, to be fair, it'll probably be useful for others looking at this.

So far I've set the bios to auto/ATA and indeed now the XP installation disk does find windows.  I had a look at fixmbr but hesitated to actually let it run at this stage since it seems to be saying that it's non-standard and it might make things go wrong.  I must admit that when I looked at the disk with a low level editor, the MBR and boot record both looked to be OK and the partition table looked as I expected and pointed to all the right places.

I've yet to do the bios reset as suggested and I'll do that next, although I don't really think that's going to reveal very much.  Having done that I'll try a windows repair install, loading up the intel SATA drivers and see if that puts things back as they should be.  Hopefully that will allow me to then try to boot with ahci set.

FYI the system does not have a floppy drive installed, though I have a USB one available.  Thanks for your assistance with this.

Ken.

0 Kudos
trentham
Bronze

Re: Dimension 9150 will not boot from sata drive

Jump to solution

I reset the BIOS, set it back to auto/ATA and set going a repair install having first loaded the intel SATA drivers from floppy.  It recognised the old windows installation and did the file copying OK but when it cam to reboot, it just hung as before.  I tried setting the bios back to auto/AHCI but it still hung.

What did surprise me was that when I selected a repair install, it said there had been a previous incomplete attempt and did I want to try again.  I answered yes to this but it did cause me to wonder if my "friend" had had a go at a repair himself.

I'm beginning to think it's time to set it back to how it was when he got it - but I'm not convinced that even that would help!  Obviously, the first thing I did was take a copy of all his data to an external drive before I started messing about.

0 Kudos
trentham
Bronze

Re: Dimension 9150 will not boot from sata drive

Jump to solution

I've now done a bit more testing by inserting a spare SATA drive and setting bios to auto/ATA and then installing XP Pro onto the drive.  I've done it twice now, each time with no problems.  The first time I just went through as normal and the second time I loaded the AHCI driver from floppy during the install process (via F6).

In both cases the system worked without problems and in both cases if I set the bios to auto/AHCI it failed to boot cleanly but at least did something,in that it started to load windows, obviously failed and then rebooted.  Certainly it's a different behavious than I got from the original disk.  I'd hoped that by using the SATA driver at installation I'd have been able to use AHCI but apparently not.

I'm now thinking that maybe I DO need to try a fixmbr, though I think I'll try to take a copy of the old one first!

0 Kudos
RoHe
Diamond

Re: Dimension 9150 will not boot from sata drive

Jump to solution

DON'T use fixmbr!!

If you do, you'll lose acces to PC Restore which resets the (original) hard drive to exactly the way Dell shipped it with XP, drivers (including SATA) and any free software they provided. PC Restore should have the drive running again in only ~10 min vs 2+ hr to do a clean install.

PC Restore will wipe out any personal files and software installed by the user, so it's good you backed up the drive before you started working on it. You will have to install the XP service pack (eg, SP3) plus all subsequent updates for XP, IE, .net etc. But it's still faster/easier than doing the clean install.

But if the system fails to boot when set to ACHI after installing the SATA drivers, are you sure you installed the right SATA driver for this hardware and XP? 

Maybe there's a hardware problem on the motherboard with the hard drive controller..?? You could always leave the BIOS set to Autodetect/ATA. You'd lose the advantage of SATA and the Intel Matrix Storage Manager, but the user probably won't notice any difference.

Ron

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos
trentham
Bronze

Re: Dimension 9150 will not boot from sata drive

Jump to solution

I've certainly not been prepared to run fixmbr unless I can first back up the old MBR and reinstate it if needed.  It did seem likely that if it's not standard then there's a reason for that.

Mind you, I'm not sure that PC Restore is available anyway!  According to the instructions, there's supposed to be a blue bar with www.dell.com at the top of the screen during boot but there is no sign of this.  If I press ctrl/F11 nothing happens.  If I select the boot menu and choose boot to utility partition, nothing happens - i.e. it just sits there.

I'm not at all sure I DO have the correct SATA drivers installed.  I searched the Dell support site for this computer and found R130118 which purports to be Intel Driver for Matrix Storage Manager.  When I added the driver during the XP install I was presented with a list of options:-

"Intel(R) ICH8R/DO/DH SATA RAID Controller (Desktop ICH8R)"
"Intel(R) ICH8R/DO/DH SATA AHCI Controller (Desktop ICH8R)"
"Intel(R) 631xESB/632xESB SATA RAID Controller (Server/Workstation ESB2)"
"Intel(R) 631xESB/632xESB SATA AHCI Controller (Server/Workstation ESB2)"

and chose the second; ICH8R AHCI, though must confess I'm a bit out of my depth here.  I had expected to end up with a system with the drivers installed but maybe I'll try installing it into the running XP and see if that gives me AHCI.  I must admit, I'm less bothered about getting AHCI running rather than ATA.  The user will never notice the difference and I just want to get it working!

 

Ken.

0 Kudos