Dell Inspiron 15R SE (N7520) and Source engine games (CS Source for me)

I signed up just for the sake of pointing this out. I would've done this at AMD's site but since the Radeon driver is ONLY supported via Dell's site, I'll post it here. If it needs to be re-posted on AMD's site, I don't mind undertaking the trivialities. Again,  just to clarify, the issue has been resolved. I hope a competent individual at Dell will find this post, consider it, and possibly use it for improving upon the current Radeon 7730M driver, version (lest the needed bug-fixes address the issues I'm about to describe have already been discovered and are being worked on). For reference, I used the following driver package: Video_AMD_W7_A01_Setup-N8PHN_ZPE.exe (497218976 bytes).

Owning my first dual-GPU laptop, I was concerned over the fuss with regards to the Enduro switching technology. Surprisingly, I faced no issue with switching (except that annoying pop-up where I have to profile the game/app accordingly). Modern Warfare, Starcraft 2, Dishonored, Halo (1 so far, I'll test 2 later), they all ran brilliantly. I faced issues with a favorite of mine, CSSmiley Frustratedource. While it was detected appropriately, and I forced the built-in GPU to render the game just in case the Radeon wasn't turning on, I realized that the Radeon chip was processing it all along due to massive frame-rate drops. The issue was that CSSmiley Frustratedource would at a distance gray out models and textures. For example, if any of you are familiar with it, on de_dust2 when choosing Terrorist, aiming straight down the middle we can see the double-doors entry. Bots, being as stupid as they are, always come from there the very first round. On my old HP DV5-1215tx (used an nVidia 9200m GS chip), there were no issues at all. Here, I was facing the same issues I would otherwise have seen on an Intel graphics chip: gray models from afar. I checked with a sniper scope, no difference.

I remembered that the Intel cards were known for having compatibility issues thanks to heap size problems. I Googled the issue with just Radeon and heap but nothing. I then decided to go on to Google the issue from a more broad sense, and stumbled upon this link: http://forums.guru3d.com/showthread.php?t=286637 . It describes that on some cards, shader issues have occurred (one poster mentions his/her nVidia 8800 GTX having gone through the same issues). He/she recommended to set the DirectX level to 8.0 (I remember having read somewhere that 8.1 is also supported, so that's what I'm using now). Towards the bottom, of the page, the appropriate startup variable is mentioned as -dxlevel 80 (I use -dxlevel 81).

I followed the instructions, made a shortcut to hl2.exe, added the options -game cstrike -dxlevel 80, and fired up the game. Sure enough, I could see at the double doors on de_dust2 bots in their entirety. I upped it to -dxlevel 81, no problem. Setting it to -dxlevel 90 reintroduced the issue. Just to be thorough, I downloaded the web installer and confirmed whether or not DirectX was up-to-date; it was. I proceeded to download the popular June 2010 DirectX redistributable package which includes some SDK libraries, thinking that those libraries might solve the issue. Unfortunately, it was of no use. All in all, I had to fall back to -dxlevel 81. A note here to all the gamers, make sure you run the game once with the -dxlevel 80/81 flag, change your graphics options accordingly in one go, exit, then ERASE the -dxlevel flag. Otherwise it'll reset your graphics settings (courtesy of http://forums.steampowered.com/forums/showthread.php?t=1386498).

Given that the Radeon 7730M is only featured in the 15R SE (at least that's what notebookcheck.net assures me), I figured that there probably aren't as many bug reports being submitted. While Googling, I found no results with regards to Dell's site that were relevant to my issue, or perhaps it was a careless overlooking on my behalf. At any rate, after all this typing, if there already is such a post, forgive me, let it slide. I just want to notify the chief distributor of the 7730M driver that there may be a flaw with your driver. My buddy has an HP ProBook 4530s with a 7470M. Way crappier card, but he doesn't have the same issues. This led me to believe it's highly likely the driver isn't perfected and could use some refinement.

Dell, this is what I wanted to convey: kindly confirm the shader compatibility with DirectX 9.0 requisites. Halo, a DirectX 9.0 (I forget if it's a, b, or c) worked beautifully, no problem. Why THIS messed up is beyond my entry-level IT skills. In the end, I myself do tech support, not development and programming.


Dell Inspiron 15R Special Edition (N7520)

Core i7 3632QM@2.20 GHz, 8 GB RAM, 15 GB swap, 1 TB HDD, no mSATA, Windows 7 Ultimate (x64)

0 Kudos