When Using WD15 Dock External Mouse and Keyboard Stop Working Occasionally

I have an XPS 13 9360 connected to the WD15 dock. I've noticed that regularly the external mouse and keyboard I have attached to it stop working.

Here are some things I have observed:

  • When this happens, the mouse and keyboard are still recognized by the computer. i.e. when I plug and unplug them I can see them show up and disappear from Windows Device Manager. Also, when I view the mouse and keyboard's device status in Device Manager it reports "This device is working properly."
  • The USB port on the dock seems to be working fine. I know this because when this happens I can unplug the mouse and plug in a different peripheral (e.g. external hard drive) and find that it works fine. But when I replug the mouse, the mouse still does not work.
  • I know my mouse is fine, because when it stops working I can unplug it from the dock and plug it directly into the laptop's USB port which causes it to work fine (but if I unplug and replug to the dock it does not work).
  • The laptop's built-in keyboard and touch pad still work fine.
  • This usually seems to happen sometime after coming out of sleep especially when waking the computer using the power button on the dock (but not always as far as I can tell so far).
  • Sometimes restarting the computer fixes (temporarily) the issue.
  • Sometimes unplugging and replugging the dock fixes (temporarily) the issue.

Steps I have taken to try to fix:

  • I have upgraded my laptop BIOS to the latest which is currently 2.5.0.
  • I have installed the latest drivers I see on the Drivers and Downloads section of the WD15 page here: http://www.dell.com/support/home/us/en/19/product-support/product/dell-dock-wd15/drivers
  • I have unplugged all other peripherals from the laptop and the dock so that I am running with ONLY the external mouse plugged in. The issue still happens.
  • I have tried to upgrade the dock firmware, but the utility reports it is already the latest. The latest WD15 firmaware I see on Dell's site says it is, but when I run the following command it looks like my firmware version is actually newer than what is on Dell's site.

Any help with this would be greatly appreciated! I'll post any additional patterns I find.

0 Kudos
2 Replies

RE: When Using WD15 Dock External Mouse and Keyboard Stop Working Occasionally

This is admittedly a rather long shot, but try installing the latest Thunderbolt firmware for your XPS 13?  I know the WD15 is just regular USB-C and that the USB-C controller firmware is updated as part of the regular system BIOS update, but I'm wondering if the Thunderbolt controller might still be in the hardware path somehow and therefore a firmware update there might fix something like this.

0 Kudos

RE: When Using WD15 Dock External Mouse and Keyboard Stop Working Occasionally

Such issues with USB on docks were reported to re-occur with certain recent BIOS versions. I mean, the WD15 wasn't useful with my XPS 15 9550 initially, but improved with certain updates.

Do the mouse & keyboard on the dock happen to start working if you turn on the Airplane mode (or disable the wifi&BT adapter in Device manager)? I finally got it working properly after replacing the wifi&BT card with the Intel 8260 (newer: 8265, 9260). Looked like some sort of interference between USB and wifi (RF shielding problem, driver???).

0 Kudos