Inspiron Desktops

2 Bronze

Inspiron 3656, Secure Boot Violation, Invalid Signature Detected

Secure Boot Violation, Invalid Signature Detected. Check Secure Boot Policy in Setup

My home/personal PC “Dell Inspiron 3656” has an issue. I can’t boot!I get a black screen with a red error box. In the red error box it reads “Secure Boot Violation, Invalid Signature Detected. Check Secure Boot Policy in Setup.”I can’t get past that. I have been in/out of the bios screen and made some alterations to the boot options, but still, nada.I followed some youtube videos and came up short. Some changes worked for other people, but not myself.

I didn't make any recent changes to my PC either. Nothing.

Any help? Advice?

Replies (4)
7 Thorium

Secure Boot enforces a policy that only allows signed bootloaders to load on your system.  Windows 8 and up, as well as some Linux versions, have signed bootloaders, so if you're seeing that message all of a sudden without having tried to boot from some other device or an older OS, then your bootloader has either been corrupted, perhaps by a Windows update or application installation that went awry, or else it's been maliciously altered by some kind of malware.  You can go into the BIOS setup and disable just the Secure Boot option, changing nothing else, to see if your system still boots.  If it does, it means your system is probably infected.  If it doesn't, then disabling Secure Boot should at least give you a different error message, but regardless of what it is, if your system doesn't boot, then the bootloader is probably damaged.  But either way, you'll want to restore from a previous image backup if you happen to have been keeping those, otherwise plan to reinstall your entire OS from scratch to be safe -- and then going forward you may want to consider implementing a periodic image backup strategy.


2 Bronze

It is simple:- 1. Go to BIOS setup by pressing F10. 2. Select “File” tab. 3. Click on “Apply defaults and exit.” PROBLEM SOLVED!!


@Ronaldbabu wrote:
It is simple:- 1. Go to BIOS setup by pressing F10. 2. Select “File” tab. 3. Click on “Apply defaults and exit.” PROBLEM SOLVED!!

Don't know what PC  you're talking about, but you have to press F2 to open  BIOS setup on Dell PCs. And applying the BIOS default enables Secure Boot, so that's not going to help... :Huh?:

Ron

   Forum Member since 2004
   I'm not a Dell employee

5 Tungsten

what good post by           

    on secure boot. failure.

the PC with HDD that fail can also cause this.

sure turn off only safeboot in the BIOS page.

if it still fails or boots but now acts corrupted, run the full S.M.A.R.T tests on the HDD. 

installing windows 10 on bad hdd is just a waste of time ,so a tech always tests the HDD first, if that is the boot drive.

2 ways to do that, one is if the PC has dell onboard, ePSA run it and run the full hdd diagnosics.

if not there, I boot to USB stick with Linux, Unbuntu,v16 up,  and run DEMO mode, "tryme"

then run the full disktest.  (see the bad sector errors here, if the hdd runs out of spares, it is doomed.)

http://www.pcdied.com/linux.html

 

watch out on youtube  1/2 those are lies.  ok or worse.  always ask for help here first, dell.com

 

 

nobody
Top Contributor
Latest Solutions