Last reply by 01-12-2023 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Bios firmware installation error with linux: Invalid file!

Inspiron 3585

I want to install my laptop's the newest bios firmware. I'm using Linux(manjaro) so carried this file to the a properly formatted disk.

But I takes an error "Invalid file!"

I select Ubuntu specifically than download and proceed same transaction but got some issue.

Could you help me?

I could able to upgrade 1.4th version but now can't

Replies (4)
2 Bronze
2 Bronze

I tried again for 1.6 th version from 

and tried 1.7 already

and tried 1.9 BUT it says Invalid File!


I'm trying to update from 1.4th version.

Could you tell me why it isn't install?




5 Rhenium

Updating the BIOS from BIOS Boot Menu (independent of operating system)

Note 1: Before updating the BIOS, ensure that you suspend BitLocker encryption on a BitLocker-enabled system. If BitLocker is not enabled on your system, you can ignore this step.

Note 2: Do not turn off the power or interrupt the BIOS update process during the update.


1. Copy the downloaded file to a USB drive. The USB drive does not need to be bootable device.

2. Insert the USB drive into any USB port.

3. Power on the system.

4. At the DELL logo screen, press F12 to access the one-time boot menu.

5. Select BIOS Flash Update in the Other Options section.

6. Click the ... button to browse the USB drive to locate the downloaded file.

7. Select the file and click Ok.

8. Verify the existing system BIOS information and the BIOS update information.

9. Click Begin Flash Update.

10. Review the Warning message and click Yes to proceed with the update.

The system restarts and displays a progress bar at the Dell logo screen. The system restarts again when the update is complete.


2 Bronze
2 Bronze

That is exactly what these people are doing.

Latest Solutions
Top Contributor