Legionic
Copper

Suspend-resume problems on Ubuntu 18.04

Hello everyone, I am using an Inspiron 15 7567, I recently installed Ubuntu 18.04 on it, But I had restart/suspend/resume problems with it, So i followed This guide and got restart and other issues fixed but I still cannot resume from suspend, the laptop just hangs, Can anyone tell me what the problem is ? or perhaps give me a direction ? I tried multiple distros and desktop environments but still no luck....

0 Kudos
7 Replies

Re: Suspend-resume problems on Ubuntu 18.04

I have an XPS 15 9560, something that has worked for me is the kernel parameters acpi_osi=! with acpi_osi='Windows 2009' then make the brightness control acpi_backlight=vendor

 

Good Luck!

 

** PS : You might have more chance on AskUbuntu or Reddit for an answer!

AdT XPS9560
Copper

Re: Suspend-resume problems on Ubuntu 18.04

HI!

I have the same laptop and after having replaced windows 10 by ubuntu 18.04 lts I am facing the same problem with the suspend-resume.

Did you add those options to GRUB_CMDLINE_LINUX or to GRUB_CMDLINE_LINUX_DEFAULT?

Thanks a lot in advance for your help Smiley Happy

Best regards,

AdT

0 Kudos
Highlighted
agathver
Copper

Re: Suspend-resume problems on Ubuntu 18.04

I stumbled across this thread yesterday, as I too was plagued over this issue, This struck me when I was collecting dmesg messages from different OSs while trying to report a bug on Fedora Bugzilla. (I'm a dev there). This also works on Fedora, replace your commands accordingly.

Blacklist nouveau

As usual, it's the stupid and buggy "nouveau" driver. 18.04 is moving away from the old OST module "bbswitch". So, the kernel loads "nouveau" driver, in order to use Optimus power saving.

Fixing this:

  1. First, install NVIDIA drivers. `ubuntu-drivers autoinstall` will install nvidia-390. It's substantially altered from the earlier packages.
  2. Disable nvidia-fallback.service which always loads nouveau: `systemctl disable nvidia-fallback.service`
  3. Add `nouveau.blacklist=1` to GRUB_CMDLINE_LINUX
  4. Use bbswitch for power saving
0 Kudos
humanx
Copper

Re: Suspend-resume problems on Ubuntu 18.04

I'm using 18.04 also without any suspend issues, but my laptop has AMD processors if that matters.

0 Kudos

Re: Suspend-resume problems on Ubuntu 18.04

I am experencing a similar problem on the Inspiron 14 7276 after installing Ubuntu 18.04 and switching from the noveau driver to the proprietary nvidivia Xorg driver.

When enabling the NVidia mx150 driver (tested with nvidia-driver-390 as well as ver. 396) the computer works normally and the card is recognized but when closing and reopening the lid, the laptop cannot resume from suspension.

A green screen is shown with icons of my desktop all confused on the background, the mouse pointer is still there and moves but no input either from the mouse or keyboard is accepted and the only way to regain control of the computer is forced rebooting.

I tried all the above suggestions in this thread but none of them fixed the problem, is there perhaps something else I should try to solve this suspend/resume problem?

Thank you. Luca

0 Kudos
Casc4
Copper

Re: Suspend-resume problems on Ubuntu 18.04

It is the buggy nouveau driver again. That's what solved the issue for me.
Edit the file /etc/default/grub.

$ sudoedit /etc/default/grub.

Add "nouveau.modeset=0" to the line that says GRUB_CMDLINE_LINUX then press ^O to save the file and ^X to live then run.

$ sudo update-grub.

Reboot.

0 Kudos

Re: Suspend-resume problems on Ubuntu 18.04

I followed this Video " 

https://www.youtube.com/watch?v=5nGbWE-pvIE&t=433s

 

and it solved the problem for me...Problem is Nvidia's drivers do not support Optimus on Linux so you have to install bumblebee to fix the problem...

Ever wonder how to turn off your NVIDIA card when not in use? We cover NVIDIA / Optimus / Prime and graphical / command line options. Details below! PPAs: * ppa:graphics-drivers * ppa:bumblebee/testing * ppa:nilarimogard/webupd8 Command line cheat mode: * sudo apt-add-repository ...
0 Kudos