Highlighted
Bappi
1 Copper

Audio Problem

how can i install stereo mix in Dell Vostro 1015?  please someone help me....

0 Kudos
1 Reply
Jim Coates
6 Gallium

RE: Audio Problem

You have to have the Conexant audio driver installed, and then hack the driver files. The hack is at

http://forums.toshiba.com/t5/Audio-Sound/How-get-Stereo-Mix-on-Conexant-sound-card-SOLUTION/td-p/174...

Go to the 1st page of that thread and scroll way down to the 15th post. The poster's name is AcrUsr and he found the hack. Keep reading deeper into that thread for more details from AcrUsr and screen shots.

After you perform the hack and reboot, you may need to enable the stereo mix device. To do so, right click on the speaker icon in the system tray in the lower right hand corner of the screen,  and click "Recording Devices" In the box that shows up, right click in the white area and left-click "Show Disabled Devices"  If stereo mix wasn't there before, it should be now.  If it says it is disabled, right-click on it and left-click on Enable.

Please understand that my laptop does not have Conexant audio and so I have not done the hack and cannot offer much assistance with it. A few Dell owners have tried the hack and the results are mixed. Works for some but not for others. An owner named SeanieOS with an Inspiron 7520 tried the hack but was getting error messages. He finally got it to work and wrote up directions which I have pasted in below in italics.

=====================================================================

1. Open the Device Manager.
2. Open "Sound, video and game controllers" and right click on "Conexant High Definition Audio".
3. Select "Update driver software".
4. Select the second choice: "Browse my computer for driver software".
5. Then select again the second choice: "Let me pick from a list of device drivers on my computer".
6. Now select "Have Disk" (Button in the middle right)
7. Now choose the edited file and confirm all requests with OK.

=======================================================================

Another person found he was not able to save the edited file. He had to change the permissions in Windows. Here is his description of how he did it.

Basically right click on the .inf and then click these tabs/buttons.. Properties> Security>Advanced>Owner. The current owner should be TrustedInstaller. Change this to an account on your computer that has Administrator rights and you can log in as. So Click on Edit and in the "Change Owner To:" field there should be an entry there such as: Administrators (Your computer name\Administrators) so choose that then Ok and apply and Ok to close out all the dialog boxes.

Now right click on the .inf file again: Properties>Security>Edit>Select "Everyone" in "Group or User Names">Select checkbox for "Write" in the "Permissions for Everyone" section>Hit Apply and OK your way to close all the dialog boxes. Now you can save the .inf file you deleted the semi-colons from!

This step is VERY important. You must change back the permissions to the way they were. Right click on the .inf and as before change the Write permission by deselecting the checkbox for "Write" and also then change the Ownership of the .inf file back to TrustedInstaller. This time you go Owner>Edit>Other Users or Groups and type in NT SERVICE\TrustedInstaller in the box and hit Check Names then Ok and Apply your way out of the dialog boxes.

Now finally re-install the driver: Here I got problems with the driver not being recognised and possibly it was because Windows 7 64 bit was saying it is not digitally signed so here's what I did: Start Menu>Right click Command Prompt>Run as administrator>type in this command and hit enter... bcdedit /set nointegritychecks ON.

To install the driver: Device Manager>Sound, Video and Game Controllers>Right click on Conexant SmartAudio HD>Update Driver Software>Browse my computer for driver software>Let me pick from a list..>Have Disk>Browse>Now in here you need to find the location of the .inf file you just edited, in my case I pasted in the path to the folder and hit enter then selected the chrdt.inf file and hit OK. When it was installed I went back to the command line as before and ran the command: bcdedit /set nointegritychecks OFF

Now I rebooted the computer and this time Stereo Mix DID show up in Control Panel > Sound > Recording Tab after right clicking on empty space and selecting Show Disabled and Show Disconnected Devices.

Jim Coates -- 15 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos