Highlighted
2 Bronze

CPU showing less clock speed

Jump to solution

I've Studio 1555 having core2duo 2.1 GHz . Now it always giving speed of 1.19 GHz. When I did stress test by dell support center , in report it shows current speed 1.20 GHz and maximum qualified speed 2.1 GHz.

What can be the reason for decreased speed ? How to get it back to normal ?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
4 Germanium

Re: CPU showing less clock speed

Jump to solution

Hi,

Intel Speedstep technology takes advantage of a power-management technique known as demand-based switching (DBS) and is designed to dynamically modify the voltage of the CPU—and hence the processor clock  speed—based on CPU load. As a result, DBS enables processors to generate less heat by operating at the minimum voltage and clock speed necessary to perform the required operations. For example, on the Intel Xeon processor, reducing power consumption from 1.4 volts (3.6 GHz) to 1.2 volts (2.8 GHz) can reduce the heat generated by over 30 W.  So if you disable this feature you may face issues like system overheating. You can also make disable this feature in BIOS and check if it makes any difference. 

Steps to enter system BIOS:

  • Restart the computer.
  • As soon as you see the blue Dell logo start tapping the ‘F2’ key.
  • If you wait too long and the Microsoft Windows appears, then continue to wait until you see the Windows desktop. Now shutdown your computer and try again.
  • After this BIOS would appear . You can only use the arrow keys of the keyboard to navigate between the options as the mouse is not functional in this mode.
  • Navigate to advanced tab and disable "Intel (R) SpeedStep (tm)".
  • Press F10 and restart. 

As an example, you can check the image below:

 

For more information, you can also check the link: http://intel.ly/UjnFet 

Please reply in case you have further questions.

Thanks and regards,
DELL-Chinmay S
#IWork4Dell 

View solution in original post

7 Replies
Highlighted
4 Germanium

Re: CPU showing less clock speed

Jump to solution

Hi,

By default, Windows will run all your cores. However, in some circumstances windows will set your active cores lower than the max. In some circumstances Windows 7 will disable certain cores. Often this is to save in power consumption or to assist older programs in working correctly.

You can follow the steps below to resolve this issue:

Go to 'Start' and type 'msconfig.exe'. and Run the program as Administrator.

    

Click the 'Boot' tab and choose 'Advanced Options'.

 

Check the box labeled 'Number of processors'. Pick from the list how many cores you want to run. Click 'OK'.

 

Note: If you number of processors is incorrectly displayed or disabled, try ticking detect HAL in the BOOT Advanced Options in msconfig and then rebooting first.

      

Click 'Ok' again and Click 'Restart'.

Please reply for further clarifications.

Thanks and regards,
DELL-Chinmay S
#IWork4Dell 

0 Kudos
Highlighted
3 Argentum

Re: CPU showing less clock speed

Jump to solution

How many cores (graphs) do you see if you open task manager (CTR-SHIFT-ESC) and select the performance tab ?

I believe (maybe Chinmay S could confirm this) that the extra cores selectable on the advanced boot menu are for diagnostics rather than performance and should not be altered.

My Vostro 3750 shows four cores running in task manager but just one selected in boot menu.  

0 Kudos
Highlighted
2 Bronze

Re: CPU showing less clock speed

Jump to solution

In performance I can see both cores. I also change in advanced menu to 2 cores...but even thn there is no change. And I reverted it back to 1 core as it is reporting both cores even when 1 core is selected in advanced menu but speed still 1.19 Ghz...:(...Any other solution plz

0 Kudos
Highlighted
4 Tellurium

Re: CPU showing less clock speed

Jump to solution

Did you experience any problem with the power adapter recently? If the power adapter is not properly recognized the CPU speed will be reduced and battery won't be charged.

Press F2 at powerup and check  the power adapter status in the BIOS. If it says "power adapter = unknown" or something similar something is wrong with the power supply (power adapter,power jack,mainboard)

0 Kudos
Highlighted
2 Bronze

Re: CPU showing less clock speed

Jump to solution

It is acknowledging power adapter as 90w.... . what other problem might be....

0 Kudos
Highlighted
4 Germanium

Re: CPU showing less clock speed

Jump to solution

Hi,

Intel Speedstep technology takes advantage of a power-management technique known as demand-based switching (DBS) and is designed to dynamically modify the voltage of the CPU—and hence the processor clock  speed—based on CPU load. As a result, DBS enables processors to generate less heat by operating at the minimum voltage and clock speed necessary to perform the required operations. For example, on the Intel Xeon processor, reducing power consumption from 1.4 volts (3.6 GHz) to 1.2 volts (2.8 GHz) can reduce the heat generated by over 30 W.  So if you disable this feature you may face issues like system overheating. You can also make disable this feature in BIOS and check if it makes any difference. 

Steps to enter system BIOS:

  • Restart the computer.
  • As soon as you see the blue Dell logo start tapping the ‘F2’ key.
  • If you wait too long and the Microsoft Windows appears, then continue to wait until you see the Windows desktop. Now shutdown your computer and try again.
  • After this BIOS would appear . You can only use the arrow keys of the keyboard to navigate between the options as the mouse is not functional in this mode.
  • Navigate to advanced tab and disable "Intel (R) SpeedStep (tm)".
  • Press F10 and restart. 

As an example, you can check the image below:

 

For more information, you can also check the link: http://intel.ly/UjnFet 

Please reply in case you have further questions.

Thanks and regards,
DELL-Chinmay S
#IWork4Dell 

View solution in original post

Highlighted
2 Bronze

Re: CPU showing less clock speed

Jump to solution

Yeah....now i get it. In fact when i run video editing software on battery it remains on 1.18 Ghz, but as soon as I plugged power supply it goes upto 2.1Ghz.

So for over heating and saving power it might be using less clock speed.

Thanks for reply...and now i'm feeling relief that my system is ok...:)

0 Kudos