2 Bronze

DELL XPS 17 (L701X) video drivers not working on clean install

Hello, everyone once again.

I`m having a really hard time with my Dell laptop. After it fell to the ground some time ago, its GPU (Nvidia GeForce GT 445M) stopped working. As it is not possible to change only a graphics chip, I had to change whole motherboard. I ordered a refurbished one and installed it. As I wanted to make a clean install, I proceeded to driver instalallation, downloading the latest and installing them in the correct order (as shown on dell support webpage). All was working fine until I installed the graphics driver. After the restart my PC freezes onstartup - when Windows logo appears. In the beginning the logo animated but then just freezes and nothing happens.

Then I tried older graphics card drivers - the same thing. Even updated BIOS (maybe I shouldn`t have...) - still the same thing. Hardware seems to be working fine. Nvidia also detects the correct chip and proposes the correct driver. Tried also latest drivers from nVidia page, same thing. When launching in safe mode and disabling the video driver, PC works nicely with integrated VGA driver.

I also tried to launch W7 from my old HDD that I was using before my laptop fell - with all software and drivers installed and working fine at the time. When I launch Windows with GPU driver disabled, everything is working with integrated VGA graphics. But when I enable graphics driver - PC freezes on startup in the same manner. Same thing applies to the ubuntu - it freezes on startup. 

The guy who changed the motherboard assures me that it is not the hardware problem (I hope so too), but then I can`t figure it out where is the problem with the software. Can you help? Thanks! 

4 Replies
Highlighted
1 Copper

Re: DELL XPS 17 (L701X) video drivers not working on clean install

Hi,

Welcome to the Community.

go through these steps this might resolve your issue.

Boot the system in safe mode. Go to Device manager. Uninstall the Graphic card drivers. Restart the system in Safe mode with Networking...go on to below link

http://www.geforce.com/drivers

download the drivers for Nvidia Geforce GT 400M series drivers according to the Operationg system that is installed on the system and restart the system in normal mode...this might resolve your issue

Please let me know the results. Glad to help!

Amit Garg

Certified Dell Community Professional

Highlighted
2 Bronze

Re: DELL XPS 17 (L701X) video drivers not working on clean install

As I `ve said already - I had tried, the latest driver from nVidia, which is the same on geforce page. I reinstalled it anyway, but result is still the same - PC freezes on "Starting Windows" logo.

Highlighted
1 Copper

Re: DELL XPS 17 (L701X) video drivers not working on clean install

Hi,

Then try Clean Installation from Windows disk or Recovery disk. on first boot install the chipset drivers and then video drivers from nvidia website. this might resolve your issue.

Please let me know the results. Glad to help!

Amit Garg

Certified Dell Community Professional

Highlighted
2 Bronze

Re: DELL XPS 17 (L701X) video drivers not working on clean install

The same problem persisted. I believe it is the hardware problem, I took my PC to Dell for repairing. Thank you!