Laptops General - Read Only

Last reply by 01-19-2018 Unsolved
Start a Discussion
Moderator
200763

Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Good day Dell Community,

Over time I’ve received a lot of questions about M.2 drives so I wanted to share some of what I have learned. I will explain in a kind of question/answer format:


Question:

What is Dell’s scope of support for the Samsung and Toshiba/OZC NVME drivers posted on these Manufacturers’ websites?
Toshiba/OCZ: https://ocz.com/us/download/ (To get the NVME driver select OCZ RD400/400A in the drop down)
Samsung: http://www.samsung.com/semiconductor/minisite/ssd/download/tools.html
Note: Samsung’s explanation of what their NVME driver actually does is on page 22 of the following document: http://www.samsung.com/semiconductor/minisite/ssd/downloads/document/Samsung_SSD_950_PRO_White_paper...
Keep in mind:
• There exists Dell branded OEM Samsung and Dell branded OEM Toshiba M.2 drives as well as               non-Dell-branded Samsung and non-Dell-branded Toshiba retail drives
• The drivers in question linked above will load for both Dell OEM drives and retail drives alike
• The Samsung and Toshiba/OZC drivers in question can only be used when running in AHCI mode
• These drivers do not apply when running in RAID ON mode as the M.2 drives will be operating under IRST in RAID on mode
Answer:
Dell does not support the Samsung and Toshiba/OZC drivers for use in AHCI mode. Dell systems with Dell OEM Samsung or Dell OEM Toshiba drives running in AHCI mode will use a Windows inbox driver called stornvme. Stornvme is the driver Dell supports in AHCI mode. Use of the Samsung and Toshiba/OZC drivers will ultimately be decided at end user discretion.



Question:
What are some differences between AHCI and RAID ON modes?
Keep in mind:
• Dell systems ship from the factory with the SATA operation mode set to RAID ON
• There exists M.2 SATA and M.2 NVME ( PCIE ) drive types
• Some Dell system models will support both M.2 SATA and M.2 NVME ( PCIE ) drive types while other     Dell system models will only support M.2 SATA drives
• If a Dell system’s M.2 connector supports NVME there will usually be backwards compatibility with         M.2 SATA drives
• The RAID ON controller and AHCI controller each have different hardware IDs and therefore each controller will require different INFs in order to point to other needed files and resources

  -RAID ON drivers = IRST drivers with naming standard iaStorAC
  -AHCI drivers = naming standard iaAHCIC

Dell’s PreOS IRTS and AHCI drivers can both be found in the following package: http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=CRRKJ&fileId=368088204...

Extracted view:



Note: The above downloadable package also has an installer EXE in case you want to update to 15.2 on systems which have an OS already installed.

Answer:
A new host interface known as NVMe was launched together with Gen 7 (Intel CPU) platforms. This new host interface was built from the ground up for SSD. The host detects on boot up if the storage device is a SATA or PCIe device and then switches the software stack accordingly. Since the host cannot assume all storage devices implement the AHCI host interface the necessary controller is then pushed to the device itself and loaded at boot time. The illustration below describes this.
RAID ON mode: enables the port remapping hardware in the Intel CPU. The remapping hardware is necessary for the Intel RST driver to load the NVMe controller provided by the SSD against the Intel AHCI controller in the CPU. This is required for the Intel RST driver to enumerate NVMe SSD. Also enables support for RAID 0/1/5/10 ( RAID level availability varies by system model ).
AHCI Mode: In this mode NVMe SSDs are enumerated by StorNVMe which is the Windows inbox driver. Implying that in this mode the NVME drive does not work with the motherboard’s AHCI controller, shown in the below illustration:

Below, I have outlined what the storage devices and drives look like in device manager for both M.2 SATA and M.2 PCIE drives, in each operating mode.
M.2 SATA drive when running in IRST RAID ON:

M.2 SATA drive when running in AHCI mode:



M.2 PCIE drive when running in IRST RAID ON:



M.2 PCIE drive when running in AHCI mode:


Question:

Is there any performance difference between running an NVME drive in RAID ON mode VS. AHCI mode?
Answer: Based on the explanation on differences between RAID ON and AHCI above, I believe the answer to this is ‘no’. I’ve taken benchmarks below using CrystalDiskMark.
Benchmark Conditions:
• Precision 3510 with a Dell branded Samsung PM951 PCIE 4x drive
• Windows 10Px64 1703 (Creators edition)
• All system drivers updated through Dell Command Update
• One test in RAID ON running IRST 15.2 driver
• One test in AHCI running default stornvme driver
• One test in AHCI testing with Samsung NVME driver
• Power plugged in and all performance and power options at Windows defaults

RAID ON Test results with an NVME drive:



AHCI Stornvme and NVME drive:



AHCI mode with Samsung’s driver:



Question:
How can I tell how many lanes my M.2 PCIE drive is running on?
Keep in Mind:
• Some M.2 ports will support only 2 PCIE lanes of bandwidth while other M.2 ports can support 4 PCIE lanes of bandwidth
• The amount of M.2 PCIE lanes a system has available can depend on processor and/or motherboard
• 4 lane capable M.2 drives are typically backwards compatible with 2 lane ports but will suffer performance loss as a result of fewer lanes of bandwidth
Answer:
You can find out how many lanes a PCIE drive is running by using a program called HWiNFO
https://www.fosshub.com/HWiNFO.html
Note: Dell does not support this HWiNFO program. This is just a utility I’ve personally found/used and wanted to share.


Question:

When I go to the Dell website to purchase a PC I see ‘drive classes’ when selecting an M.2 drive. What does each class mean?
Keep in mind:
• The drive class standard as seen on the Dell website and below, is a storage device identification standard created by Dell
Answer:
Below is a chart of what each drive class means:




Question:
Why can’t I set a hard drive password on my NVME drive?
Answer:
There are 2 types of M.2 drives. M.2 SATA and M.2 PCIE ( NVME ). HDD password availability for each type is as follows:
M.2 SATA drives are provided hard drive password support from system BIOS.
M.2 PCIE drives are not provided hard drive password support from BIOS. This is working as designed.
Note: M.2 PCIE drives can operate normally even when SATA operation in BIOS is disabled. Hard drive password support is also not provided to M.2 PCIE drives in this mode. (Figure 1)





Question:
Where can I find more information if I want to upgrade my Dell to M.2?
Answer:
The following post contains Dell M.2 / NVME Specifications And Upgrade Requirements For Latitude, XPS, Precision Mobile and Optiplex:
http://en.community.dell.com/support-forums/laptop/f/3518/t/19992358
Included in this document you'll find:
• needed part numbers in order to upgrade
• number of total internal drives supported for mentioned models
• how many M.2 PCIE lanes are available on mentioned models

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


Replies (49)
Moderator
16102

Greetings Florinbobea,

It depends on what chipset you have as the 5580 can come with either: Skylake vs. Kaby Lake.

Dell supports Windows 7 on Skylake

Dell has no support for Windows 7 on Kaby Lake

Which processor do you have?

If you have a Skylake system you need to make sure the following is true:

1. Boot mode set to UEFI

2. SATA operation set to AHCI

3. Legacy Options ROMs enable

4. Secure boot off

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


2 Bronze
2 Bronze
16123

Dear Justin,

I was wondering if you could help me with the following regarding the use of a Samsung SSD Pro 960 for my XPS 8920 systems.

It has been known for awhile in the Community that RAID must be set to boot Windows 10 from this SSD. If AHCI is on, the system refuses to boot.

I have also been able to boot using RAID, with the SSD being installed directly to the M2 slot on the motherboard. However, if I try to use a PCIE adapter with it (and plug in a PCIE x4 or x16 lane), boot failure happens, even in RAID mode. For a reason, the SSD is still detected in BIOS, but with the weird size 185275945GB, instead of 1024GB. Note that if I install the SSD to the M2 slot and use AHCI mode, the same problem happens. My BIOS is 1.0.8, which is the latest.

Is there anyway I can do to overcome this  issue? I am OK with RAID, but I really want to use the PCIE adapter for my Samsung SSD Pro 960 rather than the M2 slot.

Thank you.

2 Bronze
2 Bronze
16102

Hi all!

Please help me, I am stuck on a big problem from several days.

Here in the company where I work we have deployed about 100 Precision M5510 with internal M2 harddisk.

I need to create a full image (iso) of the hard disk as reference and also as complete backup in case of change hard disk. I will have to do this activity not only one times, but quite often.

We usually use Acronis2016 from a live USB. But on these machines is impossible to detect the hard disk M2.

We have tried all:

- Bios in legacy or UEFI

- SATA mode HCI, Raid, or even SATA disabled

How we can clone the hard disk of these machines?

We are really blocked on this...

Thanks a lot!

Moderator
16102

@LittleBear84,

Based on your note that the issue is happening on the firmware level, I think it's fairly safe to conclude that there's a firmware compatibility issue between that specific drive's firmware and the system's BIOS.

I would recommend a different drive, like Samsung PM951.

@Lordpba,

I'm afraid that question is beyond my scope but I did some searching. This may help you out:

kb.acronis.com/.../15791

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


2 Bronze
2 Bronze
16101

Hey Justin...running into an issue here.  We bought a couple of XPS 8920's with Win 10 Pro and NVMe Hynix PC300 drive that came with it (it also came with a 2TB SATA drive but I unplugged it) , the OS had a bunch of software on it (McAfee, other stuff) so I reinstalled Win10 from scratch, now to do this I had to change it from RAID to AHCI to get the Win 10 install to recognize the NVMe drive and it seemed to work fine (I never changed it back to RAID)

Today I updated the BIOS to 1.0.9 and now Windows won't load, I tried AHCI and RAID settings, neither work...UEFI and Secure boot are ON

It get's past the Dell logo and gets to a "Media Present State, Media found" but then just errors out saying No disk found or something...

What should I do?

Note the BIOS (even the updated one) looks super old with no mouse control

I tried restoring BIOS to the old version using the instructions below but Alt+F and Alt+B doesn't do anything

http://www.dell.com/support/article/us/en/19/sln245206/how-to-restore-the-bios--system-setup--defaults-on-a-dell-system?lang=en

UPDATE: I just reinstalled the OS (Still on AHCI), and then started to updated the Intel chipset and rebooted, that went fine and I got into Windows....I then tried to update the SSD driver and Intel Storage Adapter (through Dell's website) and it rebooted and now I am stuck again

UPDATE2: I think I figured out the issue....if you are reinstalling Win10 you HAVE to leave the settings to UEFI and RAID ON (I don't think it matters if SecureBoot is on or not), AHCI/Legacy will not work.

When you get to the Win10 install screen it won't find the NVMe disk but you can load the NVMe drivers through the link Justin mentioned above.  Once that is done it will finish the Win10 installation and you can safely update all the drivers (including BIOS to 1.0.9) and everything should work properly!

Moderator
16101

Greetings Etsrad1,

Keep in mind that in AHCI mode Windows is using stornvme driver, not IRST. I wouldn't recommend trying to update stornvme.

It seems like your reinstall media doesn't have the IRST driver on it. Here's what I would do:

1. Set the unit back to RAID on

2. Boot back up to the reinstall media and during the partition screen click 'load driver' The driver to load is listed below. I've shown it in extracted view for your convenience.

3. Load the driver then proceed to reinstall Windows

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=WTY4TP

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


2 Bronze
2 Bronze
16101

Hi, I have Dell 7577 with 256GB NVMe ssd but the write speed is slow 

this is my system info 

can anyone explain why in my system NVMe ssd is not under PCI Express x4 Bus , but the OP had it ?

2 Bronze
2 Bronze
16101

Seems to be very interesting

Moderator
16101

@Vikram0136,

Thank you for your question.

What is the number of lanes shown when you click on the actual drive itself, within HWiNFO?

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


2 Bronze
2 Bronze
16101

I have encountered the same problem that i couldn't see sdd in the list

refer the below screenshot:

www.mediafire.com/.../IMG_20171113_150633024.jpg

I have even tried the above things of irst files copied to bootable driver and this is the screenshot

www.mediafire.com/.../IMG_20171113_233741060_HDR.jpg

the new folder from the above picture has both irstorac files and also the rapid storage driver.exe file .

but whenever i click on load driver i gives me an error

refer the screenshot for the error:

www.mediafire.com/.../IMG_20171113_233752449_HDR.jpg

i have downloaded the os from microsoft official site

made bootable using rufus tool

System model : Alienware 17 R3

Processor:i7 6700k Skylake

Ssd: pm951 Samsung 1024GB

Hdd : Hitachi 1024GB

I even tried calling the technical support they have suggested me to change to ahci mode.could i use the raid mode in my laptop.if yes , please get back to me at<Email id removed>

Thanking you ,

Bhuvan

<Email id removed>

Latest Solutions
Top Contributor