2 Bronze

Dell Studio 1558 CPU upgrade problem, please help

Hi all,

I have a very strange problem concerning two Dell Studio 1558 laptops.

In summary the problem is the following - a Studio 1558 works normally with an i3 processor but doesn't boot with an i5 processor that worked on another Studio 1558 with the same motherboard (and pretty much the same of everything else). What follows is an explanation of all the testing that I did and the results I got.

The first laptop (i5 430M - 4GB ram - ATI Mobility Radeon HD 4570 - 500 GB disk - 720p screen) worked fine for about 6 years until one morning I turned it on, the keyboard and the fan were working but the screen was black, no POST, no life signs. I tested the screen with the self-test and it was working as expected.

After some research on the net, calling a local authorized Dell repair shop, and testing (swapping ram etc.) I concluded that the integrated video card (ATI Mobility Radeon HD 4570) was burned out.

As the card is integrated and can't be replaced, I decided to buy a replacement motherboard. Instead I bought another (working) Dell Studio 1558 locally as it was actually more expensive to buy the motherboard on eBay and have it shipped from abroad. The Dell I bought was i3 350M - 4GB ram - ATI Mobility Radeon HD 4570 - 500 GB disk - 1080p screen.The motherboard is supposed to be the same in both laptops, judging by the sticker tag next to the ram slots - CN-0CGY2Y.

As the board is the same I though that I can just swap the i3 for my old i5. The BIOS of both laptops was the latest version A12. I should also mention that some months ago I had upgraded the 4 GB (2x2GB) of ram on my i5 laptop to compatible 2x4 GB and it worked OK.

So me and my brother swapped the processors on the newly bought i3 laptop, put in the working 2x4 GB of ram and turned it on but we got 4 beeps - which indicates a memory read/write error. We took out the ram and got 2 beeps. We switched with the old ram, and the ram from the newly bought Dell - that didn't help, we had no beeps and black screen boot with 1 stick or 4 beeps with 2 sticks. We always tested the ram in the original combinations of two working sticks. Resetting the BIOS by pressing the power button with the CMOS battery out didn't seem to work either.

So we reverted back to the original configuration with the i3 and the laptop was working fine with the old 2x2 GB and the new 2x4 GB ram. So we hadn't done anything wrong to the motherboard.

After that we tested again with the i5 and the working motherboard and this time it gave a CMOS checksum error on POST asking us to press F1 to continue or F2 to save current configuration. So we pressed F2, saved the current config in the BIOS, which properly registered the i5 processor, and managed to log in to Windows 7.

Everything was fine until 15 minutes later when I got a "Page fault in nonpaged area" BSOD after which I rebooted and the laptop would again give 4 beeps on boot. It wouldn't start with the old ram from both laptops and the 2x4 GB. The pattern is always the same - if you insert just 1 stick in slot 1 you don't get any beeps but the laptop boots to a black screen and no POST. If you insert both sticks you get 4 beeps. After that if you replace the i5 with the i3, it shows the CMOS corrupted checksum message and if you press F2 it boots normally again.

I consider it unlikely that the i5 CPU is fried. We tested the motherboard from the i5 laptop with the i3 and it wasn't working - so the motherboard should be the problem as I concluded initially. And it is very unlikely that the board and the CPU burn out at the same time. And after all it booted to Windows once with the i5.

The laptop is working fine with the i3 and the 2x4 GB of ram. As there doesn't seem to be any hardware reason for this strange behavior I was wondering whether it has something to do with the BIOS. Maybe some Dell protection that prevents upgrades from i3 to i5 by the end user? Or some micro board revision preventing this upgrade?

I should note that the i3 laptop came with a Windows 7 license (which my i5 laptop didn't have) so I was wondering whether there might be some BIOS protection that detects mods to the system as the license is tied to one particular machine.

Can anyone help resolve this great mystery? Any help would be greatly appreciated! Thank you.

0 Kudos