AndyDeathstar
1 Copper

Dell Vostro 3560 Switchable graphics problem

I recently bought a Dell Vostro 3560, with a 1gb AMD Radeon HD 7670M discrete graphics card. I love Skyrim and bought this laptop to play it as my old HP wasn't up to the challenge. Unfortunately, Skyrim does not pick up the AMD card, only the intel one. So, I tried other games and to no avail. Tomb Raider, Dishonored, Trine... all of these are totally not playable. The only game I have been able to run well is Devil may Cry 5 (super smooth on ultra graphics). Why is this? I have read almost everything written about this issue, but I can't find a fix.

I have updated both graphics cards and bios from Dell website. I set the applications to run on the high performance graphics processor in the catalyst control centre. It still won't work.

This is unacceptable.

Specs:

Intel Core i7-3632QM (2.2GHz)
8192MB (2x4096) 1600MHz DDR3 Dual Channel
32GB SSDR mSATA Full Card + 1TB Serial ATA
AMD Radeon HD 7670M 1GB Discrete Graphic Card

Windows 7 64-bit

0 Kudos
1 Reply
Angiebr
1 Copper

RE: Dell Vostro 3560 Switchable graphics problem

I have the same problem with my 15R SE... The GPU just doesn't show on the option...i tried everything... please!!! Someone help...
I bought Tomb Raider Ultimate Edition, and i can't play it!!! Dammit!!!

0 Kudos