zantoshk
1 Copper

Dell XPS 13 (L321X, Early 2012) Touchpad suddenly stops working with new driver

Hello folks.

I have had this laptop for a while.  I found some forum posts about a problem from when I first bought this laptop, and I had resolved that problem by uninstalling the Dell provided Cypress drivers.

Recently, I found that there were newer drivers available from Dell.  Specifically, the newer drivers were released on April 10, 2014.  I installed them.

The drivers enable a number of nice features on this touchpad, including pinch to zoom, rotate and multitouch, but then the touchpad also suddenly stops working.  

Once I restart my laptop, it works once again, but then it'll stop working as suddenly as the first time.

I haven't figured out why it does this.  There's no indication of a failure or any indication of it turning itself off.

The driver I installed is Dell Touchpad Driver - Version 2.5.3.65, A07.  Below is the tray indicator, but it seems fine, even though the touchpad is presently not working.

Inline image 1

Below is the Dell application and I've already tried turning it off and on, with no effect.

Inline image 2

Below is a screenshot of my device manager, and it shows three devices.  One of them is my bluetooth mouse that I was not using earlier, but once the touchpad became unresponsive, I had to.

Inline image 3

Below is the cypress driver info.

Inline image 5

Does anyone have any clues on how to re-enable the touchpad once it stops working?  None of the methods I've tried so far works, and I have to restart my laptop to get the touchpad back.

Thanks.

0 Kudos