abitech
Not applicable

E6400 won't install Chipset drivers after rolling back from Win10

I rolled back from Windows 10 to Win 7 Pro SP1 and am now missing a bunch of drivers for devices that were working just fine before. I've installed chipset drivers from Dell and from Intel's sites, tried older versions, etc. When I run the installers, most tell me I'm currently running a newer version, but since nothing works, I've proceeded anyway. With the Dell-provided installers, the install starts and almost immediately finishes. From Intel, it looks to actually install, but I'm left with Device Manager full of missing drivers. I have installed the Dell System Software. (I know about the install order here, but can only do so much since some were left intact after the rollback.)

After hours of trying to uninstall, reinstall, etc., I'm left with three missing: 

  1. PCI Simple Communications Controller
  2. PCI Serial Port
  3. Microsoft Usbccid Smartcard Reader (WUDF)
  4. IDT High Def. Audio CODEC (which is odd since it was working until the Dell System Software was installed. It also says the driver installed is best, but gives errors that it doesn't work. Ugh.)

I've Run SFC /scannow in case of some corruption. I turn off virus protection when trying to install drivers. 

I'm baffled.

0 Kudos