melzisme
1 Copper

E6420 Boot loop after installing Windows 7 Pro

I recently bought a used Latitude E6420 laptop and did a clean install of Windows 7 Pro but it went into a boot loop after setting up username and time zone.

I tried both AHCI & RAID settings, non of them worked

I tested 32 bit version and i received the following error :

"windows setup could not configure windows to run on this computer's hardware"


so i used the oobe to force it to complete.

if i install the 64bit version, i won't get the error.. but both the versions ends up with the boot loop. I cant even press F8 at all.

i tried using Intel Rapid Storage Technology (Pre-OS Install) but it wouldn't  allow 64 bit unsigned drivers.

anyone else had similar issue before or knows the fix for this ?

0 Kudos
3 Replies

RE: E6420 Boot loop after installing Windows 7 Pro

Hi,

Thank you for writing to us!

This could be a hardware issue,

1- Complete format of the Hard drive and then check if you are able to install the operating system.

2- Run hardware diagnostics on the system.

3- Check if the system reboots in BIOS .

Kindly private message the service tag and email address.

Thanks

Robin

DELL-Robin D
Social Media Support
#IWork4Dell

0 Kudos
melzisme
1 Copper

RE: E6420 Boot loop after installing Windows 7 Pro

Hi Robin,

Here's what I've done.

I have 2 x units of E6420

1 Win 7 Pro 32 bit

1 Win 7 Pro 64 bit

both units of E6420 having the same issue.

Tried installation for both win 7 pro version 32/64 bit with & without SP1 slipstreamed.

For 32 bit. error appears, so i ran msoobe . As soon after it restarts, it went pass POST, as soon it reaches Windows startup it reboots.

for 64 bits version, no error with installation, able to get to OOBE then after restart, i have the same issue  where it keep rebooting after BIOS POST.

BIOS ver previously A03, and ive upgraded to A23.  same rebooting issue before and after upgrading BIOS firmware.

0 Kudos

RE: E6420 Boot loop after installing Windows 7 Pro

Hi,

In this case we would suggest you to run diagnostics on both the system. Alternatively we can you please check when you tap the F8 key on the systems does it come up with boot options and are you able to boot into safe mode on both the systems .

Kindly private message the service tag of both the system and let us know which one is on 32bit and 64 bit .

Thanks

Robin

DELL-Robin D
Social Media Support
#IWork4Dell

0 Kudos