evilguy
1 Copper

How to disable USB 3.0

Hi there, I have Alienware 15 laptop previous generation (bought in 07/2015). All devices that I am plugging in are working except mobile phones (iphones, android).
Unfortunately all usb ports are 3.0 and whenever I connect phone device it intermittently disconnects (usually 1-3 seconds period). I find out that there could be a bios configuration to disable usb 3.0, but alienware laptops doesn't have it. 

Solutions I've found in the internet:

  • Disable usb 3.0 in BIOS  can't as BIOS doesn't have that option
  • Disable Intel(R) USB 3.0 eXtensible Host Controller in Device Manager. Also didn't help, as it is disconnecting device fully. But some devices are working such as usb mouse.
  • Updated power options to Disable  for USB selective suspend setting. Didn't solve the problem
  • Tried to connect each of the port (4 ports available) and connect and restart.

I have tested windows 8.1 and 10, but when I had windows 7 it worked only before first restart and during that time my external HDD led was showing that it is working on usb2.0 configuration.

Note that I have connected same phones (iphone 4s, samsung s4, one plus 5) with same cables to other computers and they've work perfectly. (other computers with Windows 7,10, Lubuntu, Ubuntu, MacOS)

Just curios if any owners of Alienware 15" with Intel(R) Core(TM) i7-4720HQ Processor had any similar issues and resolved them.

Tags (2)
0 Kudos
1 Reply
dell-robert p
6 Gallium

RE: How to disable USB 3.0

Hi evilguy,

Thanks for posting.

Apologies that your computer is not working as expected.  You may wish to post your question in the Alienware Forum, as there will be more experts there who can respond.

0 Kudos