Highlighted
geforcefly
1 Copper

Inspiron 2650 BSOD during/after Windows XP setup

I have a Dell Inspiron 2650 laptop that I can't get XP to work for the life of me.

Configuration:

Pentium 4 Mobile 1.6GHz, 512MB RAM, 30GB hard drive, 14" display, DVD drive, 1.44MB floppy, A13 BIOS installed

 

I'm trying to install XP on this laptop and nothing seems to allow me to finish.  I've used FOUR different CDs and gotten four different BSODs:

XP Home SP1a Dell: BSOD after OOBE (where you enter user profile names, etc...) (Windows logon process terminated fatal error)

XP Home SP2 Dell: BSOD after OOBE (d0000001 Unknown Hard Error, Unknown Hard Error )

XP Home SP3 Dell: BSOD starting GUI setup (c0000145 BSOD, d0000001 Unknown Hard Error)

XP MCE SP2 Dell: BSOD after OOBE (blank Blue Screen)

 

I've tried multiple sticks of memory (which all pass in memtest86+), two good hard drives (a 20 and a 30), and also tried without the DVD and floppy drives installed.  Safe mode gives me the same BSODs as well.  In addition, using the Ultimate Boot CD for Windows version 3.5 build also BSODs with the same error as XP Home SP1a.  Furthermore, Ubuntu 9.04 and Linux Mint 7 will freeze on the first screen to begin setup before it really starts.  I don't have enough floppies to make a Dell Diagnostics set of floppies nor can I start Windows to install Dell Diagnostics onto the hidden partition.  The system is not overheating and the air vents for the CPU and GPU are clean and unobstructed.

However, Linux Mint 6 installs and works perfectly.

I'm running out of ideas.  Am I missing anything, or is this laptop destined to never work with XP?

0 Kudos