Laptops General - Read Only

Last reply by 03-03-2016 Solved
Start a Discussion
Not applicable
180164

Latitude E7440 and USB3 Hard drives

Hello. I've been searching around for an answer to this issue but to no avail. I've got one of the new Dell Ultrabooks; (Latitude E7440) and cannot get my USB3 portal hard drive to work with the USB3 ports. I've also got a new Dell E-Port Replicator (dock) with USB3 ports.

Example of the issue:

  • USB3 HDD plugged into any of the laptops USB3 ports - HDD powers up, but Windows does not detect the hard drive being plugged in.
  • USB3 HDD plugged into any of the docks USB3 ports - Same symptoms.
  • USB3 HDD plugged into any of the docks USB2 ports - HDD works fine but Windows reports that it could run faster (ie USB3 speeds)
  • USB3 Flash Drive plugged into any USB3 port - Works fine.
  • All USB2 devices work in all USB ports on the laptop and E-Port Replicator. 

Troubleshooting done:

  • Reinstalled USB3 Hub drivers from the Dell website
  • Tested my HDD on another PC (non Dell) works fine on USB3 ports.

Any ideas? I've Googled and find people with similar issues but no definitive solution.

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
2995

Hi ELPAICO,

Not sure if you ever found an answer to this? I've recently got the same laptop and i must say there are quite a few "power saving" options which are a pain - for example the way Windows disables Mobile Broadband ...

Regarding the USB issue - i had the same problem, what i found to fix the problem:

- From your Power Options -> USB Settings -> USB selective suspend -> Disable all 

- Use the USB port on the back right hand side of the laptop, when you are facing it (not sure why this works though)

Cheers,

Ig

View solution in original post

Replies (3)
2 Bronze
2 Bronze
2996

Hi ELPAICO,

Not sure if you ever found an answer to this? I've recently got the same laptop and i must say there are quite a few "power saving" options which are a pain - for example the way Windows disables Mobile Broadband ...

Regarding the USB issue - i had the same problem, what i found to fix the problem:

- From your Power Options -> USB Settings -> USB selective suspend -> Disable all 

- Use the USB port on the back right hand side of the laptop, when you are facing it (not sure why this works though)

Cheers,

Ig

2 Bronze
2 Bronze
2995

You could try this. 

(keywords: regedit devicehackflags)

www.thewindowsclub.com/usb-devices-not-working-windows

(keywords regedit enhancedPowerManagementEnabled)

2 Bronze
2 Bronze
2995

- Use the USB port on the back right hand side of the laptop, when you are facing it (not sure why this works though)

^^^ THIS ^^^

Both my laptop's USB ports are marked with the SS superspeed logo, but only the rear one seems to work as one, or at all.

Latest Solutions
Top Contributor