rjhart
2 Bronze

Permanently disable NVidia audio device

Basically my question is, does anyone know how to permanently disable the NVidia audio device on an XPS17 laptop?

Whenever it's enabled - or rather when specific audio devices (such as my TV or monitor) are enable, once my computer has been on long enough, I can no longer switch audio devices or open the windows sound properties. The only solution at this point is to reboot.

I have found that by disabling the external audio devices, it fixes the problem. But it re-enables them if I plug in an HDMI cable or something. I found a better solution was to disable the underlying system device - "High Definition Audio Controller" - which is the NVidia audio device. This works as long as windows is running and prevents it recognising any of the HDMI audio devices.

The problem is that as soon as I reboot windows, the device is enabled again. So does anyone know how to prevent it being re-enabled.

As for the original problem - I have all the latest drivers and (for other reasons) have reinstalled windows several times while I've had the laptop, nothing has fixed it.

System Information:

Device: XPS 17 (L702x)

OS: Windows 7 Ultimate Edition 64-bit

0 Kudos
9 Replies
DELL-Sandeep P
Moderator
Moderator

Re: Permanently disable NVidia audio device

Hi rjhart,

Welcome to the community.

I would like to inform you that I have done some research for this issue and below is the suggested solution I have found out which might be useful for you:

1.  go into device manager- go under display adapters go into your GTX 400 series Card and see what says for  

    location.. E.G. "PCI bus 18 "

2. go under system devices

3. you will see two HD audio devices.. check them both to see which one matches your GTX 400 series pci bus

   location.  disable (not uninstall) the one that matches your 400 series card.

4. check under sound devices and it should no longer be there (this step might or might not require a restart)    

 FOR SLI SYSTEMS THERE WILL BE AN HD SOUND DEVICE FOR EACH CARD  

I ALSO RECOMMEND UNINSTALLING THE SURROUND DRIVERS UNLESS OTHERWISE NEEDED AND CHANGING THE NVIDIA CONTROL PANEL TO "SINGLE DISPLAY PERFORMANCE MODE" (this will help with flickering)  AND SET TO MAXIMUM PERFORMANCE POWER MODE

 now if you want you can follow these proceedures to clean out your drivers) although you might not have to. but

it is a good idea to clean your drivers after this and steps 1-6 are a template on how to uninstall and reinstall display drivers.  GOOD LUCK TO ALL OF YOU AND  I HOPE THIS HELPS

1. Download Driver Sweeper and driver cleaner and install them.  mainly need driver  google them. also down load the latest audio drivers from evga and the latest Nvidia drivers straight from Nvidia.  

2. boot up GO INTO PROGRAMS AND FEATURES IN CONTROL PANEL. Uninstall Nvidia Physx and Nvidia surround driver.  DO NOT UNINSTALL NVIDIA DRIVERS ON NVIDIA CONTROL PANEL YET.

3. Reboot. Go into safe mode (press F8 repeatedly upon power up)

4. While in SafeMode go into program and features now selected Nvidia Drivers then uninstall them. it will then ask you to reboot the computer DO NOT REBOOT YET SELECT NO.  

5.  While still in safemode open Driversweeper select nvidia display and click analyze. when it is done click on clean.  Then open driver cleaner. click on the box that says "use multiple filters" the select Nvidia, Nvida wdm and nvidia stereo.

6. Once you have finished with driver sweeper and driver cleaner reboot back in to regular mode. open device manager and check to see if your display adapter reads "Generic video adapter" or something along those lines and that it is a microsoft driver.  then check your sound drivers to make sure that All 4 Nvidia soundrivers are uninstalled. Once you have verified that all the nvidia drivers are uninstalled REBOOT INTO SAFEMODE.  

7.  WHILE IN SAFEMODE.  Go into open programs and see if there is anything labeled Realtek audio drivers if there is uninstall that. DO NOT REBOOT YET.  Open device manager and go to sound devices and select any remaining audio devices and uninstall them. then open driver sweeper and clean out the left over files. After using driver sweeper you can now Reboot into regular mode.  

8.  After reboot open up device manager and make sure that all the drivers you uninstalled and cleaned out were replaced by Generic Microsoft Drivers.  Then install The nvidia display drivers and disable windows automatic updates.  Now reboot.

9. after you reboot go into device manager and DISABLE the 4 nvidia sound driver the REBOOT BACK INTO SAFEMODE.  Once you are back in safemode open up device manager and uninstall the Nvidia sound drivers.  if they won't uninstall then make sure they are disabled in safemode.  Reboot

10. Now install or reinstall your onboard audio drivers then reboot.

If you have any further queries please feel free to contact us.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
rjhart
2 Bronze

Re: Permanently disable NVidia audio device

Thanks - that's actually the advice that led me to this fix. But the problem is that it doesn't remain disabled on a reboot. I haven't removed the drivers yet, but I can't see how that would affect whether it's disabled or not (I wouldn't have thought a driver would have the authority to re-enable a disabled device).

0 Kudos
DELL-Sandeep P
Moderator
Moderator

Re: Permanently disable NVidia audio device

Hi rjhart,

I appreciate the time and effort that you took to troubleshoot the issue. I understand that a device should not get enabled on a restart when it is set to disable under device manager.

It could be an issue with the Windows itself and instead of re installing the windows we would advise you can try and remove the driver and then check if that is successful for you.

If you have any further queries please feel free to contact us.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
rjhart
2 Bronze

Re: Permanently disable NVidia audio device

Well I asked Microsoft, and of course they told me to take it up with NVidia.

I have implemented a work around - I have placed a script in the startup folder which disables the device using devcon.

It's slightly annoying that I need to use a work around, but it seem to work without causing any issues so it'll do.

0 Kudos
DELL-Sandeep P
Moderator
Moderator

Re: Permanently disable NVidia audio device

Hi rjhart,

Its great to hear that you have develop a workaround till the Nvidia comes up with a resolution. Kindly share the script with us so other customers can also benefit from the same.

We truly appreciate the patience and cooperation that you have shown in this regards.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
rjhart
2 Bronze

Re: Permanently disable NVidia audio device

Note that this only works if any problems don't occur during startup.

1) the devcon utility is needed. If you're running Windows 7, you need to follow the answer at:

answers.microsoft.com/.../9abcc12c-d7db-4249-aec4-fc4ff0ea6ee8

2) Find the hardware ID of the device required

I just ran "devcon /hwids * > C:\hwids.txt", then looked through the output file for the device identified as in the first response to this thread. In my case:

PCI\VEN_10DE&DEV_0BEE&SUBSYS_05711028&REV_A1\4&4DCA75F&0&0108

   Name: High Definition Audio Controller

   Hardware IDs:

       PCI\VEN_10DE&DEV_0BEE&SUBSYS_05711028&REV_A1

       PCI\VEN_10DE&DEV_0BEE&SUBSYS_05711028

       PCI\VEN_10DE&DEV_0BEE&CC_040300

       PCI\VEN_10DE&DEV_0BEE&CC_0403

   Compatible IDs:

       PCI\VEN_10DE&DEV_0BEE&REV_A1

       PCI\VEN_10DE&DEV_0BEE

       PCI\VEN_10DE&CC_040300

       PCI\VEN_10DE&CC_0403

       PCI\VEN_10DE

       PCI\CC_040300

       PCI\CC_0403

3) Then using the ID from that, create a batch file in the startup directory disabling the device:

devcon disable "PCI\VEN_10DE&DEV_0BEE&SUBSYS_05711028&REV_A1*"

And that's it. This is very much a work around, not a solution, but it does the trick for me. Luckily I don't want to actually use the HDMI Audio!

0 Kudos
DELL-Sandeep P
Moderator
Moderator

Re: Permanently disable NVidia audio device

Hi rjhart,

Thanks alot for sharing this information with us. I am sure alot of other customers facing the similar issue would benefit from the same.

We truly appreciate the patience and cooperation that you have shown in this regards. If you have any further queries please feel free to contact us. 

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
ro2207
2 Bronze

RE: Permanently disable NVidia audio device

Good day, I've tried following the steps outlined above and created the.bat file that disables my particular hardware (I used hw id with devcon to make sure). Upon start up, the CMD black screen pops and instructs devcon to disable my "High def audio device". The command is processed and the screen closes but the device is not disabled. It seems devcon tries to disable it before it gets re-enabled by windows upon startup, so I still end up whith UAA High def audio enabled on device manager.If I manually run the command it gets disabled, but I want it to work automatically upon start up. Any ideas? Thanks a lot.

0 Kudos
rjhart
2 Bronze

RE: Permanently disable NVidia audio device

Hi,

I've actually since upgraded to Windows 8 and that's solved the problem I was having.

But my suggestion would be one of the following:

- Output the batch file output to a text file to make sure there are no errors.

- You might be able to use Devcon to determine the current status, and not disable it until it's been enabled.

If I get some time, I'll get devcon again and see if I can come up with something.

0 Kudos