jojo2050
1 Copper

Problem with installing m2 PCIe NVME on Precision 5510

I recently bought a Precision 5510 and it comes with 125GB m2 ssd and wondows 10.  So I decided to upgrade to a bigger capacity of hard drive.  So I bought a 512GB m2 PCIe NVME Toshiba XG3 THNSN5512GPU7.  But after I installed it, the laptop won't recognition it as NVME but regular SSD.  I want to use it as its full potential.  Please help.

0 Kudos
8 Replies
9 Rhodium

RE: Problem with installing m2 PCIe NVME on Precision 5510

Did you replace the existing drive, or add a second?

0 Kudos
jojo2050
1 Copper

RE: Problem with installing m2 PCIe NVME on Precision 5510

I replaced the existing drive since there is only 1 m2 slot.

0 Kudos
jdrodrig
1 Nickel

RE: Problem with installing m2 PCIe NVME on Precision 5510

have you tried reinstalling the Intel Rapid Storage Technology?

0 Kudos
jojo2050
1 Copper

RE: Problem with installing m2 PCIe NVME on Precision 5510

I uninstalled it from device manager.  It restarted the windows.  I went back to device manager it shows intel 100 series/c230 chipset family sata ahci controller under IDE ATA/ATAP controller.  Is that what you mean by reinstalling?

0 Kudos
jdrodrig
1 Nickel

RE: Problem with installing m2 PCIe NVME on Precision 5510

sorry if I gave you fake hopes. I just got my 5510 and I remember than somehow in a systeminfo panel I saw a table that had a green dot next to drives using Intel Storage Technology and I thought it would be it. my has an NVME and I just installed a 2.5 SSD in the empty bay.

in some machines there is a bios setting on AHCI to let the computer know is a high speed disk. what options you see in BIOS? maybe just for kicks, reinstall the latest BIOS.

0 Kudos
jdrodrig
1 Nickel

RE: Problem with installing m2 PCIe NVME on Precision 5510

but even more obvious; if you just bought it, you have warranty/support, what does tech support says?

0 Kudos
jdrodrig
1 Nickel

RE: Problem with installing m2 PCIe NVME on Precision 5510

0 Kudos