1 Copper

USB ports not connecting to devices Inspiron 17R SE 7720

I have a Dell Inspiron 17R SE 7720 laptop and all of a sudden last night the USB ports stopped functioning correctly. This problem has occurred before however it usually fixes itself overnight or when I do a reboot. I tried two USB devices (the only two I use regularly), my iPhone and a portable WD Elements hard drive. When I connected the iPhone it started charging as normally suggesting it was still receiving power from the USB port however it did not show up in iTunes or anywhere else on the system (including the Device Manager) in any form (including as an iPhone or as an imaging device etc.) . When I connected my hard drive a similar thing happened, the light would go on and it would power up however it would not show up on the system.

I have tried rebooting, checking for updated drivers, reinstalling the drivers and booting in safe mode to no avail, I have googled for some time however a large majority of online solutions recommend going to Device Manager to find the devices I am connecting however they are not there. I have also tried Dell update and troubleshooting software which did fix something (one of the things it mentioned was device changes not detected and something not installed properly, forgive me for this I did it a while ago). None of this has solved the problem however.

0 Kudos