Highlighted
keilo123
1 Copper

XPS 13 9350 Touch Screen Not working

Hi all,

I have an XPS13 9350 which I purchased in July 2014.  It's an i7 processor and was bought with touchscreen.

For some months I had not used the touch screen until a few weeks ago.  However, when I tried to use the touch screen I found it no longer worked.  On investigation I found that Dell diagnostics didn't even recognise that I had a touch screen.

I have done extensive research online but have found no solution.  I have tried the HID power management process to no avail.  In control panel I have no Pen and Touch icons so I assume Windows cannot see the touch screen either.

I have read that this issue is related to Windows 10 so it shows that it must be over a year since I last tried to use the touch screen.  Obviously I don't use it a lot but it is annoying that the laptop is not working as specified.

Is anyone able to help?

0 Kudos
1 Reply
Moderator
Moderator

RE: XPS 13 9350 Touch Screen Not working

Thank you for posting your query here.


This could be an OS or hardware issue


·        Has the touchscreen worked after Windows 10 upgrade?

·        Open device manager and expand HID complaint & check if there is any red X or an exclamation right click on the driver & click uninstall

·        Please update the chipset driver & bios by entering your service tag here http://dell.to/1SZoqSB

·        Restart the computer & make sure all windows updates are completed. 

·        If the issue persists, try doing a Windows reset by following this link http://dell.to/2eRB6zG , please back up your data before resetting.

Dell-SreejithR
Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Would you like to be a Dell Community Rockstar?

0 Kudos