Latitude

Last reply by 11-04-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Lattitude 5590 Sleep problems

I have a brand new Lattitude 5590 that goes into sleep mode at various times. Sometimes it wakes up but more times than not it does not.  I touch the keypad and the back light comes on or I touch the power/sleep button and it lights up.  The only way to get it back on is to hold the sleep/power down for 5 seconds to force a reboot.  NOT COOL!!!  Has latest BIOS and drivers.  Running Win 10 pro 64 bit.  If I put it into sleep mode with the button, it will not wake up either. 

Replies (47)

You are a lifesaver.  I've been fighting this issue in my organization for some time.  Even had some of the laptops MOBO replaced.  Some worked and some didn't.  I've had the latest and greatest drivers and BIOS updates installed.  But the driver that you posted (even tho technically a downgrade) fixed the issue for me on all the effected machines.  Very grateful to you! 

Reverting back to this driver still works 10/25/2021. These laptops are less than impressive.

2 Bronze
2 Bronze

I suppose this bug is related to default Intel driver which is installed with Windows or updated by Windows Update service. After updating the Intel driver from Dell support website everything looks fine.

2 Bronze
2 Bronze

An old Intel video driver solved my problem.

I have same symptoms - power button does not light but the CPU gets increasingly hot if I connect the battery, AC power, or USB-C power. I have the latest BIOS, drivers, etc. It might be ~3yrs old but system looks and was running like new with plenty of RAM and M.2. I tried the power+"M key" - no result. Tried all variations of removing power (including BIOS), clearing flea power, and re-applying.

Don't want to waste time/$ on a MB if that will not solve.
Did you find a solution for this condition?


Thx

2020 and DELL doesn't fix this bug, ¿why we should stick to the past with this old driver?

Also you should disable automatic driver update in Windows 10 itself otherwise it will download the buggy new driver. The setting is in Control Panel/System/Advanced system settings/Hardware/Device Installation Settings/No

Intel UHD 620 Manual Driver Update.png

Thanks for the post. I was able to resolve the problem. A couple things to note though, as of today when I downloaded the file, when tying to install it, it'll give you 2 options "Install" or "Extract". So 7zip is not needed for the extraction. Also you should disable the automatic updates before uninstalling and trying to manually update. If not, you'll be met with the following error:

"Windows encountered a problem installing the drivers for your device

Windows found drivers for your device but encountered an error while attempting to install them

This device is not configured correctly. (Code 1)

If you know the manufacturer of your device, you can visit their website and check their support section for drivers."

 

Cheers guys!

Big kudos to @Marcin78 with the tip to use an old version of the UHD graphics driver. This solved the problem for me. My organization has almost 1,000 Latitude 5490 / 5590s, and we get this problem on 1-2% of them.

To expand on what Marcin78 said, here's the procedure we are using now:

First, just try installing the latest updates of the video driver and BIOS on the affected device. If this fixes the problem--great! But if not, then:

Open Device Manager to see if the device is using the "HD" or "UHD" version of the Intel graphics driver. Per Marcin's post, if it's "UHD" use the 26.20.100.6888 A14 driver, which is available for download here: https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=977fv

If it's the HD driver, another commenter mentions luck with the 24.20.100.6170 A06 driver, available here: https://www.dell.com/support/home/en-us/drivers/driversdetails?driverId=GG5FR -- I haven't had a chance to verify this in my environment yet.

Run the installer. If it installs--great! Open Device Manager to verify the driver is now running the above version. I, however, got an error from the installer: "This computer does not meet the minimum requirements for installing the software". If you read through the log file, you'll see the specific error: "Package is Legacy. Install not allowed because UWD is installed". The workaround for this is detailed by @Cyber_Knight in another forum post. Instead of running the installer, you'll need to extract the files out of the installer (I used 7-zip for this) and then go to Device Manager, go to the Driver tab, and choose "Update Driver" and browse to the files you extracted. (You do not then have to also run the .exe installer as Cyber_Knight says. In fact, when I did so, it messed up the installed version.)

I've only done this once so far. I'm not sure if this is necessary, but if you have any problem with the "Update Driver" step, you may have to first uninstall the driver, then "Scan for hardware changes" to get the "Display" node to come back in Device Manager, and then "Update Driver".

Also--I'd recommend turning off automatic updates if you have Dell Command Update installed so that it doesn't overwrite your work above with new releases of the video driver.

2 Bronze
2 Bronze

Solved! In my Latitude 5590 this sleep problem was related to Intel UHD Graphics 620 driver. Downgrade from 26.20.100.7262 to 26.20.100.6888 completly solved this issue.

Top Contributor
Latest Solutions