Highlighted
2 Bronze

SupportAssist 3.4.5 don't work!

Jump to solution

Hello 🙂

I'm Max from Sanremo (Imperia) - ITALY.

I've a Latitude E6430 and I'm very happy with this laptop ...but SupportAssist hasn't worked since the last update (v. 3.4.5 on Windows 1909 PRO).

I've tried to unistall SA, delete all keys and reisntall SA more than once ...but nothing to do ...SA v. 3.4.5 it no longer works!

Could it be that laptop it's out of warranty, or SA it does still work?

For the rest, my pc works wonderfully.

Many thanks for the help that you can give me ...and ...excuse me for my not perfect English 😥.

Greetings, Max 😉

   

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Hi Lsufan51.

I haven't tried to install SA v. 3.4.5 from several weeks. ... the PC it has been clean for some time, both for the keys and for the services that are activated by this utility.

As soon as I can, work permitting, I'll bring with this latest release of SA and refer here.

Thanks, Max

View solution in original post

Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

EUREKA ...😀!!

This version of SA (3.5.0), recommended by the friend LSUFAN51, it's finally WORKS!

In 8 minutes about, I've managed to scan the whole PC ... I'm happy to still have this utility ...  thanks again guys for your punctual support. ..Max 😉

View solution in original post

0 Kudos
24 Replies
Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Anyone who can give me some advice? 😐

0 Kudos
Highlighted
5 Iridium

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Please check Dell rep solution in link below,  hopefully it will be a help to you.

Installation of SupportAssist does not end

https://www.dell.com/community/SupportAssist-for-PCs/Installation-of-SupportAssist-does-not-end/td-p...

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Many thanks LSUFAN51 ...

I've followed all the uninstallation procedure for SA > I've donwnloaded again Support.Assist.Installer.exe > reinstalled SA with administrator's privilege ...but SA 3.4.5 it doesn't load the PC's optimization tools as before 😞

Do you have any idea what it could be? 😯

Thanks again, Max 😉

 

 

0 Kudos
Highlighted
5 Iridium

Re: SupportAssist 3.4.5 don't work!

Jump to solution

I've received your email....

Support Assist doesn't work on any of my computers as well. Here're some of the things I've tried to get Support Assist to run again:

1. Uninstalled Support Assist using Revo Uninstaller and deleted all the leftover Support Assist registry

Fix Dell Support Assist Not Working, Support Assist Hardware Scan Not Working

https://youtu.be/dvIUNTTJUHA

2. Ran a Support Assist clean installed.

Dell Support Assist Not Installing (Official Dell Tech Support):

https://youtu.be/oHS2HvOoarc

3. Support Assist in the Compatibility Mode (windows 8 and 7)

Make older apps or programs compatible with Windows 10

https://support.microsoft.com/en-us/help/15078/windows-10-make-older-apps-or-programs-compatible

None of above work. I then check Event Viewer to see if there's an error on Support Assist. To get into the event viewer screen; Type Event Viewer onto search box, select windows logs.

This is what I've seen in event viewer screen:

Windows Installer install an update. Product Name: Dell Support Assist. Product Version 3.4.5: Dell Support Assist Installation success. Error status 0

I believe there's nothing wrong with Support Assist installation. This is on Dell's end. Give it a few days or week to see if Support Assist will run again.

Capture.PNG

 

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Thanks a lot Lsufan51!

The unistallation procedures, that you've kindly listed, I've tried them all ...before I've writing again on this forum 😕

I'm afraid that my laptop it's too old for this SA release ...since before the update to v. 3.4.5 tha SA utility it worked fine ...😐

Thanks again for your availability ...my laptop works well even without SA ...I'll make a reason for it.

Best regards, Max 😉

0 Kudos
Highlighted
1 Copper

Re: SupportAssist 3.4.5 don't work!

Jump to solution

From what I've seen, it is all older laptops that do not work with SupportAssist 3.4.5.  My E6540 also just gets stuck at "Loading PC optimization tools" if the SupportAssist service is running.  If it's not running then the loading message changes to the next procession of still loading, wait as we set it up, then eventually to there was an error, please restart and try again.  So, it seems that the issue that gets stuck is the service itself, since the app keeps trying to load when the service isn't running then at least quits with a failure message.  With the service running it's a perpetual loading screen.  SupportAssist works on my other machines such as my E7450 and E7470.  Doing all the instructions for the clean uninstall and reinstall just brings me back to the same issue.  The app just doesn't appear to be compatible, so maybe it's Dell's way of being Apple and trying to force upgrades of perfectly working devices by removing service options?  Can we expect an update to SupportAssist to address this issue that seems to be affecting many?

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Thanks prcappy 🙂

I've think at this probability too, because a similar thing it's also happens with the old Android smartphones ...🤔
the manufacturers no longer provide updates to the s.o. and we're practically forced to replace the device.


Luckily my E6430 it works perfectly and there are utilities, like CCleaner, that can help keep it in perfect working order.


I will do without S.A.as I wrote, ... too bad ... it was a very useful Dell's tool. 😐

Thanks for your reply, Max 😉

0 Kudos
Highlighted
1 Copper

Re: SupportAssist 3.4.5 don't work!

Jump to solution

I finally have it working!  Thanks to Vinod for the instructions below.  It looks like the regedit step is where my issue was, so be careful if following these but in my case this did the trick.  The instructions I received I'm quoting below.  I also made sure that the Dell SupportAssist, Data Vault and Hardware Assist services were stopped before the uninstall.  I made sure I did both an uninstall from Control Panel as well as from Settings > Apps to remove both the Windows Store and downloaded updates.  Then I removed all SupportAssist folders from Program Files and ProgramData.

"The SupportAssist window must not be open on the system.
There should be no pending SupportAssist notifications in the Windows Action Center or on the taskbar.
Steps
Click Start, go to Control panel > Programs, and then click Programs and Features.
The Uninstall or change a program page is displayed.
Right-click Dell SupportAssist, and click Uninstall.
When you are prompted to confirm the uninstallation, click Yes.

and As well as remove from Regedit>>Type win+r key Run>.Type Regedit Search  SupportAssist> Select and Delete after restart systems then Check "

Hope this helps someone!

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.4.5 don't work!

Jump to solution

Thank you prcappy ... but I've already done the whole installation procedure several times > deleted all keys and reference > installed SA again (v. 3.4.5) but nothing to do 😣

I think that (my simply opinion) I could still benefit from SA only installing an earlier version than 3.4.5, but unfortunately ...it's not found!

Thanks anyway

0 Kudos