Latitude

Last reply by 08-04-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
115249

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (383)
2 Bronze
2 Bronze
579

I had the same issue with a work laptop (Latitude 7420) and the WD19TB.  The wired connection would work for 10m or less then drop.  I updated the drivers, BIOS, etc., etc.  I spent a lot of time thinking it was the Thunderbolt driver. Nothing worked.

What appears to have solved it for me was rolling back to an older version of the Realtek USB GbE driver.  The version I'm now using that works is 10.47.0818.2021.

Good luck everyone, this has been a very frustrating issue that my company's tech support wasn't able to resolve either.

1029

Hello! I have a 7420 and a WD19S (all fully updated via dell command update) and have been seeing the same drops out of the network after the machine was going to sleep... not everytime but often. A full shutdown of the pc would be required to get the WD19S 's network to be recognised in windows (unplugging/plugging back in the WD19 doesn't work).

However I recently just found a workaround... I also have a DA300 USB-C network adapter which I believe uses the same network drivers.. if you remove the WD19, then plug in the DA300.. (no need to plug the network into the DA300)... remove the DA300 and then plug the WD19 back in windows recognises the network connection. I guess the plugging in of the DA300 reinitialises the drivers ??

Perhaps a person cleverer than me knows a command line code to kill and reload the drivers ?

1828

Correct we are seeing the same issues in our company, reboot is the only workaround to get in working again, I think this a how Windows sleep impacts the thunderbolt controller maybe. for whatever reason USB  Realtek ethernet will not wake up until a reboot of the OS. In my opinion due to the power states in laptops something isn't talking back to wake up a the ethernet on the dock. 

We are seeing these errors in like Windows will not retry the connection till a reboot/shutdown

 

Log error after sleepLog error after sleep

https://superuser.com/questions/1644353/what-is-the-nhi-event-source-and-its-event-id-1-in-the-micro... 

https://docs.microsoft.com/en-us/windows-hardware/drivers/kernel/introduction-to-the-directed-power-... 

1907

Unplugging and plugging back in didn't change anything. Still showed error code in Device Manager.
Restarting helps, until next time
Nowhere in the specs sheet WD19S has thunderbolt support mentioned, only USB type C. But the symptoms are just as described.

2 Bronze
2 Bronze
1914

There might be more to this now, this was just recently published by Microsoft so this maybe more Windows or at least MS knows something about it a bit - https://docs.microsoft.com/en-us/troubleshoot/windows-client/deployment/devices-connected-via-thunde... 

Basically disconnect it and plug it back in or Reboot 

 

10 Diamond
2007

@JeffCKF  Suit yourself...

Ron

   Forum Member since 2004
   I'm not a Dell employee

2008

@RoHe I would prefer that Dell/Realtek simply fix the issue and let me complain about it until they do

Our network is all Unifi for what it's worth. Interested to hear if that's the case for anyone else with this issue.

 

 

10 Diamond
2014

@JeffCKF - You could use the Windows Group Policy Editor to block driver updates (blocks all driver updates) pushed via Windows Update, and disable/uninstall Dell Command Update, at least until this gets resolved.

Ron

   Forum Member since 2004
   I'm not a Dell employee

2022

We have spend well over $100k in the last 2 years upgrading to Dell laptops with the WD19TB (and now WD19TBS) dock. This issue has absolutely killed us lately. It doesn't matter what we change on the driver settings, we still get random disconnects. We were able to deploy an old driver (Realtek - 12/16/2019 - v10.37.1216.2019) to every single computer pretty easily to resolve this problem, but computers keep updating to the new driver via Windows or Dell Command Update and the problem becomes a whack-a-mole issue essentially every day.

Dell needs to do something about this, dangit.

2099

When is Dell going to fix this? I have tried suggestions here and nothing changed
Currently testing 04 Jul 2022 firmware and 23 May 2022 NIC driver. Sadly, didn't find a changelog.

Latest Solutions
Top Contributor