Linux Developer Systems

Last reply by 11-29-2016 Unsolved
Start a Discussion
2 Bronze
2 Bronze

3 finger tap middle button stopped working (XPS 13 9350 - 14.04)

Following the latest 14.04 HWE update that brought the 4.4.0 kernel update I can't get the trackpad on my XPS 13 9350 to recognise a 3 finger tap as the middle button.

I've tried running synclient TapButton3=2 which was what was needed to enable it before but no joy.

I do a lot of work on the command line and I'm really missing the double click to copy, 3 finger tap to paste.

I realise that most of the dkms extra modules are locked to only build for the 3.19.0 kernel and a most of them where probably backports from the upstream kernel anyway, but is there a timeline on when we can get a update to the OME packages to fix this?


Replies (6)
Not applicable

I suspect it might be the same problem as with ubuntu 16.04

What is your output of



2 Bronze
2 Bronze

⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                            id=10    [slave  pointer  (2)]
⎜   ↳ DLL0704:01 06CB:76AE Touchpad               id=12    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=14    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                        id=11    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=13    [slave  keyboard (3)]
    ↳ Intel HID event filter                      id=15    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                            id=16    [slave  keyboard (3)]

I'm also really missing 3 finger tap to open in new tab....

Not applicable

yeah, this is what I thought. See, you have two devices for only one touchpad:

DLL0704:01 06CB:76AE Touchpad


SynPS/2 Synaptics TouchPad

I have already reported this bug but it's still there.

The solution is to disable the second one. You need to create a file /etc/X11/xorg.conf.d/51-synaptics.conf
Here are the steps:

cd /etc/X11
sudo mkdir xorg.conf.d
cd xorg.conf.d/
sudo emacs 51-synaptics.conf

(replace "emacs" by you favorite editor) and then paste into the editor

Section "InputClass"
Identifier "touchpad ignore SynPS/2 Synaptics duplicate"
MatchProduct "SynPS/2 Synaptics TouchPad"
Option "Ignore" "on"

and restart

2 Bronze
2 Bronze

Cool, that works, my productivity is restored, and there is significantly less swearing going on round here.

Do you have a link to the bug?

Not applicable

I'm glad it worked for you as well.

Here is the bug report:

2 Bronze
2 Bronze

THANK YOU!  For 2 things.  

 1.  The solution.  Lets hope it works.

2.  Posting a clear series of commands to cut and paste to actually implement the darn thing!  

So often you get solutions that read like "I just blurbled the xfig files using the diddly-daemon" and your average idot (me) has absolutely no clue how to replicate.  I can work through terminal and GEDIT, but I try hard not to.

So thank you for making the Linux world a friendlier place.   

Latest Solutions
Top Contributor