Linux Developer Systems

Last reply by 08-30-2013 Unsolved
Start a Discussion
2 Bronze
2 Bronze
316219

New XPS 13 Ivy Bridge w Ubuntu 12.04 - no stable wireless

Hello,

I just received a brand new XPS 13 with Ivy Bridge chipset. I directly installed the 12.04 version on it and went to work... for about 3 minutes and then, the wifi dropped. I had to reboot to bring it back and it fails after few minutes... all the time.

I tried adding the sputnik ppa and update as well as many other workaround found on the various ubuntu forums. No can do and right now, I am quite frustrated.

My plan for tomorrow is to upgrade to 12.10 with the 3.5+ kernel. I have not found any post about this particular problem on this version. The problem seems to originate from the Centrino Advanced N 6235 network card driver which might have been updated in 12.10.

What is exactly going on with this problem?? Is there a new driver or a fixed driver in the pipeline? Have you heard about problems with 12.10?

Thanks for your support,

Jacques

Replies (110)
2 Bronze
2 Bronze
1190

Neeraj,

Happy to hear from somebody although I'll be really happy when this situation will be resolved.

I talked too early in my last post and the connection on the DLink WBR started dropping like it was with the Cisco LinkSys. Just to make sure, I purchased a DLink N750 Dual band router and tried it with no more success.

In case this could help you, I got better results when using WPA-Personnal (instead of WPA2) with TKIP encryption and b/g band exclusively on both router and XPS (disable n band).

I will try your configuration and let you know my observations.

Kind of very frustrating to have a nice piece of equipment such as the XPS and struggle that much on a basic and absolute dependency like networking.

Talk to you later,

Jacques

2 Bronze
2 Bronze
1192

Did you use the standard Ubuntu 12.04 build or did you use the Sputnik Ubuntu 12.04 build? Just wondering if that would make a difference?

2 Bronze
2 Bronze
1192

Since the sputnik image is not supported, I used the standard build and then, added the sputnik ppa to update and install the fix for wifi, brightness and trackpad. But this did not work obviously.

I then decided to freshly install 12.10 since the kernel is based on 3.5 instead of 3.2 which seem to be very unstable for wireless applications. This improved my situation noticebly but I still keep loosing connection intermittently for no apparent reason.

I will post any significant findings as I go along.

J

2 Bronze
2 Bronze
1192

Hi  ledj0304,

On my non-Dell laptop (centrino chip) I started experiencing similar wifi connection problems since around Intrepid. I was using an old MSI router and funnily enough my wife who uses an apple had also been battling with wifi issues for some time too. After pulling my hair out with wifi issues over several subsequent linux releases I finally replaced my MSI router with a Netgear N300 and lo and behold both my ubuntu wireless issues and my wife's apple wireless issues disappeared forever.

The MSI router never had any problems when connecting from Windows machines (though these machines did have different wifi hardware, which may have been a factor).

I've since resolved that certain wifi hardware doesn't play well with certain wifi routers under ubuntu and apple and when I have problems in future I'll look at the wifi router first to try and resolve my issues.

Not overly helpful I'm sure but posted anyway just in case someone does finds this useful

2 Bronze
2 Bronze
1192

Hi mohudu,

I did not post for awhile but the problem, in my case, is a hardware problem and Dell, gracefully offered to replace the PC all together. I should receive the new unit next week and, hopefully, this problem will vanish.

I understand that, in your case, the router was the culprit but it definitively is not in mine. I have 3 different wifi routers D-Link WBR, D-Link D625 and Cisco linkSys EA3500 and the problem persists with all three of them. And during that time, my Android phone connection remains rock solid in the same conditions.

Anyway, I will recap the whole story as soon as I have evidence that the new unit will solve the problem.

Thanks for your post as it might be helpful for somebody else.

Cheers,

Jacques

2 Bronze
2 Bronze
1192

Any update since getting the replacement? I have the same problem. I bought the XPS 13 w/ windows 8 installed so I could have 8 and an Ubuntu build. Installed Ubuntu 12.04.1 lts network card not stable. Installed Official Dell Sputnik Ubuntu 12.04 lts and the network card is unstable. Going to process a return.
2 Bronze
2 Bronze
1192

Hello Statik1909,

The new XPS has been shipped and I shall receive it thursday according to tracking. I will post updates next week.

J

2 Bronze
2 Bronze
1192

I think this is possibly my issue

bugs.launchpad.net/.../901410

Possible fix is to add the PPA to repo and updating

launchpad.net/.../sputnik-kernel

Testing this tonight

2 Bronze
2 Bronze
1192

I received a new replacement XPS and did some relatively good testing with it. The good news is that the wifi seems to work on all b,g and n band. The bad news is that there are many Fn keys that simply do not work even though I added the canonical untrusted sputnik kernel ppa and did all the recommended updates. So now, I have 1 XPS that works very well except for the wifi and one XPS that has a working wifi but all sorts of other problems which renders it more useless than the first one.

It's sad because I just love this ultrabook and really want to make this work.

This is really deceiving.

Jacques

2 Bronze
2 Bronze
1192

I'm having this same problem.  I'm on an enterprise wireless network, HP access points.  Seems like when the WPA/WPA2 rekeys or something the connection drops and it takes a reboot to get it back.  I'll look at the PPA above and see if it helps...

Latest Solutions
Top Contributor